8.0.3 not updating changes? WORKAROUND


(John Scrip / MASSIVE Mastering LLC) #1

Made changes to pages in 8.0.3 and published. Refreshed browser and nothing changed. Changed to “preview” mode in RW - and nothing changed (!!!???) but changes still there in edit mode.

Closed the program - Opened again and changes were there. Published, refreshed, all good.


(Lisa Sandler) #2

I find that in general, if I preview too fast after making a change, it doesn’t register/re-render.


(Greg Schneck) #3

@dan
With limited use, (I’m still on v7 for production) I’ve experienced the same issue with RW8… Sometimes, after a page change is made and I Preview I get the cached preview… not a new one. If I go to another page and then click back I then get the updated Preview. Never saw this in versions 5, 6 or 7.


(John Scrip / MASSIVE Mastering LLC) #4

Just had that also. But it’s also uploading the cached version. But yes - Change pages and come back - or restart RW - and the new stuff is previewed and publishes.


(Dave) #5

I could be wrong, but in my experience, the changes don’t seem to show up until I click out of the stack I’m working in. So, if I’ve entered text into a paragraph stack and then hit preview (or publish), it’s not there. But, if I click anywhere outside the stack, then it’s there when I preview and/or publish.


(Greg Schneck) #6

Hummm, I’ll check that out but why would I suddenly notice something “different” after using RW for years? I’ve never in my life noticed a Preview not updating upon doing a “preview” but suddenly that is what is happening.


(Greg Schneck) #7

btw… as info… It is true that if you are editing and IN a stack (cursor is in active within the stack) and you COPY, (normal Mac Cmd C) the stack is not put on the clipboard. To copy (then paste) a stack you must exit out of the stack before you copy. That is probably “normal” and as it should be. Though this doesn’t seem to be “consistant” for all types of stacks.


(Isaiah Carew) #8

I think the devil may be in the details on this one. I’ve been tracking a few very similar issues. All of which have completely different root causes. The symptom of failed/out-of-sync preview is general enough to encompass a lot of different “illnesses”.

It should go without saying, but if you’re experiencing a strange issue then Realmac and YourHead would like to take a look at your project and see what you’re seeing and hopefully get the problem fixed. So send your projects our way.

If you’re inclined to try to understand a bit more yourself, here’s some stuff I’ve noticed. This is really just for folks that would like to tinker and understand the issues a bit more.

New Stuff

RW v8.0.3 seems to have corrected a number of internal issues that causes exporting to fail/crash/give-up.
Result: check your misbehaving pages in the recent build.

New Settings

Be aware that there are some new project-wide settings and app-wide preferences in RW8. If you’ve changed some of these it can affect how your project is being updated.

Slow Stuff

Slow exports behave differently. RW8 does more asynchronously, and very slow things can result in repeat exports or even looping exports.
Result: If you see repeating exports for a single preview, or looping exports send your project to RMS or YourHead to have them take a look.

And this last one is for the truly adventurous nerd that likes to dive deep. :nerd_face::face_with_monocle:

Compare and Contrast

One great way to isolate issues is to run RW7 and RW8 side by side on the same project. Since RW8 made a copy of your project file, you can open both. It’s fun to run them side by side and compare apples-to-apples.
Result: If you notice any big discrepancies between the two, send your project file or a step by step procedure about how to see the discrepency


(Greg Schneck) #9

@isaiah I’m still on RW7 for prod work so I’m just not in 8 that much yet. But if I continue to see “delayed” previews (cache displayed, and not the updated page) I’ll certainly be happy to send the project file to you.


(Greg Schneck) #10

@isaiah @dan
Confirmed… RW7 and RW8 previews differently depending if stack is “active” (selected) or not.

In RW8 I added a new text stack to existing page. I added a few words to the “Lorem ipsum” default text and previewed with the stack still active (highlighted). My added text did NOT show. I clicked outside the stack so that it was not selected and preview then it worked fine… my added text did in fact show if stack was not active.

I then went to RW7 and did the same. The newly added text showed in preview EVEN WHEN STACK WAS ACTIVE AND SELECTED. In 7 the preview worked if selected and active first time and every time.

SUMMARY OF WHAT I SAW:

  • RW7 always showed edit in preview whether active (selected) or not.
  • RW8 FAILED to show edit in preview if stack was active.

I was also able to duplicate this behavior on a brand new project.

  • create a new project
  • add a stacks page
  • add a text stack and add some text at the end and then without leaving the stack PREVIEW (leave stack active)
  • THE ADDED TEXT WILL NOT SHOW
  • De-select the stack by clicking outside of it.
  • Preview and your added text will show.

Please let me know if you don’t see this behavior.


Crash on SiteMap page
(Isaiah Carew) #11

@1611mac this is a great post and really opened my eyes to what you’re seeing. There definitely is a change here. It was actually intentional. I know this seems crazy… :crazy_face: but bear with me… :smiley:

RapidWeaver 8 has some new super powers – it previews changes on the fly all the time. This is pretty great, but Stacks needed to adjust how text editing works a little bit.

  • I started writing a response to this that would explain what we did, but it was pretty hard to explain.
  • Then I started making a video about what we changed, but even that was difficult to get right.

That’s when I realized there really is a real problem here.

So, I’ve made a little view that shows:

  • How things worked in RapidWeaver 7
  • How things work right now in Stacks
  • Some tweaks I’m going to make to Stacks in the next few days

This isn’t a tutorial video. It’s a deep dive into one tiny behavior of Stacks, how it works, and where we’re going. But if you’re interested in those sorts of things, have a look.

If not, then just look out for Stacks v3.6.3 coming pretty soon when I’ve had time to test out some of these little tweaks we’re making.


(Greg Schneck) #12

Thanks much! I’ll absolutely check out the video as these things interest me very much!


(Greg Schneck) #13

Ha… Wow… the habits we get into. @isaiah… I haver never one time clicked the “Done” button in years of using RW. I simply keep working and the jump to working in a different window/stack/etc or doing a preview. So these things have been doing the “Done” for me.

Honestly! I’ve clicked “Done” ONLY when setting param’s on photo’s.

A great video that caused me to think and really opened my eyes to the Simulate feature of RW8. Thanks so much! It all makes perfectly good sense!


(Lisa Sandler) #14

I just had to look up where “done” was because I’ve never noticed it either.


(Greg Schneck) #15

I can see I’m going to be setting up a keyboard shortcut for “Done.” :slight_smile:


(Isaiah Carew) #16

And that’s about how it’s supposed to work. Just like you probably never chewed “Copy” from the edit menu and use Cmd-C instead. Explicit controls are there for new users and for exceptional cases. Most users, once they understand the app, will just use the implicit behaviors. The more expert you become the more depth and complexity you find. :smiley:

Hopefully I’ll be able to return a couple of those implicit controls that you’re used to in the next version.


(Greg Schneck) #17

For myself, it’s simply a matter of clicking outside the stack before a Preview. I often don’t get a system “Copy” because of the same reason (I’m still active in the stack) so it’s a behavior that would be good for me.

I have a 27" iMac plus a second 27" monitor so I’ll likely run Simulate (live update) on the second monitor.


(John Scrip / MASSIVE Mastering LLC) #18

This is typical “me” stuff – What I thought of as a bug is actually a new feature. :rofl:

And that’s all good – Just what I was used to being different. When I make site tweaks, I’ve just sort of “trained myself” to make the tweaks, publish, check online, then I close / save / go on about my business.


(Tom Murray) #19

Thanks for the video.


(Gary Wann) #20

Interesting. In all my years of using Rapidweaver I’ve never had any issues with the edit/preview - and in fact I don’t think I’ve ever clicked (or even really noticed!) that ‘Done’ button.

I’ve ALWAYS clicked outside the stack I’m editing before previewing - just the way I work I suppose. Thanks very much Isaiah for the video, it explains exactly what is happening in the background - even if I wasn’t aware :smile: