Preview doesn't work


(Jeffrey Shaw) #1

Well I’m certainly hoping a fix is coming for this otherwise it’s $59 down the pan! Preview just shows a blank pane. Not just with my imported RW6 projects - also with a brand new one with a single styled text page. So - can’t use it at all.


Kein Preview in Rapidweaver 7
Crash on preview
(Matthias Ficht) #2

You should write an email to support@realmacsoftware.com. Dan & Co. will for sure help you out.
In the last several weeks while beta-testing RW7 and also now with the final version I never ever did experience the issue you are describing. Maybe some incompatible plugin is causing this effect. You could also try to create a new user on your machine and see if the issue still occurs when previewing with RW7 there.


(Jason Bostick) #3

Before you bury RW7 forever, if you can provide some other details (to us here, or the Realmac guys) it could be something relatively simple.

Your theme, plugins, computer info, etc.


(Jeffrey Shaw) #4

Thanks - wasn’t really expecting to have to bury it, but it’s annoying nonetheless. I have emailed Support and shall see if RW HQ can sort it out. Cheers.


(Bruce Kieffer) #5

Try seeing if your resources are linked. I had that problem. Relinking the resources fix it for me.


(Jeffrey Shaw) #6

Many resources were indeed unlinked - that meant a significant (but obviously necessary!) bit of housekeeping to track it all down. All done: sadly it made no difference to the problem. I guessed it wouldn’t, in view of the fact that I had tried with a new project with a single styled text page - no resources to get lost, and it had the same problem.

Thanks anyway!


(Bruce Kieffer) #7

Sounds like something else is wrong. I have eight RW7 sites that are all working fine.


(ben) #8

If you drop us an email with as many details as possible, one of our developers can take a look and get it fixed for you.

Please include your OS version, a list of all installed Addons, and steps to reproduce the issue.

We’ll get you up and running ASAP :+1:

support@realmacsoftware.com


(Dean) #9

2 computers, same downloaded rw7, share the same resource folder in dropbox, create a new project, add some text or stack.

1st computer preview works as normal
2nd computer preview gives blank page. element inspector shows

are there preferences we can try and delete? I deleted a couple of com. files, but they seem old and nothing changed.

when you click on Preview, the 1st computer says exporting, then shows the page.
the 2nd never says exporting, just straight to the blank page.

export project to a folder does work and the project can be viewed this way.
publishing works too
changing the view mode works.

I hope this helps!


(Jürgen Schulze) #10

Edit: The author sent me a new version of his theme and it worked seamlessly after installation. Thus, I’d recommend to get in touch with the Them-authors as a first stop! (-;

Seems as if there is some random stuff with preview.
I have 4 current projects. 2 of them moved seamlessly. 1 has visual issues but 1 creates the loop of death.
When I want to preview, it gets into an endless loop of exporting random pages of the project. Clicking cancel does not help. Switching back to Edit-mode does not end the loop, either. I have to close that project in order to get out of that loop. When I close it, RW7 crashes (i.e. it quits).
I’ve created a screencast to illustrate: https://www.dropbox.com/s/3ub2qvwl32squj6/RW7-glitch.mp4?dl=0
Anybody sharing the same hiccup and has a solution?
As said: It is with RMS now and it might well be a theme glitch. The theme author is briefed, too.
That way, at least this project needs to stick with RW6


(Jeffrey Shaw) #11

Well I’m very confused now. I restarted RW with option key to load without add ons - all previews fine, with a new blank project at least. So I thought I was going to have to do hunt for a misbehaving add on. I then restarted RW with normal add ons and – preview works!! BUT - now the home page of my site not only garbles the preview but also the export, so output is unusable. I tried deleting all the content from the page item by item and it is still garbled. I tried deleting a CCS snippet (so there is no additional code in the page inspector); still garbled. But a fresh project with all the same content imported displays just fine. Go figure. The only way forward for me now is to recreate the whole site afresh in a new file. That is several days’ work, so I am not keen! Any ideas of anything I could have missed?


(Jean-Francois Landry) #12

After installing RW 7 and updating my website, preview is unavailable for every single page. RW try to create the preview page, than shows this error message : « Couldn’t posix_spawn: error 1 ». :disappointed:

Yeah! Update RW to 7.0.1 solve my problem. =) Thanks to the developers!


Couldn't posix_spawn: error 9 when trying to preview RW6.0.6
(Jeffrey Shaw) #13

All OK now - I recreated the home page within the original project and it previews and exports correctly. Hoping this means I can now transition to RW7. Phew!


(Andreas Kolisko) #14

I have the same Problem here. A foundation website, all Previews are white.

What do you mean? [quote=“Powderkeg, post:13, topic:7064”]
I recreated the home page
[/quote]

Rebuild it in RW7? That is not a solution!!!
@Ben:I can send my Project file to the support if needed


(ben) #15

First thing I’d suggest to do is make sure that both the Foundation theme and stacks are up to date. Have you done that?

If they are up to date, and you still can’t preview, please email support@realmacsoftware.com with as many details as possible, including your project file, and one of us will be able to help further :slight_smile:


(Dean) #16

create new mac user
login
run RW7 (no previous themes etc installed)
create new project from defaults
preview a page… white page

preview a page in browser:
browser says:

This site can’t be reached

The webpage at http://localhost:0/ might be temporarily down or it may have moved permanently to a new web address.

where is RW building the preview?
permissions problem?


(ben) #17

Hey @bluemist ,

RapidWeaver 7 uses a new system to preview pages locally - basically, a local server is created. What we’ve recently found is that if your hosts file has been tampered with (by a filter, security app, or similar), this would hinder RapidWeaver 7 from running / showing the local server. In return, the preview function would be rendered useless in RapidWeaver.

I’d like you to try the following to see if your hosts file is as it should be. If it isn’t we’ll send the necessary steps to repair it.

  1. Go to Terminal.app in /Applications/Utilities
  2. Type in nano /etc/hosts
  3. Press the Enter key
  4. Enter your password (admin)
  5. Send a screenshot of what appears. Here’s what mine looked like: https://www.dropbox.com/s/uz74l6xhle4fncr/Terminal_Hosts_RW7.png?dl=07

Another thing I’d like you to check is what appears when previewing your site in a browser. This will tell us what host your computer is using to preview the site.

  1. Press Command + P
  2. Go to the address bar and copy the URL and paste it in your response back to us.

Thanks for your patience as we look into this. Can you send all details to support@realmacsoftware.com and reference this thread!


(henry4ross) #18

Based on others’ reported experiences with RW6 I will not be early adopter

It is excellent software, I just don’t use it that often so why run the risk?


(LJ) #19

I had exactly this problem when first beta testing RW7. However, after a re-start of my Mac, it never happened again. Couldn’t replicate hence couldn’t get to the bottom of it at all


(Michael M.) #20

Maybe, this is a solution (in German):

Your can get GasMask here: http://clockwise.ee

I didn’t try it for myself because I had no problems with preview. But maybe it helps some others