Lost images when saving project after editing


(Peter Labourdette) #1

Hello,
I am experiencing a problem where I am losing images from pages in a project after :
From my existing project-
Duplicating 1 page then making edits only to this new page, then Saving as “New Project”.
In this new project -Images are missing from 20 different pages (none of these pages were edited).

If I copy and paste the page into a new stacks page then “save as” the same thing happens.

Is there a bug in RW7 that loses images and data when saving?
I emailed Realmac support about 10 days ago and have not heard anything from them.
Is anyone else having similar issues?

I am running Running Mac OS Sierra 10.12.6
Rapidweaver 7.5.5
Your Head Stacks 3.6.0


(NeilUK) #2

In the general settings, there’s an option to “make document portable” or something along those lines. If you select that, the images should work.

That might not be the issue you’re experiencing, but worth a look.


(Rob Beattie) #3

How are you adding the images in the first place? Drag and drop, warehousing (storing on a server and referencing them with a link) or via Resources?

Rob


(Peter Labourdette) #4

Rob-the images are dragged and dropped into image stacks. This is happening on pages that worked fine for years through RW6 and RW7. Now after editing other newer pages, these older pages are missing images and just show the question mark where the images were.


(Isaiah Carew) #5

Hi Peter,

I did a lot of digging in the files you sent over to us (sorry I’ve been slow to reply I was in hospital last week having some minor surgery), I have been able to discover that the second file you sent is missing > 30MB of data scattered about in various bits (not just images – but also some of the data files, other media files, etc). It’s pretty well scattered around the file – not isolated at all to the pages you modified. Which is all a very unique issue I’ve not yet seen before.

I sent some other detailed questions too. I’d like to more about how you’re conducting this experiment – how the files get copied, etc. – and whether the same sort of corruption you’re seeing can be repeated with this experiment at will.

If you can do this consistently it would be great to have a movie or more details into the precise mechanism. Like even the most minute details that you probably think are completely useless – where you click, how you drag, which menus you choose, etc.

There are tens of thousands active users of these products and quite a few using them every day full time and I think it’s pretty safe to say that lopping off 30MB of project files is something most people would notice!!! :stuck_out_tongue_closed_eyes:

Which is to say that there is very likely something very specific to your setup, machine, environment, or even the way that you’re copying or storing these files, that is catalyzing this issue.

This is not to say that it’s not a bug – it very well may be – i think there’s a pretty good chance – but it’s one that’s been (thankfully) very well hidden to most users. What we need to discover is what makes you so “lucky” to have uncovered this one and be able to see it over and over.

I promise I’m very interestested in your reply (and any other details you have) – but I am only able to sit at my desk a couple hours a day at the moment, if I don’t get back to you immediately my sore hip apologizes in advance. :slight_smile:

Isaiah


#6

I’ve been having this problem for a long time.
Many days it goes well, but then all pictures are disappeared in a stacks page.
Strangely, it doesn’t affect all stacks pages in a project.
I sent this bug and the corresponding project files to Isaiah a few months ago.
The error occurs irregularly. I didn’t find a workaround.


(Isaiah Carew) #7

@Volker - although the symptom seems similar on the surface, the reality is that it is quite different.

In your case all data files (images primarily) go missing almost entirely from specific pages – the page is left image-free. As if someone removed them purposefully from those pages.

In @Petelab’s case the file is missing seemingly random data scattered around the file, so some pages are missing just one or two images. It also affects other files (that are not so noticeable on the surface). It’s more as if someone cut off the process of copying the project file mid-way.

I obviously don’t know what is at the root of these problems, but every bit of evidence suggests that it is something quite different in each case.

The only similarity is that they have “missing” and “images” in the titles of their forum posts. :stuck_out_tongue_closed_eyes:

Isaiah


(Peter Labourdette) #8

Thank you Isaiah for your prompt response and all the work you are doing to solve this problem.
The folks at YourHead have a top notch customer service team!


(Isaiah Carew) #9

Lots more details about the research of this bug here in this bug report: https://github.com/yourhead/s3/issues/815

I’ve closed it now because there does not seem to be anything that I can do to change the behavior or work around it. Submitted to Realmac with a ton of details and a nice video to show how to duplicate the problem with only the built-in page styles. The video is in the bug report details if you like to watch really boring, super technical things. :stuck_out_tongue_closed_eyes:


(Cielito Gonzales) #10

I’m having the same disappearing or “missing” images problems too. Fortunately, I create 2 backups (with new file name) of a project in 2 different drives whenever I edit. I have had to copy and paste from a backup to the one missing the images.

I hope someone can get to the bottom of this. Thanks for helping, Isaiah.


(Isaiah Carew) #11

The bug was identified. And Realmac confirmed they could reproduce it. You should contact Realmac support to ask when they might fix this in RapidWeaver 7.

Unfortunately the bug is related to saving duplicates of your project file. So in a horrible irony the fact that you keep losing data is encouraging you to do the very thing that is likely triggering the bug and… making you lose more data. :see_no_evil:

The workaround that I suggested for others is very simple and seems to be very effective:

  1. Always make duplicates of your file in the Finder when RapidWeaver is not running at all.

  2. Never use the Save As… command in the edit menu or Command-Shift-S.

I believe this will entirely avoid the problem. If you still notice a problem with similar symptoms even though you never use Save As… then it’s likely to be a different problem and we should start a completely separate investigation.

Isaiah

// @dan


A funny thing happens on the way to my site
Dr. Cleaner erases RapidWeaver Images
(Cielito Gonzales) #12

Thanks, @isaiah
I do method 1 after editing projects. Unfortunately, I used to do method 2 before editing. Never again! :slightly_frowning_face:


(Isaiah Carew) #13

But at least we know that your symptoms followed the same known pattern – and that means there’s a very good chance that avoiding that one thing will solve the issue for you going forward. :smiley:


(Dan) #14

This issue will be fixed in RapidWeaver 7.5.6 due for release within the next few weeks.

Thanks
Dan


(Isaiah Carew) #15

Woo hoo! :tada::heart_eyes: Yeah!!


(Scott Lee) #16

Isaiah! thanks for the info! I only lost my images twice and it was after I installed Dr. Cleaner. Dr. Cleaner reclaimed over 3 gigs of memory…I would imagine that has got to be images. Anyway, it hasn’t happened since I uninstalled it! Fingers crossed!


(Isaiah Carew) #17

@chicken - yes, i was pointing to this thread just because of the last past in other thread. mostly just because it said that he had contacted support and they couldn’t find a solution.

but yes, if you’ve been using Dr. Cleaner – then there’s a good chance that was it. cleaning apps wiping out useful directories has been a problem for as long as i’ve been a developer. :persevere: i think you’ve probably got your problem solved.