Map not showing with Firefox only

Hello everyone !
I have a Google map here, in the sidebar, using Map2 from Doobox.

My problem is ; this maps appears normally when using Safari or Chrome, and do not appear when using Firefox.

Do you have any idea why ?

OK ; it seems to be a simple API key, I’m working on it…

Done ! Sorry guys !!!

same problem here.
it doesn’t show in Firefox.
What did you do?

To show Google Maps on a website, you need an API key now.

This is what happened : I made my “API key” settings to quickly, with just “without www address” (hope I’m clear). I mean ; I just put my website adresse, with no www, in the “authorized address field”…

And so, when I was displaying my page in Safari and Chrome, I was on the “” address.
When I was trying in firefox, I was on the “” address, I didn’t pay attention to that…

So ; I completed the API. Does this answer to your question ?

Hm … not really, but I think I didn’t get your point, sorry.
What I meant is: Opening your site in Firefox the map doesn’t show up.
Opening it in Safari it shows up …
So a totally different issue …
Sorry …

It’s because I didn’t pay attention that :

My API keys was configured only for the www address.
So it worked in Safari and Chrome each time because the “memorized URL” was the www one.
And it didn’t in Firefox because the memorized URL was just “”.

If I had typped the “” address in Safari, it wouldn’t have worked either.

The problem did not come from Firefox ; just from my API settings.

So now I completed the API key informations, and it’s ok everywhere…

Hope I made myself understandable :wink:

You should redirect one or the other. Decide if you want your URL’s to be www or not to have www on them and setup redirects so no matter what the user enters it ends up at proper URL’s.

Otherwise search engines may consider the two URL’s (www and non-www) to be duplicated content.

1 Like

Thanks, I did that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.