Menu not working on blog pages


(Chris Loneragan) #1

This has been bugging me for months now. I know it is a Rapidweaver bug that Nik from RW is aware of, but it has been unfixed now for at least 4 months despite several new releases of Rapidweaver. The bug is that the navigation menu does not show in blog posts in Tesla Pro (and others?).

Please please fix this!


(Brad Halstead) #2

Hi @ChrisL

Tesla Pro is a Theme by Elixir Graphics… (So is Tesla that is built into RapidWeaver 6) so just making sure you’re contacting the correct support person…

If actually Tesla Pro, you’re better off contacting Elixir Graphics imho.

The issues I encounter are:

  1. that when you go to a specific blog entry there is no nav-bar visible to go to other pages in the site.

  2. that it doesn’t matter if you define perms-links or not, same result occurs.

Are these correct?

I am not sure if this a Theme issue or a RW issue, but the nav-bar is not generating sub-pages for blog entries as the blog entries are now created in the files folder of the Blog folder (/blog/files/permalink1.html), when it should be generated in /blog/permalink1/index.html for nav purposes… either way, it’s certainly an issue with RapidWeaver or Tesla Pro Theme.

Please report to Elixir Graphics… @Elixir

Brad


(Adam Shiver) #3

This indeed a bug with the navigation output. Realmac is working on a solution for the problem. It has been one that has been a very tough bug to track down and find a solution for. Hang in there, Nik and the others are definitely working hard to get a fix for it. He and I talk quite often on the progress of this particular bug.


(Brad Halstead) #4

Thanks Adam (@Elixir) for checking in and reporting the current state of affairs for Tesla Pro Theme.

Brad


(Adam Shiver) #5

No problem. It really is a tough bug, even though it looks super simple on the surface. I pushed the navigation API to somewhere the RMS guys didn’t expect and made a weird use case that fouled things up. They’re sorting it out though, so please be patient. :slightly_smiling:


(Chris Loneragan) #6

Thank you for the update - nice to know it is being worked on. I just find it very poor that it is taking literally months to fix. I, and many others, have paid for RW and Tesla Pro and now have a bug that means we have to miss out on all the up to date features of RW because the latest 2 versions don’t work for us. I have a business that relies on the blog function working!


(Nik Fletcher) #7

We’ve been looking into this for some time, and as Adam notes it’s simply due to some behavioural changes that we made to fix another issue. The reason for the delay is simply down to us having three things in process:

  1. shipping 6.3.8
  2. working on RW7
  3. needing to spend additional time making sure that any tentative fix doesn’t break the navigation set up for other sites.

The last of those items being the most important!

We’ll be issuing a 6.3.9 beta soon with a tentative fix to gather feedback, and obviously want to fix this as soon as we can!

—N


(Adam Shiver) #8

On top of it as always! Thanks @nikf! :smiley:


Known bug not fixed
(Roosje) #9

I also have this problem in my website (template SPLIT), so I’m hoping 6.3.9. will fix this. The team of Yuzoolthemes can not help and gave me a link to this forum.

Not sure if my problem is the same. It shows a whole lot of navigation-items in the navigation-bar. I think is has something to do with a second level of pages? The navigation-items are titles of pages.
Example


(Will Woodgate) #10

Sounds identical to what was discussed here:


(Chris Loneragan) #11

Nik, is there any news on the fix for this issue please? You have known about it for many months and have even fixed it for one user on a personal basis. I love Rapidweaver, but I really do not love the customer care in this instance!


(Mathew Mitchell) #12

@ChrisL Nik is no longer at RealMac. You may want to reach out to Dan or others on the RW team. I agree it’s a shame this hasn’t been fixed. At the very least it would be good to know if this is already fixed in the upcoming RW7.


(Chris Loneragan) #13

Thanks Matthew. I’m not sure how to contact them directly, but hopefully they will see it here and sort the fix out. It is ridiculous they have taken so long!


(Chris Loneragan) #14

I have contacted Dan directly and await his reply. I have suggested that upgrading to RW7 should be free as a goodwill gesture to users who have been left in the lurch by the developers.


(Robert Ziebol 🖖🏼) #15

You can contact @dan and @ben buy using the @ symbol and then typing dan or ben after. They are pretty active on the forums.


(Chris Loneragan) #16

Thanks @zeebee I shall use @dan and @ben - I’m not mega forum savvy I just want to use RW effectively for my business website, and the log is essential for that.


(Roosje) #17

The update 6.4 fixed my problem. Thanks!