Tesla Pro menu not showing in blog pages


(Chris Loneragan) #1

I am using Tesla Pro for my business web site. The menu has stopped showing in blog pages, which is very annoying and leading to people leaving the site instead of continuing to browse. Can anyone suggest a reason please?


(Marten Claridge ) #2

Can you share a link please?

Marten
RapidWeaver Central


(Chris Loneragan) #3

Thanks, it’s www.clphotography.co.uk


(Marten Claridge ) #4

There seems to be a setting or some code hiding the navigation bar on the blog sub pages:

#navigation_bar {
display: none;
}

Has this got anything to do with the menu stack you are using on some of the other pages?

Marten
RapidWeaver Central


(Chris Loneragan) #5

Thanks for spotting that Marten. The menu bar (My Menu Stack) works in conjunction with the Tesla Pro menu bar on the other pages, but not the blog ones, and it worked on the blog pages before the last RW update. How can I change the setting you noticed?


(Marten Claridge ) #6

I don’t have the theme or the stack, so I can’t comment on whether or not there’s a setting to hide the navbar in the theme… but there may well be such a setting in the menu stack.

Personally I don’t see what the floating menu brings to the table… and if it is the cause of this issue then I’d remove it.

Marten
RapidWeaver Central


(Chris Loneragan) #7

I can’t see a setting anywhere, but I have found some other forum posts mentioning missing menu items on blog pages on several themes since RW 6 came out. The floating menu is there for when people scroll down the page - several people mentioned to me that the theme is annoying to the user as the menu bar disappears when you scroll. My bounce rate has dropped since putting it on.


(Marten Claridge ) #8

I’ve since found a copy of the stack and there’s an input field at the bottom of the settings called Theme Menu. If you’ve entered navigation_bar here in any of the instances, then it’s probably this affecting your navbar on the blog pages.

Marten


(Chris Loneragan) #9

Thanks Marten, I appreciate you looking at this for me. I don’t have that setting on my version of the stack, but it isn’t on the blog page anyway. I’ve tried removing it from all pages but the menu bar is still missing on blog sub-pages, so it can’t be the end stack causing the issue.


(Marten Claridge ) #10

Maybe time to contact the theme developer then… Give him as much detail as possible and tell him the steps you’ve taken trying to resolve the issue.

Marten


(Chris Loneragan) #11

I’ve tried contacting through the support page on Elixir Graphics website but no reply :frowning:


(Marten Claridge ) #12

They’re still on holiday in the US, you might not get a reply until tomorrow or Tuesday.

Marten
RapidWeaver Central


(Chris Loneragan) #13

Thanks again Marten. I’ve just noticed also that if I try changing the site theme, it changes all pages except the blog sub-pages. Wondering now if it’s Rapidweaver that’s got the fault rather than Tesla Pro!


(Chris Loneragan) #14

Thank you to Adam from Elixir Graphics and Nik from Rapidweaver for answering the question. There is a bug in Rapidweaver 6.3.6 that Nik is working to resolve.


(Kevin Atkins) #15

Late to the party, but I’m using the free version of Tesla on a site, and I too am missing the navigation since the last RW update. I’m preparing a December update, too, which is going to be problematic without navigation! Hope it gets resolved soon.


(Kevin Atkins) #16

If it’s relevant, I tried publishing my blog update today, but it refused with an Exception error, saying it couldn’t generate the RSS correctly. I unticked RSS and it published okay, but the navigation is still missing. I’ve had to ‘cheat’ and put a back button in the sidebar, so that there’s at least some way to get back home, but it’s not ideal.


(Chris Loneragan) #17

The problem is with Rapidweaver and not Tesla Pro. A new version of Rapidweaver (6.3.7) was released this week, but the problem still has not been fixed - I find this very very disappointing as blog functionality is vital to my and many other websites so should be a top priority for the developer.


(mesmerize) #18

Hello, I’ve just found this issue. Is there still no fix to Rapidweaver blog posts showing the menus.
I noticed it was leaving out some of the key code to show the blog, I could manually add it but this is a bit of tedious process.

We just bought the rapidweaver program and it seems strange this small bug is still unfixed.


(Adam Shiver) #19

I’ve talked with Nik about this particular bug on several occasions. This is something the Realmac crew is definitely working on a fix for. It is one of those bugs that seems so easy on the surface, but is way more complex underneath.


(Liz Cranfield) #20

Thank you to Adam from Elixir Graphics and Nik from Rapidweaver for resolving this problem for me. The problem was in Rapidweaver and not the Tesla Pro theme. I have just tested a beta version of Rapidweaver 6.4 and the problem has now been resolved - see the blog on www.writeforkids.co.uk where I have documented the problem and noted the problem has been solved today. Nik has confirmed that version 6.4 should be available for general release in a few weeks. Hope this helps you all.