Mobile Ansicht view zerstört alles


(Rigo) #1

Hallo,
Ich habe ne Seite gebastelt und online gestellt.
So finde ich sie für den Anfang echt cool, aber die mobile Ansicht zerstört alles.
Warum ist das so?
Was kann ich dagegen machen?
Das Theme kam 30€ (Reservations)
Überzeugt euch selbst…
www.partyband-mv.de


(Oscar Schmid) #2

Hallo @Rigo182
Hab dein Posting ins deutschsprachige Forum gezügelt.

Das Problem werde ich mir später anschauen.


(Oscar Schmid) #3

Alles ist nicht zerstört, aber das Menü.

Bei einer bestimmten Breite des Fensters sind noch beide Menüs sichtbar, weiter verkleinert ebenfalls

Hast du irgendwo irgendetwas verändert (mit CSS etc.)?

Du hast unterhalb des Headerbildes einen zusätzlichen, unnötigen Menübereich, der so nicht erscheint auf der Entwicklerseite.


(Oscar Schmid) #4

Dieser Bereich sollte verschwinden.


(Oscar Schmid) #5

Dies ist nur auf der Startseite so. Auf den anderen Seiten sind die doppelten Menüstreifen weg,
… aber leider stimmt mit den Headerbildern etwas nicht. Wie hast du diese eingebunden?

iPad Hochformat zeigt dies. Da hast du wahrscheinlich etwas “zerstört”! Ist beides da.

!


(Rigo) #6

Die Banner Bilder interessieren mich wenig. Mein Hauptproblem ist das nur die linke Seite vom Text gezeigt wird. Nicht überall. Irgendwie da wo n Stack ist mit mehreren Feldern nebeneinander.

Kann ich irgendwie ne automatische webanzeige einstellen? HTML des Themes verändern?

Fast alle großen Seiten haben ja auch n Button o.ä. Wo man klicken kann für die normale Ansicht.


(Oscar Schmid) #7

Ich weiss nicht, wie du die Seite "Live"gestaltet hast. Responsiv ist sie aber nicht wirklich. Drum wird auch nicht alles angezeigt.
Dann hast du hier das Menü ganz zuunterst und es wird nicht geöffnet oder geschlossen beim Klick auf “Menu”, sondern es steht immer offen.
Da stimmt wohl einiges noch nicht.

Eben, nochmals die Frage:
Hast du dies und das, da und dort per CSS verändert?


(Michael M.) #8

Es ist schwierig, das Problem im Quellcode der Webseite auszulesen - man müsste sich das Projektfile anschauen.


(Chris) #9

Die Webdev Tools zeigen, dass das stacks javascript file nicht gefunden werden kann. Sieht es denn in der Preview von RW gut aus? Wenn ja, empfehle ich, einmal alle Seiten neu zu veröffentlichen.


(Rigo) #10

Wo ist den das File von Javascript hin? Wieso gibt es das nicht? Kann das an der Stacks app liegen?

So sieht alles in der RW Preview gut aus! Gibt ja leider keine Mobile Ansicht.

Per CCS habe ich nur verändert…
den Footer (Social Media) und das Banner Bild (laut Anleitung … siehe Bild)


(Rigo) #11

EINS STEHT FEST!!!..

Ich habe nochmal genau geschaut…

Überall wo ich den Stack einbinde (Bild) geht die Ansicht flöten!
Da ich den ziemlich oft benutzt habe, kommt es sehr Häufig zu dem Problem.

Ich möchte den Stack aber gerne benutzen … versteh ich jetzt leider nicht…


(Michael M.) #12

[quote=“Rigo182, post:10, topic:6480, full:true”]
Wo ist den das File von Javascript hin? Wieso gibt es das nicht? Kann das an der Stacks app liegen?[/quote]

Stacks.app…??? Oder meinst du das Stacks Plugin?

Es könnte sein, dass bei Upload etwas schief gegangen ist und eine benötigte Datei nicht hochgeladen wurde (siehe Post von @cric) - also alles noch einmal Hochladen und schauen, ob der Fehler danach behoben ist:

RapidWeaver: File > Republish all Files

[quote=“Rigo182, post:10, topic:6480, full:true”]
Überall wo ich den Stack einbinde (Bild) geht die Ansicht flöten![/quote]

Wie ich oben schon schrieb, ist das schwierig, das Problem anhand des Quelltextes einzugrenzen. Vielleicht kannst du die Projektdatei hier online stellen (muss ja nur die Startseite sein)

-Michael


(Oscar Schmid) #13

@Rigo182

Ich hab diese Tabelle mal nachgebildet in RW 5.3.2 (du arbeitest ja mit RW 5, sehe ich an deinen Screenshots)

4 Spalten-Stack mit Textstacks drin.
Da läuft alles richtig bei mir, wird alles dargestellt. Ist alles in Safari zu testen.


(Rigo) #14

Vielen Dank für eure Mühe.
Also mit nem anderen Stack geht es zumindest so das man alles sehen kann (untereinander) … Werde dennoch weiter probieren und berichten.

Heute Abend stelle ich mal ne Projekt Datei online.

Ist das dafür nicht super??? Also siehe Bild


(Michael M.) #15

Die Seite soll doch responsiv sein, zumindest kann das Theme das wohl. Dann müssen auch die Inhalte responsiv eingebunden werden. Mit den statischen Columns kommst du da nicht weiter, das Responsive Bundle ist aber schon der richtige Weg.

Trotzdem muss da noch ein weiteres Problem sein, denn die Columns dürften nicht mit den Verschiebungen im Navigationsbereich zu tun haben


(Oscar Schmid) #16

Hast du dir auch schon überlegt, eine Tabelle per HTML Code einzubinden?
Da wäre ein Vorschlag

Code in der Seite (Formatierung ignorieren)

<table> <tr><th>Zeit</th><th>Ort</th><th>Anlass</th><th>Bilder</th></tr> <tr><td>Januar</td><td>Stadt a</td><td>Fest</td><td>✓ 📷</td></tr> <tr><td>Januar</td><td>Stadt b</td><td>Fest</td><td>✓ 📷</td></tr> <tr><td>Januar</td><td>Stadt c</td><td>Fest</td><td>✓ 📷</td></tr> <tr><td>Januar</td><td>Stadt d</td><td>Fest</td><td>✓ 📷</td></tr> <tr><td>Januar</td><td>Stadt e</td><td>Fest</td><td>✓ 📷</td></tr> </table>

Code in CSS

table {width:100%; font-family: Lucida; font-size: 14px; color:#fff; background-color:#ccc; border-spacing: 2px 2px; border: none; } th {width:200px; height:35px; color:#000; background-color: #fff; border:none; } td {color:#000; font-style:italic; text-align:center; background-color: #fff; border: none; }


(Rigo) #17

Ich habe das Problem jetzt best möglichst für mich gelöst.

Es hat geholfen mit colums zu arbeiten und alle auf flexibel zu stellen.

Das reicht erstmal so denke ich.

Mit den Banner habe ich noch nicht weiter geguckt??!! Vielleicht falsche Bildgrösse???
Habe zudem im css immer 100% angegeben.

Liebe Grüße.

www.partyband-mv.de (nochmal zum gucken.)


(Rigo) #18

Wie kriege ich das weg???
Sorry jetzt erst gesehen…