My HTTPS Site Looks Different/Broken vs HTTP Site

I’ve just installed a new security certificate on my website and so, using the .htacess file, I made it so that visitors are redirected to the HTTPS version of the site.

Only issue now, is that my entire site looks broken/incomplete and different from the un-secure (HTTP) version of it. I know that I have to make sure all the resources are using HTTPS rather than HTTP to make sure the browser doesn’t block them from appearing but in RapidWeaver, I don’t know how to do that.

My general & publishing settings are fine and updated but after uploading, the site is still, as I said, broken/incomplete and different from the un-secure (HTTP) version of it.

Any help would be amazing. I’ve been learning as I go with building this website and everything and i’m getting so far. I feel like this is the final boss of my issues lol. So thank you in advance to everyone who tries to assist me.

I think you will benefit from my live stream today…

1 Like

Thank you for that Joe, Ill have to subscribe to your YouTube channel.

I’m hoping to get some specific help for my issue though.

Not sure what’s broken.

Don’t know what it looked like before you forced https.

I put the home page through whynopadlock and it came back all okay.

Did you try clearing your browser cache? Or try a different browser or device.

Yeahh, everything comes up fine as far as the test results but the design of my website is almost completely different/ destroyed. I’ve attached an image of what it should look like…

| Comparing that to the HTTPS version of the site, there’s something wrong.

Have you tried a “Republish All Files” for the File menu?

Did you recently setup redirects to force SSL?

I have tried to Republish all files (a couple times). My guess is that some of the files are publishing to HTTP and not HTTPS.

But, yes, I did just recently setup redirects to force SSL. That’s when it changed.

You probably need to contact your web host. On most of the sites, http and https serve from the same directory, so the files should be the same.

Ahh okay. Yeah, I was thinking that. I was going to contact them but the wait time is like an hour so i wanted to be sure before I waited for them to connect and reply. Okay, I’ll contact them and see what they say.

I see that you are using Cloudflare. Have you cleared cache there? Or put it in dev mode?

Scratch that… it looks like its just the theme loading the JS from the Cloudflare CDN.

Well, I don’t know if maybe is using Cloudflare but I purchased my SSL Certificate through because I didn’t learn of cloudflare until after I had already purchased and set up the certificate.

Turn off the redirect so that we can see both versions online.

Okay, the redirect is turned off.

Did you update your project web address to be https?

What is your file links setting set to in the Advanced project settings?

Also… are you supposed to be able to use the Foundry stacks with another theme?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.