Using HTTPS breaks my site

I’ve been using http:// for a very long time. Now, users are reporting receiving a security warning when going to my site. I contacted my host provider and they corrected the SSL (don’t know what they did or why it needed correcting). Now, if my website is entered with https:// for a more secure site, the site is broken.

I changed all instances of http:// to https:// in RapidWeaver and re-published the entire site. I still have the problem, my host is pointing at RapidWeaver and I’m stuck not knowing what to do.

I’m very helpful for any advise or pointing me in the right direction. My website is Enter and you can observe that it breaks the site.

Many thanks.

It’s because some of the content being requested by the site is using HTTP, not https.

Some of those errors are becuase it looks like you’ve not updated the URL of the site in the RW project from HTTP to HTTPS and then done a full republish.

There also seems to be a script being called, which is also over http, so you need to edit that in the project too.

Thank you for the reply. I have gone through looking for http to change to https several times, but will carefully go back through again. I did update the site address to https in Settings/General and republished the entire site.

I also exported the site to a folder on my iMac and used Spotlight to search for http. The only thing found was a folder named HTTP, but I don’t know if that should be changed as well or even where to find it.


Did you add the call to the script yourself, maybe using an HTML stack? It seems to be connected to a map?

If not, it might be the theme doing it, in which case you might need to edit the theme or contact the dev. What theme are you using?

EDIT: Looks like it’s called MASSV and by Nick Cates? Sadly, he’s left the RW community with a message that he won’t be maintaining any of his products. His stacks got picked up by @joeworkman but I don’t think his themes did, so if the theme needs changing, which I think might be the case, you’ll need to DIY it, or get someone with more skill than me to do it.

I may be wrong though, it might not be a theme issue, so maybe wait for someone with more understanding if the theme side of things to come along and comment.

By the way, you don’t seem to be selling or gathering any data via the site, so you don’t HAVE to use HTTPS. So in theory you could get things put back to HTTP then setup a redirect for anyone mistakenly typing in HTTPS to send them to HTTP. This can be done easily with a few lines in an htaccess file.

Thank you TemplateRepo. The only reason I started down this path is because a client going to my site to schedule a photo shoot was using Chrome and a big security warning was displayed. I want to spend my time in photography, not website development so will take a look at going back to http rather than modifying a theme that is several years old and not supported, which could be no end to headaches.

Great advice!

I use Chrome, but haven’t used HTTP for some years, so double check I’m right first, before going back to HTTP!

My understanding is (was) though that http works fine, and users will only get the warning if they attempt to get to a site that is on http but by using https. In this instance users will get a warning. Butif, so long as they are either redirected back to http, or just use http from the outset, you’ll be good.

As I say though, I’ve not had a client on http for about five years now, so my memory might be hazy!

Saying all that though, editing the theme shouldn’t be too difficult, it really is just a case of changing all instances in it from HTTP to https.

There will never be an update to it, so no chance of your work ever being undone.

I would maybe go that route first, just be sure to make a copy of the theme and edit the copy, so when you mess it up, you’ve still got the original :wink:

1 Like

You get a warning of a kind on ALL modern browsers. you don’t get a pop-up but a “Not Secure” or broken pad lock in the address bar:

You also get a pretty big hit on search engines if you arem’t using https if that matters.

Might try a new supported theme.

A new theme…groan. But it is on the list of possible solutions. Still researching and communicating on it. I really appreciate the input. In RapidWeaver you can right-click on a theme and duplicate it, after that you can reveal it in the Finder and edit the html in the theme to link to https resources not http. If you’re not up to it, upload the theme here and I can try to fix it for you.

1 Like

Wow, that is generous of you. But first, know that I have two domain names, and The site is deployed to and is redirected to that. I don’t know if https is struggling with that or not and might be the cause of my trouble after my host changed the SSL. Sometimes I get technicians at my host that know what they are doing and other times not.
I took a quick look at the massv theme from Nick Cates. The version I have was updated by Nick prior to leaving the RW community. On this page there is a Find Order lookup link, I would get the latest copy of the theme. It has https now for the font-awesome and j-query and should fix the problem.

it will email you a link to download the newest theme update.

1 Like

OMG, so helpful! I just downloaded the zip file of the theme. But, I’m not sure how to use it to upgrade the theme in RW.

Actually, I may already have installed the last version. I found an archive of the theme which is the same version as the one I just downloaded. v1.2.5 If true, my problem is not yet over.

I have Version 1.2.5 and it doesn’t have the http but has https for the font-awesome or jquery. I didn’t change a thing:

Perhaps he didn’t update the version number. Just try installing it. Unzip it, right click on it and select open with RapidWeaver 8:


If you get any warnings about older versions just install it anyway:

After you install the new theme try republishing all file.

Thank you Doug. I made sure to use the theme just downloaded from Nick Cates site (v1.2.5), unzipped and opened it with RapidWeaver 7 (haven’t upgraded to v8). I then republished the entire site and tried to open my site ( but the site is still missing background graphics and the menu doesn’t work. (Scratching my head!)

My guess is that Something isn’t getting published correctly.

I just downloaded the same theme from Nick’s site and checked and the theme has the font awesome and jQuery setup to use https, just like my screenshots. I actually went into the newly downloaded theme and opened the package contents and inspected the code.

I then checked your site and the old HTTP references are still there as before. Either the theme didn’t get updated or the publishing isn’t working. Maybe you aren’t going to the correct path.

I would change something on the home page like maybe adding some text and see if the change publishes.

Agree with @teefers, you should also make sure you “Re-Publish All Files” next time you update.

CleanShot 2021-02-19 at 10.45.35@2x

I’ve been out most of the afternoon and just checked my site. Entering my URL with just http resolves to https. Of course, entering the URL using https also opens the site as expected and all graphics and menu’s work as they should.

That is definitely a change from earlier today. Honestly, I’m not sure why it works now although I’ve always suspected that if I complain enough to my host provider, behind the scenes they will finally make the right adjustment.

As I wrote earlier, points to where my website files are. The last change I made in RapidWeaver was to the location of where the files were being published. Just in case it mattered, I changed the location from to

Whatever, it seems I’m back in business now using https. I cannot tell you how appreciative I am for this community, I realize I’m not alone and there are quality people like yourselves that are willing to help.

Thank you again.