New podcast episodes


(ben) #1

Hello all you lovely Weavers!

If you haven’t subscribed to our free podcast yet (you should!), then you might have missed episode 27, which was released yesterday.

@dan and I discuss what you need to do before getting your first RapidWeaver site online. We also let you know about four new exciting addons this week and rant about web design trends.

And for those that subscribe to the RapidWeaver Community, you can listen to an interview I did with @Elixir :slight_smile:

Cheers for your ears!


(Adam Shiver) #2

Was a lot of fun just chatting about RapidWeaver and the Community! I really appreciate you having me on the podcast. Look forward to doing it again sometime in the future!


(Jason Bostick) #3

Thanks for answering my Q on the podcast. I must say that I am guilty of the preloader use. I tried it first just out of my childish “ooh, fancy spinny thing!” curiosity. I’ve since found actual practical applications for it though. For example, I am drafting up a site that has a large’ish header image (large in dimension, not really in file size), and it has a logo and title overlay. Everything loads briefly before the header image so it has this jumbled appearance before the image loads and properly spaces things out. Just seems like a distracting first impression for a user.

Admittedly, there are probably ways to fix that spacing issue that I just am unaware of so I still may be using the preloader unecessarily, but that’s the practical application for me.


(ben) #4

You’re right, there are ways to fix this.

Easiest is to set the header container height to the same as the image height, and choose a default background colour that best matches the image being used.

This way the header area is the correct height, and it has a background colour that kinda matches the image being loaded.

Do that and you shouldn’t see the “jumbled appearance” :slightly_smiling:

As a side note: I still don’t think that your reason for using the loading screen is better than actually getting some content in front of the user — I always say you should get some content in front of the user ASAP, so he/she knows that the page is loading and gets some visual feedback.


(Dick Sijtsma) #5

Hi there,
i’ve listened to your podcast. It is interesting. I like the shorter shows more then the long ones.
I have some comments on episode 26. You are telling to add a custom 404 page to a website. This is a good idea. But the way you suggest to add it is not completely correct. You tell to add it in the project and use any plugin you like to create the 404 page. But if you do it like that, the http header will sent the code 200: page found.
That’s a bad thing. Because a 404 error is used by search engines to delete pages from their index. That way, their index becomes more accurate, more up to date and they are able to give better ‘answers’ the next time for the same request.

So, in addition to what you’ve said in the podcast, you should tell your page to sent the correct http header. That is done easily in Rapidweaver too:

  1. name the page 404
  2. choose .php as the file type
  3. go to the third tab on the page inspector
  4. Choose : ‘Prefix’
  5. add the following code:
<?php header("HTTP/1.0 404 Not Found"); ?>
  1. publish

The step of calling the error-document in the .htaccess will stay the same.

So, just saying that a page is a 404 page, doesn’t mean it is a 404 page. Or, how Google likes to phrase it:

It’s like a giraffe wearing a name tag that says “dog.” Just because it says it’s a dog, doesn’t mean it’s actually a dog.

https://support.google.com/webmasters/answer/181708?hl=en

Which http header codes your pages are returning is easily checked with a lot of on-line tools. Here is one of them:

http://404checker.com/full-header-checker

I think you can use this info yourself for developing your new RealMac software site. Good luck.


(Steve Harlington) #6

Hi Dick

Thanks for the tip. I’ve followed your steps 1-6 above and when I run the 404checker all looks good

However, when I try and call an incorrect page all the stacks on the 404 page are jumbled up.

http://www.gooletriathlonclub.co.uk/error/ (This is the 404 page I created which looks fine)
http://www.gooletriathlonclub.co.uk/rubbish/
If I navigate to this page which doesn’t exist in my project file, the stacks on the page are not formatted correctly but the .htaccess file is forwarding the user to the page.

Any ideas why the stacks page is not formatted right when an incorrect URL is called yet when you call the 404 page all looks good.

Thanks
Steve


(Doobox Software) #7

I posted about this in another thread. But briefly :

You have RW in it’s default setting of “Links relative to page”.
When you visit the rubbish url and the 404 triggers, then the 404 page is served from this rubbish location, and links are relative to that page, as seen in a screen grab from your site below:

This is of course incorrect.
How to get around it?

  1. Change your RW settings to “links are relative to site root”. (unexpected side effects may occur with some stacks and themes, test.).

  2. Do the workaround I suggest in this thread :
    Should we make our own 404 pages for our beautiful bespoke sites?

If you se this workaround you should probable stop search engines indexing the 404 page as well by including this meta tag in the head of the 404 page :
<meta name="robots" content="noindex">


(Steve Harlington) #8

Hi Gary

Thanks for your response.

I changed my File Links are setting to: Relative to DOCROOT and published the site after checking each page for errors in the them and stacks. All looked OK

I then ddded your extra code in my htaccess file (See screen shot) but still have the same issue

Thanks
Steve


(Doobox Software) #9

Not sure what’s going on there. Just had another look round your site, and all the links still look relative to the pages.

Edit: Just been testing this myself. I’m not sure it’s even possible to get the links to the stacks css and stacks javascript files to resolve correctly by any means, in this situation.

I personally went with my 300 redirect option I pointed at.
This simply redirects the page to the 404 page just as if it were any other page if it finds the requested url is non existent, instead of serving a real 404 error it treats it as a 300 error.
The user is non the wiser.


(Steve Harlington) #10

The site is set to Relative to DOCROOT

I’ve set my .htaccess file to:
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . error/404.php [L,R=301]

Is that correct?

Is your 404 page a stacks page? Looks great!

Thanks
Steve


(Steve Harlington) #11

Hi Gary

Set my .htaccess file to:

ErrorDocument 404 http://www.gooletriathlonclub.co.uk/error/404.html

And all word well now.

Thanks for your support
Steve