Operation was aborted by an application callback message


(l webster) #1

Since updating to RW 8.0.3 I keep getting various messages when attempting to re-publish updates to my website, varying
from
“operation was aborted by an application callback” (most of the time)
to
"couldn’t sign in to your ftp server
or
“couldn’t connect to server” (when there had previously been a connection)

at which point the page hangs after only a few files have been processed, and then the application doesn’t respond so I have have to shut it down and start it up again. Sometimes it doesn’t even get beyond ‘starting process’.

I’ve tried re-setting passwords, checking and re-checking the cloud host settings, starting a new destination and deleting the old one, changing the connection speed and mode, all to no avail. Can you please help?

Thank you.


(Doug Bennett) #2

without more information, it’s going to be difficult to get help.
Have you tried publishing to a local folder? If that works, then folks would need to “tackle” each error your post says you are getting.
If the “publish to local works” then you can use an FTP client like Transmit, Forklift or FileZilla to publish. If you want to fix the publishing issue you are having with RapidWeaver I would suggest you see this KB article and follow the steps in order.


(l webster) #3

Thanks for the article and advice.

I published to a local folder then used FileZilla to transfer the files to the server (gridhost.co.uk) and got the message “This server does not support FTP over TLS. If you continue, your password and files will be sent in clear over the internet.”

Am thinking I need to get in touch with gridhost to see if they can do anything with their security settings and failing that, maybe reconsider the hosting server.

Thanks again


(l webster) #4

I’ve just tried republishing with RW7 with no problems so maybe it is a compatibility issue with RW8/mac/gridhost… At least I can still work with RW7


(Doug Bennett) #5

Publishing with FTP is, in fact, a poor process when it comes to security. Credentials (Password/login) are sent in the clear. RW7/RW8 will are sending that in the clear if you use FTP as the protocol, they just don’t warn you as FileZilla does.

I can’t tind “gridhost” support area, but you might look at and see if they support “SFTP”. All FTP applications and RapidWeaver support this. It’s much more secure and reliable than FTP. FTP was developed many years before the internet, and was intended for private networks.


(l webster) #6

Yes the gridhost support area seems to be non-existent, and on the control panel for the website, there are only basic details for FTP transfer and no option for SFTP.

Thanks for the info re FTP protocol, I wasn’t aware that the credentials are sent in the clear so need to find a server that can provide the support and security we all need in this day and age. Also gridhost don’t seem to support (as standard) the captcha software I was using on my contact form so I get a load of spam emails too so another reason to move on…

Thanks again.

Best regards.