Stops in mid publish


(Edward) #1

Hello,

Recently updated to RW 7.5.5. Did this on February 25th. Resolved most of my issues since upgrading.

Today however, I’ve tried to publish updates to my site and I get the following

hungup2

Hangs on Starting operation.

I checked the forum. Has this issue been resolved. Why would I be good to go for a couple of weeks, then the above issue occurs?

Last night I finally deleted versions 4+ and 5+ as I am now comfortable with 7.5.5


(Rob D) #2

Hi, Edward,

Many of us have problems with the built-in publishing system. So, to work around this, we do a local export instead. Then, using a FTP app (Transmit, Yummy, Filezilla, etc.) we manually upload locally exported files to our servers. BTW, this is my preferred method, because I have more control over all my files on server.

Besides that, I would get in touch with RMS tech support.


(Eric Vaughn) #3

Go to your publishing settings and adjust your connections speed to a slower speed.


(Edward) #4

Hi Rob D,

I installed an old copy of yummy and set things up for just that. Funny thing is, I exported my entire site just to test, and it worked. I then changed a few things around for giggles, and RW published without a hitch.

But still, I’ve got yummy on deck for any future hiccups.

Thanks for the reply/help.


(Edward) #5

Greetings Eric V,

I’ll keep that in mind if things get wonky again. Right now I have my settings at 4. RW decided to start working again. Not asking why, just gonna accept.

Thanks for the reply/help.


(Rob D) #6

I’m glad it works for you again, Edward…


(Doug Bennett) #7

One thing that I would recommend if you’re not already doing is to NOT use FTP. That includes with FTP clients like transmit or yummy.
All FTP clients including RapidWeaver and Most all host companies support SFTP. If your hosting company doesn’t support SFTP change to one that does.

FTP is not secure, your complete server credentials including password are transmitted in the clear. It’s an old protocol (predates the Internet by over a decade) and requires a lot of “handshakes” for every packet that gets transmitted.


(Edward) #8

Can’t seem to log in using SFTP. FTPS works, but I get a warning regarding the certificate. Is there a difference? I use hostgator.


(Doug Bennett) #9

SFTP and FTPS are different, but both are secure.
SFTP is FTP over SSH (Secure Shell). The SSH is established and then the FTP login credentials are sent (never in the clear). The shell session(s) once established don’t require near the amount of overhead (handshaking) then straight FTP does, so the session is much more reliable.
FTPS is FTP with SSL (TLS) that is like an https connection (certificate with public/private key). Don’t know what certificate warning you are getting but, usually, it’s because the certificate was signed off by a known certificate authority (CA), might be expired or is self-signed. If the certificate is self-signed then you can around that.

between the two protocols, SFTP and FTPS are both very secure with strong authentication options. FTPS can be very difficult to patch through a tightly secured firewall since FTPS uses multiple port numbers.

Per the HostGator documentation, unless you are on windows shared plan, you should be able to use SFTP. You may have to change the port number depending on the plan.
In RapidWeaver publishing settings you change the port number by adding a colon : followed by the port number to the FTP server name.

ftp.example.com:2222
HostGator Doc:
https://support.hostgator.com/articles/specialized-help/ftp/secure-ftp-sftp-and-ftps


(Edward) #10
  • update*

FTPS wont upload. Keeps trying and retrying.

Looking at the link you provided. Okay … when switching over to SFTP

server connections

username password

path

website address

use public key authentication
choose private key
choose public key

passphrase

backup frequency

Where do I find the port setting?


(Doug Bennett) #11

In RapidWeaver, you add the port number to the end of the Server field separate the server name with a colon : then the port number. Most FTP clients have a field for the port number. This screenshot would publish to port 2222:
2018-03-13_13-56-56


(Edward) #12

ah … the article shows ‘ftpes’

Lets try again


(Edward) #13

test button works. uploading does not. I’ve got a tech on live chat looking into it now. Stay tuned.


(Edward) #14

It’s a no go. Guess it’s time to find a new hosting company.


(system) #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.