Override UIKit Fonts in RapidcartPro - SOLVED


(Lisa Sandler) #1

@rob

Does anyone know how to use the UIKit in Rapidcart Pro and stop it from overriding my site-wide font? I’d like to change the appearance of the button colors and backgrounds, but cannot keep my fonts in doing so.

Well, I deleted the UIKit code and it’s still applying to my files. This is ridiculous. @rob please come out of hiding!

thanks, Lisa


(Roberto Tremonti) #2

By disabling “Force Base Style” in Customization > Settings > General window, no font is loaded by RapidCart Pro (UIkit).
If the font is still overridden, please check if you have loaded a custom style with UIkit Customizer in Customization > Style window.
In this case, at line 2 you should see a rule related to the font.
Just remove it and republish the page.


(Lisa Sandler) #3

I have always had “force base style” disabled. I tried deleting all the UIkit code but it’s still applying. Where do I go from here? https://www.lisasandlerphotography.com/client-store/?catalog/all/-/date/1
Thanks


(Roberto Tremonti) #4

Please try to republish all files.
You find the option in RapidWeaver main menu.


(Roberto Tremonti) #5

I confirm there’s a problem when the Style window is completely empty.

Please remove all the code and add a space or a new line.
Or just remove the second line only, the one with the font rule.

It will be fixed in next update.


(Lisa Sandler) #6

ok. that was driving me crazy as I tried republishing all several times.


(Lisa Sandler) #7

FYI-
There were other lines with fonts. I was able to find them and delete them and now I have my fonts :slight_smile:


(Roberto Tremonti) #8

Oorahy! :smiley:

Thanks for your feedback.


(Lisa Sandler) #9

Yes… I am able to fix it taking out that part of the code… but for future, this does not work: By disabling “Force Base Style” in Customization > Settings > General window, no font is loaded by RapidCart Pro (UIkit).


(Roberto Tremonti) #10

Well, this actually works.
But if you used UIkit Customizer you need to remove also all base style rules in Style window.


(Lisa Sandler) #11

Ok, it works? But only if you remove more code? So it’s not a total override. It would be helpful if you add that to the manual :slight_smile:
Thanks