Parent Menu Items that do not link to anything

I have some menu items (e.g. Home) that have no sub-menu items (children). Where I do have a menu item with children, I want to have the ability for the parent item to go nowhere. In other words the sole purpose of the parent menu item is to group together the child menu items that link to whatever I want to present.

The closest I have got is to use the Blueball FreeStack Responsive - FereeStack R NavMenu Res3 in conjunction with the Marathia NoLink stack. The NoLink stack is not elegant but it works for everything except “mobile land.”

I’ve asked NimbleHost about myMenu, but it doesn’t appear to have this capability.

Does anyone have any suggestions for implementing this capability in responsive website?


Hi David,
I had the same problem with a site I’m putting together using Foundation’s Top Bar.
The answers I got from this Forum were spot on.
Here’s the link and I hope it helps:

Top Bar Menu set up


Thanks Mike. I assume this solution requires the Foundation Theme and the Stacks? That’s quite a major upheaval for me having built the site with other components. But perhaps that’s the only way just now.


Marathia has a couple of stacks that might help. Go to StackCentral and enter Links and Marathia in the relevant categories and you’ll find them.

RapidWeaver Central

You can also try an offsite page type with a simple # in the link field.

You’ve mentioned myMenu by NimbleHost. You could configure it in such way, that only children have an URL assigned to them (but not parents).

No, the solution does not require the Foundation theme and stacks, just use an Offsite page like was suggested by @tav with any theme and it will work, just do not set a link for the Offsite page.

Hi David,

I bow to others more experienced than I am who use RW on here. It worked for me as I was doing a full re-write of a site - only the text from my original remained, and I was already using Foundation et al.

Hope it works out for you.

I’m trying to do the same thing as David but not having any luck. If I make the Parent page an offsite page (in RW6) and leave it as “Show in Navigation” but erase the" http: " under Offsite Options what happens is that the Parent page in Preview just flashes. When I publish that page nothing shows as being published but in the published site, clicking on that Parent in the menu just keeps trying to reload the page. I’m probably not explaining this very well but the site is and I’ve only tried to do this to the INFORMATION page.

I also tried just putting a # in the Offsite Options section in place of any URL and get the same thing. What am I doing wrong? The theme is Themeflood’s Ocean if that makes any difference.

TIA for any suggestions.


Hi Mary,

I originally asked this question because I was having a problem using Marathia’s NoLink stack. For me this problem only occurred when the site was accessed from “mobile land” when the responsive menu I was using needed to become drop-down i.e. access from smart phone. It is probably a conflict between the Marathia NoLink stack and the menu stack I as using (Blueball Responsive). Unfortunately neither stack authors are able to help me just yet.

I mention this because, although it is not the most elegant solution, the NoLink stack achieves what I wanted. It may well work for you.

Thanks for the suggestion of using the NoLink stack Dave. I’ll look into that. There are so many stacks out there!


I am having the same issue. My site has one theme for the home page (Chunky by Yuzool) and a different (Foundation) for the rest. The trick of using an offsite page with a # instead of the URL works for all the Foundation pages, but not with the home page.

If you need an example, if you go to this page and try to click ‘Portfolio’, it works as intended. But if you try it off the homepage (, it doesn’t.

Any idea of how I can fix it?

I came up with a workaround for my problem and maybe it would work for you.
I made the parent page a styled text page and let it show in navigation.
Tthen I took away all the theme properties for that page.
You can see this at if you look at the “The Cats” or the “Adopt A Cat” pages.
I couldn’t get the parent page to not be clickable (the hand shows up and it will take you to a black page when clicked). I like the way yours doesn’t even allow you to click. Don’t know how to do that.


The way I did it - I looked at the source code of my published foundation pages (where the effect was working) and compared it to the home page, and then went in the index.html file and changed it from:

[li][a href=“portfolio.html” rel=""][header]Portfolio[/header][/a]
[li][a href=“javascript:void(0)” rel=""][header]Portfolio[/header][/a]

(I changed all the <>'s to []'s, so it would show up on the forum)
You could give that a shot.

The problem would be that, every time I made a change, I’d need to go into the server files and edit as above. Michael from Yuzool suggested I put the javascript:void(0) into the page link in Rapidweaver as a possible fix but I havent had a chance to test it out yet.

1 Like


I’m trying to remove menu link and javascript:void(0) worked, but I’d like to fix it inside RW to avoid editing all pages after site updates.
I found this but it didn’t worked for me:

Is there a way to insert the javascript:void(0) in page javascript area?


Hey Mary,
I am experiencing exactly the same effects like you described. Although this topic is some months old - did you find a solution for your problem?

If this is still a problem for some of you people, a lot of themes that i have, have “Disable Parent Pages” in the Themes Styles settings, in fact nowadays i dont ever purchase a theme at all IF it doesnt have this option !!!


I can easily remember (not easy these days) that Henk and Nick Cates has the “disable parent page links” as a Style option and there are probably more, but those that dont, do say that it doesnt work correctly on touchscreens, but i can honestly say i havent had any problems . perhaps @willwood can put us right.


From Joe:

/* Instructions - Please Read

This snippet will allow you to disable a page’s menu item from linking to the page. This is great if you want a page to act as a placeholder in the menu, forcing visitors to navigate to a sub-page under it.

  1. Insert this snippet in the Javascript tab in RapidWeaver’s Page Inspector.

// Insert this snippet in the Javascript tab in RapidWeaver’s Page Inspector.
// You will need to modify the nav link list in the code below
// to contain the name of the pages that you want to disable.
document.addEventListener(“DOMContentLoaded”,function(event) {

// Add your Navigation titles to this list
var nav_titles = [‘Page 1’,‘Page 2’,‘Page 3’,‘Page 4’];

// ------------------------------------------
// Do not modify below this line
var links = document.querySelectorAll(‘ul li a’);
for (var i = 0; i < links.length; i++) {
if (nav_titles.indexOf(links[i].textContent) >= 0) links[i].href = ‘javascript:void(0)’;


@caffeineinjection @timmytoad Disabled / suppressed parent page links used to be a feature in many of my ThemeFlood RapidWeaver themes a couple of years ago. Touch screens and website accessibility were one factor in me removing support for disabled links, but not the main problem…

I found that disabled links were SEO suicide. Seriously - people would turn on support for disabled links in the theme settings and then a few days later their websites would plummet from Google search results.

After trawling through analytics and webmaster reports, it would transpire that these disabled pages were seen as broken links or blank pages to search engines. Often search engines could not see or reach the pages under disabled links.

You have to remember that search engines have extremely limited support for Javascript or CSS - they basically see the same you see when you print a webpage. If you break the navigation flow through a website, it can have repercussions.

Given the prominence high-up in sitemaps these disabled page links often occupied, this sometimes led to catastrophic SEO issues for some theme customers. It became apparent more and more people were hitting the same problems.

Obviously I don’t what to include stuff in my themes which is knowingly going to cause people grief! So I took the very public decision to pull the feature from my themes. Life has been good ever since…

I don’t know what mechanisms other developers use in their themes to disable links. But however you look at it, it’s a hack; so there’s possibly going to be consequences elsewhere of doing it.

My advice remains to keep all pages active and populated with content. Build a website around your content, not around your theme or navigation structure. For example, some websites do not need drop-down menu’s; a simple split or sidebar block navigation can often prove more than adequate.