PayPal and Paddle Issue


(John W) #1

I tried to purchase RapidWeaver 7 upgrade and the transaction never completes

  1. Asked and entered email
  2. Asked and entered Zip Code
  3. Goes to PayPal login
    4, Entered PayPal email
  4. Entered Password
  5. Goes to the Pay with page
  6. Shows credit card
  7. Click Continue
  8. Got a processing message
  9. got a securely logging on message
  10. Then it goes back to the Pay With page.
    Transaction does not complete. I only have issues with paddle.
    Non Paddle sites work fine with PayPal
    I tried the RealMac support email, Twitter and no one ever got back. So I will give this a shot

(Will Woodgate) #2

Try a different web browser or incognito window to make the transaction. Sometimes a web browser auto-fills fields or deletes what you have already entered.


(John W) #3

I tired different browsers (including PC’s) and incognito/private browsing. I am in the US and I need to go through PayPal for for international purchases. I don’t have any issues with sites that use someone other than Paddle. When I go through the other sites the Pay View windows shows ATM/Debit/CC X last 4 CC numbers.
When I goth through Paddle it shows just X last 4 CC numbers. It does sign me into PayPal and shows the CC but the transaction never goes through. I don’t get any failure messages, so I don’t believe it is on my side. And since it appears to be only on Paddle it is probably their problem. I have reported this to Paddle, RapidWeaver Support/Twitter and have heard nothing back. I would assume they would be interested since it affects their sales.

PS: I tried purchasing you Earthquake Theme and I had the same issue on your site


(Will Woodgate) #4

I don’t know what a ‘Pay View window’ is. Some third-party software or wallet you’ve installed on your computer perhaps? This is getting very confusing.

Record a screencast of what you’re doing (Quicktime > File > New Screen Recording) as you navigate through the checkout. Upload this video to Dropbox or a similar service and get its shared link.

Open a support request here and provide Paddle with a link to view your video:
http://help.paddle.com/
(The contact button is top right).

Also give Paddle a link to this thread and any other relevant information, like the email address you use for your PayPal account.

If somebody can see the issue visually (even if they cannot replicate it themselves) it will make things much easier to understand and hopefully resolve.

I assume your PayPal account is verified and is in a healthy state. No ongoing eBay disputes, recently changed details or similar etc?


(Tom) #5

Just had the same thing happen to me this weekend when attempting to purchase a stack from a developer. I then got two emails from “Paddle” indicating I had left an item in my shopping cart along with a link to complete purchase (which I didn’t do and unfortunately deleted emails). This AM, my virus protection program quarantined Rapidweaver because of something related to “Paddle” (not sure if that is the payment program or a Rapidweaver file). I’m out of luck right now; contacted Realmac and hope to hear something soon. Also contacted developer who forwarded details to Paddle.


(NeilUK) #6

I ALWAYS have trouble when buying stuff on sites that use Paddle. Now, I simply don’t buy anything where the only payment option is Paddle.


(Tom) #7

Sorry to hear that, Neil. Have to say I never had a problem with Paddle before. I’m being selfish now: more concerned about the malware report and, particularly, the fact that I can’t open Rapidweaver for the time being.


(Jannis from inStacks Software) #8

To comment on this as a developer using Paddle for my checkout:

  1. never had an issue before, either as customer, nor as developer with Paddle regarding this
  2. For a malware report concerning a virus in an email, you have to check you anti virus app. Paddle does not send any files inside emails.
  3. Most probably, you purchased RW via Paddle. Maybe this is related. If you could post some screenshots on the issue, we might be able to help.

(Jannis from inStacks Software) #9

I guess that is related to the Paddle Framework SDK (Software Development Kit) located inside RapidWeaver.
This is not an issue and most probably a false positive.

@dan FYI

2017-09-26_17-15-03


Malware warning
(Tom) #10

Ah Janis, you are a magician. Thanks very much for pointing that out … your usual prompt help and support is appreciated.