Problem with dark mode in 8.1.1


(Frank Marten) #1

My Mac is set for dark mode and when editing blog entries, as the text is black, it is a real pain to edit as it is black on black.


(Neil Egginton) #2

Yes, I have found the same issue, but it appears to only affect blog pages that were converted from a previous version of RW.

If I create a new blog page in RW8, the text is white.


(Isaiah Carew) #3

I have seen the same thing – not just in the Blog pages, but in other areas in RW that have Styled Text (like the sidebar). And it’s just as @NeilUK suggests – existing content is problematic, but new content/pages/posts seems fine.

// @dan @tpbradley


( ) #4

Hi @martef86,

Are you copying content over from a word-editor, like Word or Pages? If so, you’ll need to copy over as plain text (Option+Shift+Command+V) and format from within RapidWeaver.

To clean this up, select the text and go to Format > Clear Formatting.


(Frank Marten) #5

I have tested this with plain text, text copied from a web page and from Pages.
Plain text (such as from BBEdit) is black on black as is from Pages. Option+Shift+Command+V is also the same. Copying and pasting from a web page gives a white background with black text.
Also, when creating a new blog entry, it uses the font size and character size etc from the former entry. This could be good but can be very annoying.
In my case, I turn off dark mode when using RapidWeaver as it is too annoying otherwise.


(Bob Bassett) #6

I am experiencing exactly the same problem having upgraded to Mojave a few days ago and having just selected Dark Mode. If I create a new blog page everything is fine, but existing blog pages are black text on a dark background, so can’t be edited without switching to Light Mode. These blogs were originally created in V7, so the suggestion that this might be the cause seems valid. But a lot of the posts have been added in V8 and all are equally affected, as is any new post that I try to add.

Clearing formatting reveals the text, but it also removes the chosen text colour that the theme has applied, which is fine if you’re happy to use black! It would be nice to have a global fix.

I’m running Mojave 10.14.3 and RW 8.1.3.


(Bob Bassett) #7

8.1.4 has fixed it for me. Thank you.