Problems with changing font colours etc

Hi, I am Yuri – and new to this forum. I have used RapidWeaver before but haven’t done any major project in years. Now I’ve updated to RapidWeaver 8 and started a new, rather big (at least for my standards) project… At the moment I am still in the phase of playing around with my theme (Traveler) and setting up the basic website look and structure. It’s going rather well but I am now completely stuck with a problem that seems to be very basic: I cannot, for whatever reason, do changes in certain stacks regarding font color, size etc.
Precisely: Whenever I add a new text stack (I am currently trying to add a footer with company information etc. as a partial on the bottom of my bottom extra content container) into the theme it will just show as black. When e.g. I change the colour in the edit mode it will show there – but not in the preview mode. It doesn’t matter if I hit “clear formatting” first or do whatever else.
Now what makes all this more confusing is the fact that actually sometimes (I’ve done various test fields) the changes do show after switching a couple times between edit and preview mode. But this happens only very rarely and I cannot see any sort of regularity here. I’ve searched the forum for similar problems but it seems I am the only one who experiences this… Can anybody help me, please?

Hi Yuri and welcome to the forum,

The text stack you are using, is that the standard (included with stacks) text stack?

How are you changing the color?

Have you tried actually publishing a test page?

That kinda sounds like whatever your changing isn’t triggering the preview to get refreshed. That’s why I was asking about a published page.

The difference between edit and previews could also be caused by the theme overriding what you changed in an edit.

If you could try to publish even if just a test page, and post a URL here, it would help you get some help from us.

Thanks a lot Doug! That’s indeed also what I suspect… The thing is: I can edit text-colors (etc.) in other areas of the page, and they show up fine in preview mode. As far as I can tell at the moment, it is just in “Extra Content No. 7” where it doesn’t work.
However, I can’t follow up on your suggestion to do a publishing test yet because I haven’t yet got the domain registered… Maybe I should do that now before I do anything else…

If you change the color or content in the extra content area and then preview it and it doesn’t change, then try going back to edit mode and change something else on the page outside of the EC area. Now if you go back to preview does the earlier change to the EC area now show up?

If that’s the case, then it’s definitely pointing at a preview not triggering a change.

You said that this is happening inside a partial? What version of stacks are you using?

I’d also try the partial on the page itself (outside the extra content area) and see how it displays. That could help narrow it down to either the partial (and stacks inside) or something with the theme and the extra content area.

Have you checked the Master Style settings? It may be that the Extra Content area you’re using is set to use a particular set of colours and that is over-riding any attempt you make to change it.

If that’s the case, then just change it in Master Style.


It would help if we knew RW version, Stacks version and Theme used.

OP said RW8 and Traveler theme. I’m thinking if it’s stacks 4, there’s an open bug about preview and partials. Might be related.

Sorry…I missed that

Could it be that the content whose styling will not change was perhaps paste content from another app that is carrying over the styling from its original location?

Hey guys, thanks so much for your fast and awesome help! I think I am slowly getting there now! And it seems that most if not all of your suggestions seem to help to track down the problem(s):

  • Yes, it’s RW8, Traveler Theme and Stacks 4.0.3. And I really think that there is a problem with the preview mode! Now two times today, when I went back to look at the preview, suddenly things showed up completely in the wrong colour or went missing altogether. After an initial shock and clicking back to Edit mode and back again, it was all there and normal. This affects also other parts of the page that normally work fine. So it could be just a preview bug…

  • Also I have checked out Don’s suggestion, but the other way round: I have done the same thing WITHOUT using a partial (but in the ExtraContent area No. 7) and I get similar problems. So it’s probably not the partial’s fault.

  • However, I also suppose that what Rob and Elixir suggested, is indeed the case as well: It helps to copy my text first into TextEdit or use the “Paste as Plain Text” function and things work (mostly) much more smoothly.

It still could be something about the stacks being in the extra content area. I’d copy/paste the stacks out of the ExtraContent area and see how they display there.

Always paste content with Paste as Plain Text. Embedded formatting from other apps can cause lots of things that are not easy to see.

You are right! I tried it (put the partial into the normal content area) and again it does strange things: This time, it is easy to change the font size (displays correctly in Preview mode) but it won’t change the colour at all. Again: You can see colour changes in the edit mode but not in preview.
Perhaps it’s the master style that causes the conflict? But in other places I had no problem changing the font colour of some parts no matter what is defined in the master style… :thinking:

You could try temporarily changing to a different theme to see if the theme is affecting the styling.

Have you tried rebuilding the section you’re working on from scratch? Add one thing at a time to the are and see when preview stops showing what you expect. Don’t paste any text. Just type in anything for now just to see how it looks.

Beyond that, we’d really need to see a live page once you have hosting sorted to be of more help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.