Project has been changed by another application?


#1

I’ve been getting messages the past few days that my RW project file has been changed in another application. I’m not aware of how or why this could happen, has anyone else experienced this at all?

I’ve seen that this was broached in another topic but no definitive answer or solution was provided.

Realmac? Anyone?

Cheers,
Beem


(Greg Schneck) #2

Hello,
I just had this happen about an hour ago. I had two projects open at the time and both had Page Inspector open as separate window. I did a “save” on one project. When I went to the other I received the “changed in another app” message.


#3

Thanks @1611mac, in my case I only have one project open so it can’t be related (I think!). Thanks for the input though.


(Greg Schneck) #4

I did have that happen before but I forget the circumstance (perhaps I posted the other thread you saw… I forget). Did you have Page Inspector open as a separate window?


#5

Nope, I didn’t. One instance of RW open, with a single project open.


(Jason Bostick) #6

I’ve had that error as well but only once and not sure how to replicate it. I know that isn’t helpful but just adding my instance to the log.


(Isaiah Carew) #7

Not sure if this helps, but it worked for me…

I saw something similar after installing Sierra (both in RapidWeaver and other apps). I disabled the new “feature” Optimize Mac Storage – and have not seen it since.


#8

Thanks @isaiah but I’m still on El Capitan. Appreciate the suggestion though.


(Isaiah Carew) #9

OK, brainstorming a couple other possabilites:

  • Did you update RapidWeaver recently?
    There have been a lot of updates recently and when an update finishes it launches the new version – and for a small moment there is a time when two instances are running. If that process doesn’t go smoothly, for whatever reason, perhaps that could generate that sort of error.

  • Crashed recently?
    Perhaps there is some remnant of a crash still running somewhere? You might try logging out of your user account and then back in – or rebooting to see if that clears things up.

  • Other utilities?
    There are other utilities like iCloud that do background syncing. I use dropbox all the time and don’t notice that sort of thing – but it doesn’t seem out of the realm os possibility that Dropbox or another similar utility could cause this sort of behavior.

  • Other
    There are a few “cleaning” utilities like MacKeeper that do horrible awful things that border on malware in the name of “fixing” your machine. Use anything that claims to fix/clean/optimize your Mac?

I think that’s all the brainstorm items that I have. :slight_smile:

Isaiah


(Greg Schneck) #10

Isaiah… none of those things apply in my particular case… except for… “Crashed recently” - I still receive a few crashes every day but I had not had one when this happened. (I’m the one who had this happen this morning when I had two project open. Refer to earlier in thread.)

Like Beemerang (who started the post)… I’m still on El Capitan.


#11

Yep, I did update to 7.1.5 on one machine but the other is on 7.1.4 and gives the same message. Also, i download the full update instead of applying the incremental one so I think I can rule this out?

Yep did have to do some Force Quits due to publishing cancel feature not working correctly but I always shut down completely and reboot before opening RW again.

This could be it as I store my RW files in Dropbox. However, I never open the same project on different machines at the same time and always ensure that Dropbox has updated completely before I open a
project

.[quote=“isaiah, post:9, topic:10449”]
Other
There are a few “cleaning” utilities like MacKeeper that do horrible awful things that border on malware in the name of “fixing” your machine. Use anything that claims to fix/clean/optimize your Mac?
[/quote]

I stay away from these after a bad experience earlier in my “Mac career” but good to know.

Thanks for the suggestions @isaiah, I’ll keep a close eye on my Dx deployment, seems the most likely culprit.

Cheers,
Been


(Greg Schneck) #12

As info only… I don’t keep my active projects in dropbox. Rapidweaver folder also is in original location (Library). So perhaps a Dropbox issue can be ruled out??


(Greg Schneck) #13

I just received this msg again. No crashes today… I’ve worked on several projects. I opened one project (and only one) and marked some stacks as “favorite.” I did a save and then received the “project changed by another application” msg. As best I remember clicking some stacks to “favorites” was the only thing I did. I have the latest RW version and also the latest Stacks3 version.

I don’t use backups (I do my own Project backups) nor any aspect of iCloud that I know of.


(Bart-Jan Schuman) #14

I get the same message.
Happened at least with 7.1.6, just updated to latest RW (7.1.7)

Open project, add new page with “+” button, “Stacks”, rename from “untitled page” to SHP622 (happens al the time, actual name does not matter), save. up comes message.
MacOS 10.11,