Project file is corrupt


(Pascal de Roo) #1

I have made several sites in RW6 and they all work fine. Yesterday however I wanted to change one page in one of the project with a photo slider and when I inserted one picture, the program looped and I had to reboot my Mac.

Now this project cannot be opened again, can anyone help me or have a suggestion? The site is still live but cannot be edited anymore :frowning:

There is no import function in RW and I have no backup from the correct last file


(Brad Halstead) #2

@Pascal

Hi Pascal and welcome to the forums…

You don’t have a Time Machine backup either?

What’s the error message you get when you try to open the project?

If no backup and the project is truly corrupted, there is little to be done other than rebuild it. Use an FTP program, download all the files from the server (This way you have access to your resources, can view the source to see the stacks used on each page, etc). When copying text, be sure to paste it into RW Project using Paste as Plain Text so you’re not copying formatting into the project and possibly causing issues with your site.

After rebuilding, Export to a desktop folder and preview, making sure it is close if not exactly the same as your online version, tweak as necessary and you should be good to go.

Sorry don’t have a better solution for you :frowning:

Brad


(Mark Sealey) #3

Pascal,

So sorry to hear of such a disappointing experience :frowning:

You might want to investigate why you had to reboot you entire Mac: under OS X each Application runs in its own protected memory space and it’s rare - especially in the case of well-written and well-established software like RapidWeaver - for an entire system to be compromised.

Have you tried looking in your logs for a clue as to what could have been going on?

Good luck!


(Pascal de Roo) #4

@Turtle Thnks, not THE answer I was looking for of course but maybe wise to do so :disappointed:

Because the site is still live, I can make a copy

In console I got this:

17-01-16 08:52:11,628 RapidWeaver 6[6220]: *** Assertion failure in -[RMPromiseOperation _invokeBlock], /Users/Nik/Code/Realmac/RapidWeaver/RapidWeaver/Application/Vendor/RMCocoa/CoreConcurrency/RMCoreConcurrency/RMPromiseOperation.m:41
17-01-16 08:52:11,630 RapidWeaver 6[6220]: Handling uncaught exception…
17-01-16 08:52:11,630 RapidWeaver 6[6220]: *** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘Invalid parameter not satisfying: resultError != nil’
*** First throw call stack:
(
0 CoreFoundation 0x00007fff8bb52ae2 __exceptionPreprocess + 178
1 libobjc.A.dylib 0x00007fff9a454f7e objc_exception_throw + 48
2 CoreFoundation 0x00007fff8bb528ba +[NSException raise:format:arguments:] + 106
3 Foundation 0x00007fff9461688c -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 198
4 RMCoreConcurrency 0x000000010fd360e6 -[RMPromiseOperation _invokeBlock] + 392
5 RMCoreConcurrency 0x000000010fd35f49 -[RMPromiseOperation main] + 27
6 Foundation 0x00007fff945ab2fb -[__NSOperationInternal _start:] + 654
7 Foundation 0x00007fff945aade7 __NSOQSchedule_f + 194
8 libdispatch.dylib 0x00007fff9590733f _dispatch_client_callout + 8
9 libdispatch.dylib 0x00007fff9591ac1d _dispatch_main_queue_callback_4CF + 1685
10 CoreFoundation 0x00007fff8ba98cd9 CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE + 9
11 CoreFoundation 0x00007fff8ba53d3d __CFRunLoopRun + 1949
12 CoreFoundation 0x00007fff8ba53338 CFRunLoopRunSpecific + 296
13 HIToolbox 0x00007fff9140a935 RunCurrentEventLoopInMode + 235
14 HIToolbox 0x00007fff9140a76f ReceiveNextEventCommon + 432
15 HIToolbox 0x00007fff9140a5af _BlockUntilNextEventMatchingListInModeWithFilter + 71
16 AppKit 0x00007fff8cfad0ee _DPSNextEvent + 1067
17 AppKit 0x00007fff8d379943 -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 454
18 AppKit 0x00007fff8cfa2fc8 -[NSApplication run] + 682
19 AppKit 0x00007fff8cf25520 NSApplicationMain + 1176
20 libdyld.dylib 0x00007fff9850b5ad start + 1
21 ??? 0x0000000000000001 0x0 + 1
)

And then RW stopt with:

17-01-16 08:52:11,630 RapidWeaver 6[6220]: Handling crash with signal 6…


(Pascal de Roo) #5

can I sent you the project bij mail? Maybe you can open it?


(Brad Halstead) #6

@Pascal

Did you happen to do some Stack updates or Plugin updates during editing the project?

RE: Sending project via email, I will PM you my email address.

Thanks
Brad


(Mark Sealey) #7

Pascal,

Log files are a specialist area. But I suspect that RealMac’s engineers would find this useful. Suggest opening a ticket with them. At the very least they will want to know whether RW really is responsible for crashing your entire system!

Which exact versions of RW and the OS are you ringing, Pascal?

Does anything else crash?

Good luck :slight_smile: .


(Peter Danckwerts) #8

I’ve had a few corrupt RW files. Sometimes, if you copy them they seem to get repaired. Certainly worth trying.


(Pascal de Roo) #9

That could be indeed - update of a stack

All the other projects are working fine now and no problems with applications on Mac

Version 6.3.7 (15153) on OS X


(Michael M.) #10

Sometimes it can help to rename the project file and then try again to open it.


(Pascal de Roo) #11

unfortunately also the copy is corrupt


(Pascal de Roo) #12

tried, but nothing :sob:


(Michael M.) #13

Then you should contact support@realmacsoftware.com maybe they can help you. An d next time you should make backups. It’s so easy with TimeMachine…


(Brad Halstead) #14

@Pascal

Hi Pascal

The project sandwich file definitely has corrupt files in it for 5 different pages, from what I can gather, is that you had an Adobe product open at the same time whilst using RapidWeaver and some of the Adobe stuff somehow got into the sandwich (project).

Renaming the project did nothing
Relocating the project did nothing
Making a copy did nothing

My suggestion is to send an email to support@realmacsoftware.com, include a detailed report of:

  1. OSX Version
  2. RW Version
  3. Theme name, plugins and stacks used for this project
  4. What you were doing when RapidWeaver crashed
  5. What other apps you had open at the same time, if you can remember
  6. A crash report from the RapidWeaver logs…

The RapidWeaver logs can be generated by opening RapidWeaver -> Help -> Copy Support Logs

Paste these into a TXT file and save it as “yourname_project_logs.txt”

  1. ZIP the project file and the TXT file you just created and upload to the same sharing service and provide link in the email to support

  2. Please provide them with a link to this thread too so they can see what was tried.

  3. When it crashed on me, I sent the Crash reporter logs to them as well so they have a heads up, you can reference that as well if you like in your email to them.

This will give them the most complete picture of what was happening when the crash occurred and possibly why.

Sorry I couldn’t be more help with this but this definitely will give you and Realmac Software the best chance of finding and possibly repairing the issue (NO Guarantee though).

No option but to rebuild from live site… sorry dude!

Best I can do Pascal

Good Luck
Brad


(Brian LaPan) #15

Hey Pascal,

I just came across this thread. When you do send in a report/file to Realmac Software please also send an email to support@realmacsoftware.com in addition to the file via WeTransfer. If we don’t expect the file then we won’t know what to do with it (and won’t start looking at it). I’ve connected that file to this thread now.


(Pascal de Roo) #16

I did sent the file and information. Could you give me an update if you can be of any assistance

Thanks so much


(Brian LaPan) #17

Someone should be getting back to you soon.


(Nik Fletcher) #18

Hi Pascal

Unfortunately, the data within the project file is corrupted:

21/01/2016 10:38:51.547 RapidWeaver 6[2032]: *** -[NSKeyedUnarchiver initForReadingWithData:]: data is NULL

This means that the data cannot be read, and as it’s a binary file we cannot reconstruct its contents.

—Nik


(Pascal de Roo) #19

Is there an import function from ftp server?


(Mark Sealey) #20

Pascal,

There’s really no way to import data that way into RapidWeaver, although you should be able to download the actual html (etc?) files from your site via ftp and reconstruct a new project using the text and graphics etc which you can display - after you have downloaded them - in a browser locally.

In total sympathy and support, may I suggest this and one of these?

Good luck!