Publication Cacheing Issues - SOLVED


(Robert King) #1

I am having problems with a cache that looks to be caused by RapidWeaver publishing. The file image on the server is correct. At one time there were spaces in some folder names within RapidWeaver. This problem has long been corrected. Unfortunately RapidWeaver uses the old names when publishing the URL’s. Below is a link that was created by RapidWeaver to access a product page.

404 Error
The requested URL /productPages/Cutlery/Cutlery Pieces/Man Law Pizza Cutter/ was not found on this server.

If you remove all the spaces the path is correct and matches the image on the server. I use Firefox and the cache is disabled. I have also tried other browsers that have never accessed the site. The all have the same issue with the URL created by RapidWeaver.

I have marked all the files as changed. Deleted all files from the server and republished all. The spaces in the URL’s remain.

Where is the working directory on a mac for RapidWeaver? I can find no way to flush a cache in RapidWeaver but RapidWeaver is the only variable thats has not been eliminated.


(Robert King) #2

I have the same problem.


(Doug Bennett) #3

How did you correct the problem? Did you change the links or just the folder names? Do you have a URL we could look at?

Don’t know what you are asking here. RW project files are Mac-packages, they don’t cache anything.


(Robert King) #4

A cache was an assumption due to lack of alternatives. While the folder names were corrected in the pages themselves it was not updated in the stores products list. The path: option still had the old URL’s with spaces. The names have been corrected in the path element and all is working now.