Changes won't publish

I am looking for some support! I am completely new to RW8. My boss wants me to completely change the content (there is only one home page and a contact form) I am able to make the changes and when I go to publish it says everything has worked and to visit the page but it is just showing all the old content and images. I think it may have something to do with the path but I am no too sure - please help!
Thank you


Hi and welcome to the forum,

Without seeing the publishing settings (a screenshot would be great) and knowing the hosting company you are using it’s difficult for anyone to help you out.

It could be that the changes are there and working for everyone, but you are seeing the old version from your browser’s cache. Have you tried clearing your cache? Or try viewing the page on a different computer or device.

1 Like

thank you for coming back to me.

I’ve tried it on my phone too and it’s still showing the old content, Ive tried to upload the screenshot so I hope you can see it too!


If you are not getting any errors when you publish then you can try clearing the path (empty) and hit the Browse button. Then select the folder.

Had you viewed the old site on the phone before? Phones cache websites too. Have you cleared the cache on either?

we use fasthosts - definitely not getting any errors just no changes at all. Yes Ive cleared all caches and even tried on another colleagues Mac

I don’t have an account with fasthost, but looking at there help documents, they don’t refer to public_html as a path.

Where did you get that path from?

Where to upload your files

When you set up your web hosting, we automatically create a folder called htdocs within your webspace. This is your main folder and should be where all your website content is stored

Now they offer a lot of different plans so perhaps this article is different than what they told you. That’s why I’d suggest you do what I outlined above with browsing for the path. It looks like they have a file manager you can use to explore what’s out there on the server.

What’s strange is that you didn’t get any errors when the path you have didn’t exist.

I have just been googling all sorts! Im not really sure I understand the path/files :frowning: Now I have put in /htdocs it asks me to choose a file etc…

CLEAR the path, empty, then hit browse, then select htdocs. That should fill in the path correctly. Sometimes you need a trailing or preceding slash/, by browsing and selecting the directory, RapidWeaver will fill the path out correctly.


it’s worked! I can’t thank you enough!!!

Thank you so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.