Pulse CMS: URL rewriting not working


(Frank) #1

Does anybody know how the .htaccess of Pulse CMS for RapidWeaver has to look like? I have a Pulse blog on my homepage (index.php), and the pulse folder with the .htaccess is in /resources. Everything works fine, the blog list and posts are displayed, but the URLs to individual posts look like this:

/posts/?blog=1&title=some-post

instead of

/posts/blog-1-some-post

This is especially a problem when using Pulse plugins that rely on the rewritten URLs.

Any ideas?


(Jannis from inStacks Software) #2

At the end, this is the URL that counts:

/posts/?blog=1

The URL parameter &title=some-post is only for aesthetics.


(Frank) #3

Thanks, Jannis, but how do I get Pulse to display “pretty” URLs like it normally does? What do I have to put in the .htaccess?


(Jannis from inStacks Software) #4

Please send me an email, which exact Pulse Plugin you need having worked with that: https://instacks.com/contact/

Thanks.


(Frank) #5

Done, email sent. Thank you.


(Frank) #6

Just for the interested: Jannis helped me out. I didn’t consider that the .htaccess of the Pulse CMS isn’t used by RapidWeaver pages at all. So it’s obvious that the URL rewriting doesn’t work… Thanks, Jannis.