RapdSearch Pro 2: Not Generating or Updating config.php


(Peter Rood) #1

Hi Everyone

I am experiencing some problems with RapidSearch Pro 2. I have been in contact with @willwood and he is trying to help with my situation, but no luck yet. I am keeping my fingers crossed.

I am working with a Foundation website. I did an initial install of the RSP Stack and uploaded it to the server and everything worked. It connected to my database and I was able to login and index my site. Since I was testing things at the time, I decided to delete that install on the server via FTP and start fresh. Since that point I have not been able to get the RSP Stack to work again.

I have even tried to install RSP on another website with a fresh DB and I get the same problem.

Fatal error: require(): Failed opening required ‘config.php’ (include_path=’/homepages/26/d721747348/htdocs/thebugnut/search_files/rspro:.:/usr/lib/php7.1’) in /homepages/26/d721747348/htdocs/thebugnut/search_files/rspro/index.php on line 11

It seems no matter what I do now, I can’t get a config.pgp file generated with my Database Info.

  • I am using RSP 2.5.1
  • Site is hosted with 1and1.com
  • I had it working once already
  • I have re-installed the Stack, and Rebooted my computer.

I am at stand stiff on this project until I can get this working again. Any help would be greatly appreciated.

Thanks in advance.


(Peter Rood) #3

Yes, I have done that several times now.

My assumption is that the config.php file should get generated by the Stack when uploading to the server since it contains all the Database connection info.

I could probably create my own config.php file but I don’t have a sample of it.


(Salvatore De Fazio) #4

I had a similar problem.
In my case the problem was something that had to do with the PHP engine of the web server.
I solved by contacting my provider.
Try to temporarily change the PHP version of the server to 5.6.x or later…


(Peter Rood) #5

I will try that, but it currently running PHP version 7.1

Like I said… It was already working once. Why would it no longer work only an hour later… and now on to Day 2?

Also, I just tried it on a GoDaddy Server… same problem. So it is not restricted to 1and1. I tracked down a config.php file. I am going to tweak it and upload it to the server manually and see what that does.


(Peter Rood) #6

I was able to manually create a config.php file and everything is working as expected so far. So I think I am right assuming that the stack is simply not generating that file.


(scott williams) #7

quick question,
after adding the stack back to the page did you just publish, or did you republish all files (file menu)?


(Peter Rood) #8

I have tried both… didn’t seem to matter.

The bigger problem for one of the websites is that is really big, but uploading the entire website again takes a while, and often times out. so I have to upload the 2,900+ files that RapidWeaver generates in chunks.

That is a painful process for trouble shooting. That is why I started testing on a small website with a blank template.


(Peter Rood) #9

I just did a fresh upload. I deleted everything on the server. Published the site locally, then uploaded to the server using Transmit so it didn’t time-out.

I still had to upload my own config.php file.


(Peter Rood) #10

Now that I have a fresh website uploaded, and the RapidSearch Pro working, I can see that my sitemap.xml generated by RapidWeaver is out of date. I am starting to think there is a RapidWeaver issue with my computer. Is there a way to force RW to generate a new sitemap.xml file?

The one it produced had really old content in it.


(robertreinink) #11

You can also create your own here Sitemap Generator


(Peter Rood) #12

Thanks for the link.

Yes, I did that and it worked perfectly. But RW should be generating a proper site map regardless.


(system) #13

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.