Rapidsearch Pro setup on a 123-reg hosted site


(Hamish Erskine) #1

Has anyone been successful setting up Rapidsearch Pro on a 123-reg hosted site? I’ve created a MySQL database, which I can log in to via 123-reg’s control panel and I’ve entered the database settings into Rapidsearch Pro’s inspector, as advised by 123-reg’s support, and I’ve published my site. But when I try to access the console at:
http://endtimepuzzle.com/search/files/rspro/index.php/
it tells me it can’t connect to my database.
Looking at the database settings in the inspector, 123-reg told me to use 10.16.16.7 for the Host, and that the database name should be the same as my username. I’ve also tried setting the Host to localhost. I’ve tried setting php to version 5.6 and also to 7, configured in htaccess. I’ve also added a php5.ini file containing
cgi.fix_pathinfo = 1
to the root as described in Rapidsearch Pro’s FAQ.

Anyone got any ideas what I can try next?


(Hamish Erskine) #3

Hi Steve, thanks for your help. I can’t see anything that looks vaguely like mysql.123host-18. I’ve posted a screenshot of my database server details at:
http://endtimepuzzle.com/search/
Any chance you can tell me where to go from there?


(Hamish Erskine) #5

Not quite sure what you mean there Steve, as the ‘MySQL Databases’ link is the only one I can find on my control panel, and it leads me into PHPMyAdmin. Please see updated:
http://endtimepuzzle.com/search/


(Hamish Erskine) #7

I’ve tried that as the host, but it still doesn’t work


(Hamish Erskine) #8

and if I try to login to the database using 37.122.212.118 as the server, it just times out, whereas I get in if I use 10.16.16.7


(Hamish Erskine) #10

Ok, but thanks for trying


(system) #11

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.