Rapid Weaver crashes on startup - tried everything HELP! — RESOLVED

I am running Rapid Weaver 8.9.2 on my iMac 32GB 27" running Big Sur 11.6, and it works fine
I now have a new, from Apple, MacBook 16GB 16" running Big Sur 11.6 and RW 8.9.2 crashes on startup. Both units have more than 50% free memory.
I tried opening on the MacBook using the option key and disabling plug-ins and unselecting all the tick boxes. Still no success. I tried using RW 8.4, no success. I tried re-downloading 8.9.2.

I am off on a four-month trip abroad next week and will be screwed if I cannot use RW, in fact so much so I will have to cancel all my travel arrangements as I cannot work without RW.

Is there anyone who can help? I have the crash report. I did email RW but no reply and I am getting desparate

tagging @dan

Thank you for doing this Matthias

1 Like

@Theswedishtiger

This is most strange. Not seen or heard of this before…

Must be something wrong with the system, did you use the migration assistant perhaps (I’ve heard of this doing weird things before)

You could try booting your Mac into Safe Mode, details here: Start up your Mac in safe mode - Apple Support

Do you get presented with a crash report when RW crashes? could we see that as it should help diagnose the issue?

I know it’s a bit heavy handed, but could you also try reformatting your Mac and starting with a clean system.

Let us know some more details as I’m sure we’ll be able to get to the bottom of this!

Yes, I did use Migration Assistant. I did get a crash report (the first time I tried it). Just tried to get it again and it crashes without a crash report!. I did save the crash report, where do I email it to? I will try opening in safe mode. No idea how to reformat the Laptop, it took me a day to do the migration and reset all my software so loath to do this, if needs be I will, but please last resort. I will Google how to reformat the MacBook. Stay tuned for the result of the safe start up

Update - now in safe mode. Crashes, only change is Crash report has returned. Here are the first few lines

Process: RapidWeaver 8 [560]
Path: /Volumes/VOLUME/*/RapidWeaver 8.app/Contents/MacOS/RapidWeaver 8
Identifier: com.realmacsoftware.rapidweaver8
Version: 8.9.2 (20886)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: RapidWeaver 8 [560]
User ID: 501

Date/Time: 2021-10-08 11:49:26.151 +0100
OS Version: macOS 11.6 (20G165)
Report Version: 12
Bridge OS Version: 5.5 (18P4759a)
Anonymous UUID: 118D0889-870C-4BF3-8FA1-6330AD0328B2

Time Awake Since Boot: 65 seconds

System Integrity Protection: enabled

Notes: Translocated Process

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [560]

Application Specific Information:
Crashing on exception: Invalid parameter not satisfying: image != nil

Can you send the full crash report to dan@realmacsoftware.com

You could also try removing your RapidWeaver preferences, press command-shift-G in the Finder and enter “~/Library/Containers/” look for the “RapidWeaver” folder and move this onto your desktop. Then try re-launching RapidWeaver.

Let me know if that helps.

Hi @Theswedishtiger, it it looks like the Touch Bar is causing the crash!

Can you try removing your RapidWeaver preferences (as instructed above). We’re 99.9% sure that should fix it!!!

Thanks,

Dan

1 Like

Thank you, almost there, but Stacks are no longer there now

@Theswedishtiger Great news, have sent you an email about re-installing the addons :+1:

Great, all add ons are now back up and working. You have been a life saver, and a lot of folks who depend on me will be very happy as well.

Thank you again
Roger

2 Likes

I ahd the same problem. This behaviour can be caused by addons rhat are not M1 compatible. Look for rosetta versions of your addons.