Rapid Weaver not saving project


(Clint Hansen) #1

I have used Rapidweaver for about 3 years, have everything up to date.
I am working on a new project, it was saved early today. Now for some reason, after many hours of work, when I try to save or “save as” (even in other places on my computer, I get a drop down that says, “ The document could not be saved. “
I’ve looked to see if there is any reason my computer is the problem, can not see any issues and I can save other files in other programs fine. I sent out an SOS email to Realmac and am not getting a response.
What is wrong and how can my project be saved?
Please respond, I can not shut this down without having it saved.


(Brad Halstead) #2

@clint

Does it not prompt you to duplicate the file?

It should and you should and it should retain the changes.

Do not close your current project, open the duplicated Project (same folder) and make sure changes are there, if they are then you’re golden and work from the duplicate.

This seems to be an issue for some people but not others, support is still trying to track down the problem but have not been able to based on descriptions/files sent by the user to support as far as I am aware to this point.

Could be related to computer going to sleep somewhere during the workday with the project open, could be having more than one project open at a time related, there are so many variables…

Hope that helps
Brad


(Clint Hansen) #3

Brad, Thank you for your response.
It did not prompt me to duplicate. I was eager for a solution, so I went ahead and duplicated the file as you suggested.
I did not close out the current file. Opening teh duplicate, it is the old file without any changes… very frustrating, but I appreciate your help. Any other ideas?


(Brad Halstead) #4

@clint

Try an export of site, it should tell you unable to save, cancel or duplicate, choose duplicate and see if that resolves.

Brad


(Clint Hansen) #5

I can export if I do not save. It asks me to save first as it can tell there are changes. When prompted to save, again the dropdown that says it could not be saved,. It does not prompt to duplicate.

I had teh ‘great’ idea to create a new site, pull all the pages of the unsaveable site into teh new one. Tried to save that… same thing


(Brad Halstead) #6

@clint, odd behaviour… are you using RW 6.3.7?

Try marking all pages as changed and try an export, it should tell you unable to save, cancel or duplicate at least in 6.3.7

Other than that, I am outta ideas sorry I can’t be more help… you had a great idea to try, sorry it didn’t work though :frowning:
Brad


(Doug Bennett) #7

That has happened to me as well. I was able to get to save by doing a “save as” (hit the option key with file menu open) and it saved when duplicate did not. Just a thought.


(LJ) #8

I had this problem a couple of times a few months back and then all seemed well. Now it has started happening to virtually every project I edit to the point where some projects are now copies of copies of copies! Getting a bit tiresome…


(Brad Halstead) #9

Hi All

This is a very, very tough bug to crack… I have encountered it myself and tried to find a reproducible set of steps to make it occur, have sent multiple crash logs, multiple Console logs, sample projects… it is always data corruption, but what is causing the data corruption is turning out to be extremely difficult to find and to make steps to replicate to fix it (I don’t work for RMS but am trying to isolate the issue from a steps to replicate point of view!).

Solutions I have found to make the issue go away for a while (by awhile I mean a month of steady use) is to make sure you try these steps, any combination of which often temporarily fix the issue.

A. Close RapidWeaver & Restart RapidWeaver (Update any plugins if prompted - often the prompt will go to the background on site launch so check your Window to see if there are any updates the background) and repeat step A.

B. Create a new project with just a stacks page in it, save it (This will be your test project always without affecting live sites), now go into Stacks and update all your stacks if you have any out-dated. Save the project again and perform step A.

C. If Steps A and/or B do not resolve the issue then restart the Mac (This effectively kills any temporary files that may have been built up by opening and closing project files and/or multiple page views within RapidWeaver). Start RapidWeaver once your system is fully launched (Dropbox, etc have synced) for best reliable results.

D. Always launch RW with the project created above, check for updates, save the project and close the project. If the project fails to save then you’re not messing with a clients site data and repeat steps A through C again.

This isn’t a fix, but until we (the users of RW) find reproducible steps to replicate the issue, there is only so much @nikf can do to troubleshoot this issue.

I know it is a PITA, but it’s something we have to do until the issue can be reliably reproduced so it can be fixed. No reliable reproducibility means no fix.

HTH
Brad


Please fix RapidWeaver 6
(Michael M.) #10

Hi Brad

I hopefully followed your hints but nothing works. Since some days I have this annoying issue - and it appeared on two different computers where I keep the RapidWeaver projects synchronized. So I think it has nothing to do with any malfunctions of the OS, it must be the project or the way RapidWeaver saves the project files


(Brad Halstead) #11

Sorry you’re experiencing this issue, it rears it’s ugly head seldom for me but I only use RW and projects on a single computer. How are you synchronizing your project between the two computers?

If I had that capability, here’s what I would do…

Make sure all assets are in the same location…

{folder name}

  • Project.rw6 - project file
  • {assets} - all assets related to the project
  • {assets/images} - all images
  • {assets/pdf) - all pdf files
  • {assets/zip) - all zip files

When synchronizing I would zip the main folder that houses the project and assets, put it on dropbox, go to other computer download it from dropbox and extract it to the same location

Perhaps it’s assets that are missing from the project (because they are aliased) that is causing the issue

I’m outta ideas other than if you’re using something like clean my mac or some other destructive 'helper utility" may be causing issues…

Brad


(e.g.,) #12

Another dead end thread.
Would be good etiquette to write a hint of follow up, especially if the issue is resolved.

Knowing other people have had a problem, doesn’t help the next time someone else has an issue.