Rapidweaver "Unable to Save" Error


(Matthew Abourezk) #1

Hi all,

I am regularly getting an error in Rapidweaver that makes it unable to save the work in progress. Apparently this is a known issue with Rapidweaver since they supply a dialog that says RW is currently unable to autosave the project, and if I want to save my work I can duplicate the project and save the duplicate. While this works every time, it is still a bit unnerving that this underlying problem exists.

I am using the latest version of RW (6.3.8) and my Stacks 3, Foundation, and all plug-ins are up to date. Any thoughts? FWIW: I don’t recall this being a problem prior to 6.3.8 and Stacks 3


Rapid weaver "Unable to Save" Error
(Silas 'Shadow' skiá) #2

This is one of my least favorite errors.


#3

I’ve experienced this a few times in the past but not recently. It seemed to occur when I worked constantly over a period of an hour or so making lots of changes like moving the position of stacks while experimenting with the page layout.

I never tried the project duplication trick, but restarting the computer always removed the error and allowed normal saving, albeit at the cost of lost recent changes. This makes me suspect that RW is holding onto information about changes while you work and eventually this accumulates to cause problems.


(Matthew Abourezk) #4

Hi ash… I agree. I think RW is probably just not great with memory management. Might also have a memory leak and overflows the buffer after a while. I notice the problem happens more quickly when I am also running Photoshop and manipulating images. Probably eating up all 32GB of RAM after a while.

Next time duplicate your project, no need to lose your work. Gives you a chance to version off the work in progress, which is always good anyway right?

Thanks for the reply.
Matt


(LJ) #5

Like others I find this to be an occasional glitch which, like buses, comes in 3s or 4s then doesn’t occur for a while.

Project duplicate is the way to go - no need to lose any work. I always bin the previous version fairly pronto as it is easy to open up the wrong one at a future date and run into version nightmares


(Jody Joy) #6

This has happened to me too, quite a bit. Seems to happen when I’m working and making lots of small changes, then trying to save and export. RW will give me the can’t save error. I am also experiencing the issue where I will export the entire site fresh, then FTP via Transmit, and the site will not display the changes. This has happened a lot. The solution for me is to create a new empty folder on my server, publish fresh to that, then swap that out for the domain folder. No amount of re-publishing the entire site solves the issue.