RapidWeaver cannot save projects any more


(Jan-David Kukla) #1

Hello –
a few days ago Rapid Weaver told me it can no longer save my projects and that I should contact RW support if the problem persists. It does persist and all my RW projects - old ones and even new ones I have tried to set up after the error occurred - are affected. I did contact support, but have now gone 100+ hours without any reply whatsoever, except for the automated reply promising an answer within 72 hours. I have checked the forum as to similar problems but haven’t found a solution yet. The wording of the error message:

The document “ICS.rw” could not be saved. If this happens frequently, please try saving the document using “Save as …” to a new location. If you’re still experiencing issues, contact Realmac Software support."

would suggest to me, that this is a known issue. In my case “Saving As…” does not work at all. I also noticed, that the “Styled Text” plugin seems to be missing, so I tried reinstalling RW, without any effect. I am now getting somewhat desperate, as I can no longer update any of my sites. If anyone has any insight as to how to resolve this issue, I would be most grateful.

Thanks a lot!


RapidWeaver 7.4 (18672b) - Release Candidate 1
Saving Problem first time after two years
(anthony lambert) #2

I have the same issue too… not be able to do any work for a 3 days.


(Dan) #3

Hey guys,

Can you provide some info on what version of RapidWeaver you are using, would also help to know what plugins you are using and if you’ve updated any of them recently.

Does it do this on new projects? or just existing projects?

Without any of these details it’s hard to help.

As well as posting here, be sure to email support@realmacsoftware.com along with a link to download your save file and we’ll take a look.

Cheers
Dan


(Brian LaPan) #4

Give this a look and see if it solves the issue.

https://kb.realmacsoftware.com/article/9-trouble-saving-documents

If not, then send the details as Dan mentioned.


(anthony lambert) #5

Hi dan,

RW 7.3.3

I have already sent 3 emails to support

12:04 yesterday with log - nor eply
11:33 yesterday with project - no reply
11:31 yesterday showing it’s not the https://realmacsoftware.kayako.com/article/9-trouble-saving-documents https://realmacsoftware.kayako.com/article/9-trouble-saving-documents issue - no reply.

I am using foundation, RETRACT. I think Foundation updated a few days back.


Delete PDF files from Resources and RW7 won't Save
(Aaron Marquez) #6

Hi Anthony, your case has been updated - let me know if you received this! Our Helpdesk went down momentarily yesterday so our response may have been delayed.


(Rob D) #7

No less than three Company Men on the case! – Love it!!!


(Jan-David Kukla) #8

Hi,
thanks for all the replies. Here is also, what I received from support.

Hi Jan-David,
Very sorry for the late reply to your request - our help desk has had some issues over the past few days.
Since none of the troubleshooting steps have worked, I’d recommend doing the following exactly.
Step 1 - create a new project file
Step 2 - copy/drag each page (1 by 1) to the new project
Step 3 - save after adding each pageIf you are able to move all pages over successfully, then perfect.
Your file may have been corrupted when moving it. If not, then the page you added last before trying to save is the cause of the issue.
We can then narrow it down to a plugin / code, etc.
Thanks,
Aaron
Aaron Marquez
Support @ Realmac Software

When the problem manifested itself, I was using version 7.3.3 and I am only using the plugins, that come with RW, no updates. Part of the problem was, that I could no longer save any file, no old ones and no new ones. So the steps mentioned above would not have worked. Also, I did not move the file, so moving it should not have been the cause of any corruption. Between the file working and the file no longer being able to be saved, I corrected some spelling errors. The plugin that seems to be affected is the “Styled Text”. Where there is usually a “A” symbol in the sidebar, there is now only a “lego” like symbol. I will send support the project file.

I have since downgraded to version 7.3.1 in which I can no longer open the file that was affected first, but I can open other projects and also create new ones. As to the project I was working on at the time, I had to completely recreate it from scratch and am still working on that.

While downgrading and rebuilding the project gets me working again, it does not solve the software issue at the heart of the problem. I would still like to get that resolved.

Thanks a lot!


(Rob D) #9

Since it seems like your copy of RW itself is corrupted (sometimes it happens during in-app updating), I would download a fresh full copy of the app from this link: https://kb.realmacsoftware.com/section/4-release-notes and use that instead.


(Jan-David Kukla) #10

Hi Rob,
thanks for the advice, much appreciated. I had the same idea and downloaded 7.3.3 from the website and installed it. Unfortunately the problem persisted until I downgraded to 7.3.1.

All the best,
Jan-David


Project Not Saving & Default Plugins missing
(drc007) #11

I have the same problem. I get an error for some pages that the “Styled Text” plugin is missing, however the are other “Styled Text” pages in the project that are fine. The Plugin is listed in the Addons and works fine for other projects. I’ve also tried reinstalling RapidWeaver to no avail.


(Dylan Merte) #12

I have the same problem, in my case the pages saying there missing a default plugin are “Contact Form” pages.

TEMPERARY FIX: I went and deleted the few pages I had (That show the Lego symbol), recreated them and did a save, and was able to save. So for people needing to continue working on your sites that can’t save this might be a solution for you, for now.

I’m still scared to try and keep saving and working on my site because I feel like it could happen again at anytime to a different type of page, and a big and more important page, makes me not want to use RW because of this major problem.

The current solution from the developers is not a great solution for people like me that have large sites, to just merge all of your pages into a new project.

My guest to where the problem lies is, some times when you go to do a save, some very old pages (Years Old Pages in my case) are getting corrupted during the save process.

Hope this helps the developers to fix it asap.


(anthony lambert) #13

Aaron, Thanks for the suggestion above. I created a new project and copy and pasted the pages across. This was a lot quicker than I thought it would be and I am now up and running.

Looks like I will need to take regular backups if there is a bug which corrupts projects. So I can revert to it if it happens again.

As a programmer myself it seems strange that your save routine can’t give any meaningful information as to why the it is failing? Looking at your project files it looks like it is all XML based. I guess if your using some save these objects as XML type API you might not have that granular info? not a great position to be in?!

Anyway thanks for your help.

Anthony


(Tom Bradley) #14

Hi guys,

I just wanted to let you know that we’re still investigating these problems and working on a fix. What I’ve found so far is that there are a few unrelated problems here presenting themselves in the same way, the ‘saving project bug’.

@alambert & @dylanmerte
You both seem to be having problems with the Contact Form plugin. Can I ask how old the projects are that you’re opening in RW7? From my testing it seems there is a bug in RW7 when trying to decode the contact form data from pre RW5 projects.

I was successfully able to load the project first in RW6, save it (which converts to a newer format), then load the project in RW7 without issue. Are you able to test this your end?

@jandavid & @drc007
You two seem to have issues with the Styled Text plugin and saving in general. I’ve yet to figure out what’s happening here. Can you send in your projects so we can try and figure out what went wrong? Also, are they old projects that you’ve not opened in RW7 before?

@jandavid Did you by any chance reboot your machine and then try 7.3.1? It’s possible you hit this OS bug https://kb.realmacsoftware.com/article/9-trouble-saving-documents. Could you try rebooting and then creating & saving a new project in 7.3.3 for me?

Cheers
Tom


(drc007) #15

Hi,

Already sent a link to the project to Aaron. They are projects created years ago but have had content added daily since. Used Time Machine to get a backup from a month ago and that was fine.


(Jan-David Kukla) #16

Hi Tom,
I have also send a link to download my project file to Aaron. This was a fairly new project, that was created only a few days before this problem occurred, so definitely in 7.3.x.

I did check out the article about RapidWeaver reaching the maximum number of file-system resources it’s allowed, but when I ran the command in the terminal, it did not return any information on RW. I assume, that to show this information RW had to be running and it was.

The problem occurred in 7.3.3 and has -so far - not occurred after I have downgraded to 7.3.1. However, after the problem occurred, I did reboot the computer and still could neither save any old nor new projects (in 7.3.3). I have since reading your message installed 7.3.3 in parallel to 7.3.1 and tried to create in a new project in 7.3.3. This worked and I was able to save the project. I then opened a copy of my current 7.3.1 version project and I was also able to edit and save it without problem in 7.3.3. Then I opend the original “problem-file” in the newly installed 7.3.3 and there the problem was again. I could not save getting the same error message and the Styled Text plugin symbol was replaced by a lego symbol.

I don’t know if this helps, but I am still very reluctant to now start using 7.3.3 with my current project, as I don’t want to have to rebuild it again. What would your advice be? Continue to use 7.3.1 for now or try 7.3.3?

Thank you very much!
All the best,
Jan-David


(Tom Bradley) #17

@jandavid, @drc007 I’ve been digging into this a little further and found a possible case where some errors were not reported under certain circumstances. This has been corrected in the latest beta release 7.4 (18675b) available now.

https://dl.devmate.com/com.realmacsoftware.rapidweaver/18675b/1494243207/RapidWeaver-18675b.zip

If these errors do occur during save, you’ll now be notified about the problem and you’ll be able to copy out any changes or save elsewhere so you don’t loose your work. We’d also appreciate a screenshot of the error so we can fix the source of the problem.

Cheers
Tom


(Dylan Merte) #18

Well It did not resolve my issue, pages in my file not allowing me to save, are still showing the missing plugin icon.

And now attempting to do a Save As, RW just locks up. And now of course without an error message.


(Jan-David Kukla) #19

Hi Tom,
saving seems mostly fine. I did get a message, that the file had been saved by another program once or twice. But I am now having some issues uploading. They might be related to the server though, as I am having trouble uploading through Cyberduck too.

All the best,
Jan-David


(Tom Bradley) #20

Thanks for reporting back guys!

@dylanmerte We’ve applied a fix in the latest beta (18677b) that should allow RW7 to load projects with old contact form pages.