Rapid weaver sets wrong address for Podcast files

The podcast feed is not recognized because Rapid weaver sets for the addresses of the podcast files “https: / www.” instead of “https: // www.” !
Can I change it myself or is there an update for it.

Is the website address set correctly in Settings > General > Web Address?

It might also help to stipulate what version number of RapidWeaver you are using.

Version is 8.6.2 , and that was the first thing I checked, it was https://www.aufdenhundgekommen.info/ and therefore actually correct.

My subscribers tell me now, that the pod catchers no longer recognize the feed.

Now I have real problems!

Have you opened a support ticket with Realmac Software, the developer of RapidWeaver?

This community forum is mostly staffed by volunteers, so we can provide “have you tried” type advice, but regretfully we don’t have access to the inner workings of RapidWeaver or your detailed publishing / console logs.

Short term, you can probably open the published XML files in your favourite code editor, via FTP, and do a quick search and replace on the faulty links, to manually fix them. Save the changes when done. You can use any free code editor for this task, like Atom or VS Code.

Another option is to adjust your .htaccess file and add a new rewrite rule. Set it up to redirect all instances of https:/www to https://www. Therefore the faulty links will resolve. The hosting company might be able to advise you on this.

Long term, I would think any fix would need to be provided by Realmac in an update.

Thank you for help! I contacted Dan, until then I’ll try that with the .htaccess file.

I found a solution! But the problem has existed since 2018. If I enter the address with https: // … under Settings-> General-> WebAdresse:, the error arises that addresses in the feed are partially displayed as https: / … . (see picture above) and the feed is not validated and is not recognized by many podcatchers. But if I set the setting to http: // under General, the feed is output correctly without errors, and also validated and recognized by pod catchers. So if you want a feed that is recognized and works you have to set it to http: // in the settings, although my page from the server runs on https. Isn’t it strange?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.