RapidWeaver 8.1.1 - problem with resources still not solved


(michael m.) #1

@tpbradley I just downloaded RapidWeaver 8.1.1 and tried it on a test project. The project is an existing project, which I created with RapidWeaver 8.0.3. I have deleted all pages and resources from the project except the start page, as well as the publishing settings, the web icons, etc. In the remaining start page I deleted all stacks, so it’s an empty project.

Under 8.1. we had the error that a bunch of empty resource folders remained in the directory /Resources/ of the project package. Furthermore, there were many entries in the content.plist that referred to already deleted stacks, but also to other data (lines 16 to 13000).

With 8.1.1 the first problem is solved now, the Resources folder is empty. The second problem persists


(Tom Bradley) #2

Hey @apfelpuree,

Great news that 8.1.1 is helping! What you’re seeing in the plist file is publishing manifests, it records information about where files have been published. RapidWeaver doesn’t typically remove this information from the project because it’s still useful.

For example, you may have removed a resource from a project but it will still exist on your hosting server.

Cheers
Tom


"This document could not be saved"
(michael m.) #3

O.K. - I must accept your explanation, even if I cannot fully understand the meaning behind it. Why do links and configuration data that are no longer needed have to be retained in a plist?


(Tom Bradley) #4

We retain it because it may be needed in the future. A perfect example of this is if you accidentally remove a publishing destination then re-add it a few days later. It would be really annoying if you had to re-upload a big site because the publishing data was cleaned out.

In reality this data is tiny and doesn’t cause problems, so it’s safer to keep it :wink:


(Ken) #5

@apfelpuree Because many gurus on this forum recommended (strongly) warehousing of images etc, I used Dropbox - what a disaster that proved to be. Believe me, dropbox is bad as they change the application from time to time and goodbye links. I’m a great believer in ‘drag & drop’ from my hard disk and I have absolute zero problems in 8.1 or for that matter any version from 8.03 onwards. A few weeks ago I got a new iMac and transferred the folders exactly as on the old iMac (problems with graphics card). All the links were fine and not a single one of several hundred images broke a link.


(Mathew Mitchell) #6

Ken: you may have had a problem with Dropbox, but that’s NOT warehousing. Warehousing your materials essentially means FTP-ing to your hosting site and then copy the URL to use with RW.


(michael m.) #7

Maybe I didn‘t understand you correct but I think that Dropbox „warehousing“ (what isn’t really warehousing) has nothing to do with the resources problem we had with the last RW version


(Paul Russam) #8

I’ve had Dropbox since 2009 and keep EVERYTHING in there, I have no user files for any app anywhere else other than OneDrive for another business.
I have the same account linked on 2 mac and 2 windows machines.

I’ve never experienced 1 problem other than a DB server outage in or around 2010

@kpryce1 … you’re using it wrong and warehousing referes to keeping your images/videos/pdf’s et etc on your server NOT Dropbox


(Groove Q) #9

Relinked resources (even though in precisely same locations as before), copied resources to project in advanced settings, ‘save as’ new project.

Nothing, borked…no pages will preview in my project.

This is pretty bad.

58


(chuck berhain) #11

Updated to 8.1.1 and have missing resources, for the first time! Reverted to 8.1 and seems OK.
No longer have 100% trust as other updates had been fine…
Not expecting a solution to my problem I just will not be updating as routinely until problems reports become fewer.


(Don H) #12

Do you use any 3rd party plug-ins? Are they are updated?


(Jan Fuellemann) #13

These missing resources might be ones you did use quite some time ago and which are not needed now. You can check them and delete them?


(chuck berhain) #14

It’s possible they were renamed similarly and I didn’t recognize that immediately. Thank you.
I am update-shy now so whether or not that was the case, I will “clean up” my project before continuing to republish and then update.


(Giorgio Becevel) #15

After “don’t save on desktop” and “This document uses files…” NOW after exporting the project the Resources folder is… EMPTY… this is a never ending story
Going back to 8.0.3
update 29gen19:
with the last update 8.1.2 my project is working fine now.


(Guy Boutens) #16

Update PlusKit solved this problem (NSUnknownKeyExeption) in my case.

http://yourhead.com/pluskit