Again - RapidWeaver has detected missing resources in this project

I logged a question recently about why some resources, both folders and files in folders, simply disappeared. Some people were kind enough to comment on the issue, but no one was able to say why it happened. I know the resources were there before, because they are still on my host server. One of the questions I has was, could I just paste them back from my host into the resources?

This time my question is more specific and concerns the window that opens when I open the project.
“RapidWeaver has detected missing resources in this project”

It then lists a series /var/folders/_ with incomprehensible alphanumeric sequences and a “Unknown Volume” with another incomprehensible sequence, and the word “Internal”.

It says I should review these files, but I have no idea where they are, or how to review them.

It also gives me a “Scan Folder…” a “Relink…” and a “Remove”. But I have no idea what these different options do. Are there any instructions, manuals, etc. that cover these features? I hesitate to use them and then find more problems.

Some help or points would be very welcome
Keep safe

I’ve heard of people having this issue. I never have gotten this kind of message.

A few questions might help figure out what might cause the issue.

  • What is the Advanced setting for Site Resources?
    1. Copy into the Document
    2. Leave in Place
  • Was this a new RW8 project or was it a project converted from a prior version (RW6, or RW7)?
  • Where are you storing the project file?
    1. Local hard drive only
    2. Synced server (iCloud, OneDrive, Dropbox, etc)
    3. NAT or other storage

Thanks for a super rapid reply
Copy into the Document - I’ve seen some people mention to use Leave in Place, but what do these two options mean?
The site was built with RW8, but some old pages came from RW7, but not the ones affected. And I built from scratch the resources.
Local HD, but iCloud is on as is TimeMachine, and I keep an occasional copy on the side, because the problem of lost resources has hit me in the past, but due to using extensions other than .jpg.

regards

Okay,

Copy into document is the default. Anything you place into resources will be copied into the project file making it portable. Leave in place will leave the resources (like a jpg) where it was and just create a link to find the resource. The problem with that is that if images or other resources get moved, RW cannot find them. Old (Pre RW8) projects used that method. That created problems as people often forget and move or delete these kinds of things. Or if you move to a different Mac. So I always use “Copy into Document”.

Other folks have had issues with storing Projects on non- local HDs. A RW project file isn’t really a file at all. It’s a special folder called a package. That package can contain hundreds of files. Some times even these “sync’ed” services like Dropbox just don’t work. So if you need to work on a project on multiple Macs, Then I’d recommend that you zip it and then copy the zipped file to the service you are using to share with. Then on the other Mac copy the zipped file to the local HD and then unzip.

Now it sounds lie you aren’t doing any of that. I’ve never had this problem myself.
Perhaps Realmac support folks might have some suggestions @dan, @tpbradley , @Aaron

Again rapid, and very useful. Thanks a lot for that. At least I learn as we go.
It’s so irritating when you think you have a clear idea, then it does not work. Use resources (not sure why) but make sure that the images are all jpg’s and all with useful and different names, etc… Then bang, another problem and one I could work on if I understood the meaning of the messages, etc. Where are the old days when nobody put things out without documenting it before hand?
Many thanks, keep safe

I’ve suffered this problem and dealt with it the hard way by having to rebuild again almost from scratch for a number of sites. Did several tests, I can’t be 100% sure but looks more likely to be a problem that arises when using cloud sync backup. In my case I use OneDrive but I imagine it is no difference for Google Drive or iCloud. Although the project file appears to us as a document it is in fact better described as a folder of contents and not a discreate single file that syncs. Would that be right more clued up Weavers?

The way I have solved this problem is to immediatly right click and Archive to Zip the project file up after major changes, I also save these sequentially as V1, V2, V3 etc and delete older ones, so in effect this Zip file uploads as a single self contained file. Haven’t had any problems since. This mainly happened when using two computer Laptop and iMac you work on the project on one, it syncs to the cloud.

I think the thing that Realmac could do to help would be to let the project save natively as a compressed self-contained file or at least give the option to do this.

Thanks for the info, and the warning about iCloud, etc. How did you rebuild? Did you drag and dropping again the files (images, etc.) back into resource folders? Did you need to drop the images, etc. again into the webpages? Did you get those incomprehensible messages? And did you simply close and ignore them?

I’m not sure why I need to do this all over again since the images that were in the resources (but have now disappeared) are now in the webpages that are still in RW and have been published and are on the server.

On top of that on the server all the images are found twice, once in the webpage files, and one in Resources. And the resources on the server appear to just be taking up space, because they are not accessed the pages are called.

I’m not even sure I’m using Resources properly, since I’m not embedding a link in the webpages to the resources, except for pdf files.

I want to keep things are simple as possible, and I may be making it more complicated than I need to.
But thank you for the reply, I need to look at how the RW files are treated in iCloud and TimeMachine. I also need to continue to keep a separate backup of all my collections of resources.
Many thanks and keep safe

Hi Bernard, although the webpage is published, if wanting to make changes and it involves a stack with a missing resource then the page or element is screwed up.

Yes the messages with a random string of characters doesn’t help to identify the missing resources it is a case of comparing and replacing, starting again so to speak, the structural framework is still there but I had to ensure I have the correct image elements or HYPE animation files in the correct stack holders for their determined visibility mobile, tablet or desktop. So to answer your question I had to delete the unknown resources and then delete all elements that would have used a resource. Because I use a lot, and I mean a lot of image elements for animations and interactive features that are usually different for each screen size display it is no quick or easy thing to do.

Some elements, so I don’t get stung again with a resources disaster I now ftp up to a seperate folder on the server and link to them instead. This is a real shame to have to do this because the Resources feature is designed to keep everything together and not have to resort to this ‘old school’ way of doing things. I am very sure it is due to the Rapidweaver project file being a folder instead of a single document file that is the cause of this problem with cloud storage. I may be wrong but I’m guessing it is to do with saving the project file more than once, such as a V1, V2, V3 or as a different name it would be a duplicate of the resources and the cloud sync software registers that it has already saved those files of that size and time stamp and therefore doesn’t sync them. Therefore opening a newer version suddenly can’t find the resources for that project. That theory though is just a guess.

@BernardSmith : @TopHat has already made some great suggestions.

This may not be the best added suggestion for you but I’ve noticed several folks are not very aware of how big their resources are. I’m guessing the larger your RW project file (due to lots of resources) the larger the potential for problems when using a sync service. It only takes one bad sync to create massive problems. As mentioned by TopHat, zipping/archiving your project file before added to DropBox or any othe syncing service seems to eliminate any possible ills.

I have a LOT of resources in most of my course websites. If I added them all directly to RW then my project file would typically be 400 Mb or much larger. However, I put these things (audio, images, collections of PDFs, etc.) on my server directly. Then I copy the URL and use that URL when referencing the relevant image, zipped folder, etc. In general there are 2 good ways to do this: (1) use an FTP app such as Transmit or (2) use the Repository stack by @instacks . Both will work great for these purposes. The end result is my project files are typically less than 15 Mb for about 30-40 pages of content.

In previous posts I’ve heard folks with RW project files that are 500 Mb or 3 Gb or larger. That seems insane to me. Or, put differently, completely insane without a very good set of backup strategies.

2 Likes

That’s a valid point there Bernard that Matthew has said, very large files or many files, my project folder for my own website is roughly 100mb as video files I FTP instead of using resources to keep file size down but I have thousands of small files. But as Matthew says the sync software can get in a muddle and ruin everything. I do think if Realmac saved the project file as a single file it would sort the issue. It is one of those problems that will never affect somebody and then suddenly unexpected it happens and it is a disaster, therefore I think this has been a difficult problem for people to identify and in fairness to Realmac actually being able to see, recreate or witness as an identifiable and obvious problem. It is however a problem and is happening to many people when you search resources in the forum.

That certainly helped, and I think I know what I need to do to recover, and also to keep a close grip on my backups. My best guess is to build before or during a page creation a separate backup file of all the resources I’m using. I will trial this on the page I’m building now. So I can repair if needed. I will check how putting resources on the server and linking to the works. I will pick a small page and test it out.
Many thanks and keep safe

It does or has only happened to me with files I add to Resources, if an image is embedded in a stack it never throws up a problem with them.

Yes, thanks for you comments as well. And my websites contain lots of quite large images, so they can get very big over time. I shall start to populate a resources and build again a page, and then test that it works. I was hoping that RW would be stable in handling lots of pages with lots of big image files. So work in progress.
Keep safe

Another good point.

I would like to thank everyone in offering many useful suggestions. I think I can work around my problems, even if I’m not happy they occurred. Franky one of the positives with RW is the user community that tries to help when they can.
Keep safe everyone, my vaccination is planned for Thursday, but that is another story.

That would probably require RealMac to do a major rewrite of a lot of Rapidweaver. I doubt that is going to happen anytime soon.

The problem is probably not an RW issue, but seems to be more a macOS issue. The package file is a standard Mac OS feature, so the fact that every single sync system out there including Apple’s own iCloud is having issues with it would kind of point the finger at Apple.

A few years back all the sync’s worked fine with these package files.

I doubt that the package file size has much do with the problems with syncing. Keep in mind that the project file isn’t a file but a directory of hundreds of files. Many of the errors people are experiencing are dealing with plists (a very small text file). Missing resources may not be missing at all from the project package but the “link” in the plist is what’s not current.

My recommendation is to simply not use any syncing services including Apple’s iCloud for project storage (unzipped that is) until Apple figures out what exactly is wrong.
More information from Apple about bundles(package files)

https://developer.apple.com/library/archive/documentation/CoreFoundation/Conceptual/CFBundles/AboutBundles/AboutBundles.html#//apple_ref/doc/uid/10000123i-CH100-SW1

Humour me for a moment. I create in RW Resources a folder and sub-folders in which I place a collection of jpg images. I then drag and drop these images into my webpages as I build them. RW places all these Resources along with my webpages and a lot of other stuff in a single .RW8 “package”. TimeMachine will log the incremental building of these folders. iCloud will simply over-write an old version of .RW8 with the latest version. I can open .RW8 and copy Pages and Resources, even if I’m not sure how I can use that backup copy later but it does contain the images files. Fortunately when RW published, I can copy and archive the published site, along with the Resources found on the server (which still contains all the images that I originally put in RW Resources).
I can’t see how iCloud can make a mess of this process, but I can understand TimeMachine making a mess if I try to rebuilt a corrupted set of folders. But TimeMachine will have a true copy of .RW8 from some moment in the past which I can use, even if I will have lost some of the more recent work. iCould will just deliver me the last backup, which might already have been corrupted. I can’t see which process can be responsible for resources and folders being lost from RW Resources. I will admit I detected the loss after publishing, but I don’t know if this is linked. Perhaps I have a too simplistic view of this. I just think that RW is unstable.

I’ve never had the missing Resource problem that you are experiencing and I’ve used resources extensively (in the gigabyte size for stress testing) since RW8.

I also use TimeMachine as my primary backup and Backblaze as a secondary backup and have done lots of recoveries of RW projects from TimeMachine and a few from Backblaze without issue.

  • I never used resources before RW8, as they weren’t reliable.
  • I never store my projects any place other than my local HD. If I need to share it with my other Mac, I zip it and copy it over, and unzip it
  • I always leave the default advanced option set to “Copy into the Document”.

others have experienced other similar problems when storing the addons folder on Dropbox. Most of the addons (themes and stacks) are also MacOS packages as well.

Thousands of people are using RW8 that uses resources as the default image type, and thousands of folks use Stacks 4 that also defaults to using the site image stack for images, which also uses RW resources to manage the images. I don’t see thousands or even hundreds of posts with issues of missing resources.

I think every post I’ve seen with this issue all have in common using a synchronized file service or other unusual storage like NAS for storage.

Now you can choose to blame who you want to for the unusual issue that you are experiencing.

2 Likes

OK, I only have 2 websites, one is 1.4 GB the other 2 GB. I have never had recover RW8 from TimeMachine. I never used resources before RW8. I never store my 2 project in any other place than on my local HD. But I do copy them to an external HD, and they are also on my server. I have never had to share with another Mac, but I have m igrated RW twice to newer MacBook Pro’s. Without knowing it I always leave the default advanced option set to “Copy into the Document”. I don’t use Dropbox. I don’t use add-ons or Stacks. I am one of the thousands of people using Resources in RW8 as the default. I also have not seen thousands of posts with issues of missing resources. I don’t have a synchronising issue because I have other to synchronise with. I have the backup files copied that show that the resources were both in the folder and the folders were in Resources, and then they were not. I can send you every image that was in Resources and has disappeared.
I you wanted to call me an idiot that was wasting peoples time , why not just say so.
But since you are so expert you tell me what the following means

I assume you do not use a software like cleanmymac or similar? And do you miss the resources from all three locations, like the external HD, the local HD and the server? Did you by chance restored your RW file from your server and has the server been formatted differently than your local HD?