RapidWeaver 8.1.4 Beta (Build 20621b)


(Dan) #1

Hey Weavers,

Please remember this is beta / in-development software — If you’re not comfortable with using non-release software do not update.

What’s New?

  • Lots of under the hood changes in this build to help with stability and performance.

If you are happy with the associated risks of using beta software, go ahead and Download RapidWeaver 8.1.4 Beta (Build 20621b)

Happy Weaving!

Cheers
Dan


( ) #2

And please remember to make a copy of your project. Open the extra copy in the beta. If something goes, wrong you can revert to a previous version and have your original copy. :wink:


(studiozellige) #3

Question: Is the coexistence on the same machine of several versions of RapidWeaver (for my part, version 8.0.3 [which works perfectly] and a beta 8.1.x) is it not a source of conflict?


(Tom Bradley) #4

@studiozellige Generally speaking, it shouldn’t cause a problem. The one thing to remember is that projects saved in newer versions of RW can’t be opened in older versions due to changes in the file format.

I still run RW6, RW7.5.6, RW8.0.3 and RW8.1.x on the same machine :wink:


(studiozellige) #5

Thank you Tom for your quick confirmation: it’s really nice.

I will maybe venture to install version 8.1.3 and test it … unless you advise me to wait until your development is more successful! …


(Jonathan Spencer) #6

This beta has stripped all the images from the project I’m working on and won’t let me add them back in either. I suppose I had better go outside and do some gardening then.


(Doug Bennett) #7

Since you’re beta testing it would probably be great if you get a copy of the project files and details of what happens and how to Realmac Software Support.
support@realmacsoftware.com
Might include a link to this post.


(Hamish Erskine) #8

Please don’t omit to fix the ‘Clear formatting / Paste as Plain Text’ bug that was introduced in 8.1.1 and colours text black. It hasn’t been addressed in the last two updates and is getting really annoying.


#9

This error also occurs in my projects.

The bug is in 8.1.4 Beta 2 fixed, thank you.


(Dan) #10

@jspencer2, can you send over your project so we can take a look and see if we can fix it Send it to dan@realmacsoftware.com :+1:


(Dan) #11

New build is up, grab it here: RapidWeaver 8.1.4 Beta 2 (Build 20634b)!


(Dan) #12