RapidWeaver 8.1 Final Candidate 5 (Build 20536b) *UPDATED*


(Dave Farrants) #22

The latest beta is woking OK for me, I have multiple sites (12), some large with multiple pages and I’ve had no problems that were not user error! Yes, it asks for the location of Resources and Yes, I’ve had times it’s asked more than once but on each occasion, it was because I had one or more Resources NOT in its main working folder (I use an individual folder for each site). The fault was always mine - I’d have dragged a Resource in from another location which is now no longer referenced correctly to it’s working folder. When you get the message, dismiss it - the site will still open, open Resources and you’ll then see what Resource RW thinks is missing and not in its correct location, you can then locate it, re-index it and you’ll not get the problem again. It’s all too easy when engrossed in building a page to use a Resource (often a small photo or icon) and just drag it in, maybe from the desktop or a USB stick, you publish the site and see all is working fine, you then either delete the ‘original’ Resource or move it but RW8 needs to see it again to make the site work if you do any updates or make changes to a page.


(Dan Smith) #23

I thought it might be a resource problem as well. I added a blank page, deleted all other pages, deleted resources one file folder at a time until only the added blank page was left. Did one final save, closed Rapidweaver, reopen with no change.

Started a new project, added all the same resources, added the pages one at a time until the project was identical to the original. Problem solved.

This is something that was added by Realmac and by opening, then saving the project hopefully you got a backup as you can not open a 8.1 project using 8.03.


Resources not publishing
(Doug Bennett) #24

I’ve not been able to recreate this issue. Sounds as if it’s specific to your project(s) as if I understand the description above, It’s not happening on new projects? Have you sent an email to @dan with a link to a Dropbox (or similar) project file along with a reference to this post? They might be able to help.

Unfortunately, it seems the MacOS environment is getting more and more “Locked Down”. The “sandboxing” issues are part of offering an app on the Apple App Store, but even without the App Store MacOS seems to headed more and more the way of iOS.


(Tom Bradley) #25

@ibuys I’m looking into the S3 issues you’re having, can you tell me what region your bucket is in? Cheers


(Jonathan) #26

Yep, it’s in US East (N. Virginia). Sorry for the late reply.


(Tom Bradley) #27

Thanks man, I have a fix in the next release for you :smiley:


(Jim Cook) #28

Downloaded the latest build (20560b) and now RW8.1 is crashing upon saving or uploading. Can’t use RW at all now. I have multiple sites that rely on changes and I can’t make changes. Problem here is once you go to 8.1 you can’t go back as your projects want to see 8.1. Not sure what to do here. On another note, I’m also getting the same message about resources in different locations, which they’re not. I’ve never changed the location of the files since RW6. I originally got sold on RW8 and started experiencing problems such as the resources sandboxing issue so decided to try the beta, but boy is this troublesome as it’s disabled the program completely. Sent a support note to RW and waiting for a reply.


(NeilUK) #29

That’s not true. Just go back to the previous version of RW8 that worked. I had a publishing problem with that latest beta. I went back to the previous beta version and everything worked.

If you have multiple sites that are critical, why are you using beta software?


(Jim Cook) #30

Good point. My bad. The sandboxing issue had me concerned and I thought it would be fixed in newer editions. I was incorrect and I’m paying the price.


(Dan) #31