RapidWeaver 8.1 Final Candidate 3 (Build 20508b)


(Dan) #1

Hey Weavers,

This new build of RapidWeaver 8.1 has better crash detection.

RapidWeaver will now try and detect if it caused the crash or if a third-party addon is at fault.

We hope this change will help you better locate the source of any issues you may run into so that can get back up and running more rapidly. Please let me know how you get on.

Fingers crossed we’ll get 8.1 finalised and shipped before 2019 :scream:

Happy Weaving!


What’s New in RapidWeaver 8.1?

  • Sandboxed!
  • Dark Mode for Mojave now supported
  • Added Amazon S3 as a Publishing Destination
  • Touch Bar support added
  • Added support for resizing the preview in the main window
  • Added support back in for copying a resources URL
  • Added a new drop down menu to the Simulator toolbar button
  • Added iPhone XS Max to the simulator window
  • Added an option to disable OpenGraph metatags on a per page basis
  • Add a new preference to disable UI sounds
  • Multiple selection is now supported in the Resources Browser
  • Resources can now be dragged from a child folder to the root resources folder
  • Source list layout is now restored between opens
  • Improved the handling of files in the Resources Manager
  • Files in the Resources Browser can now be renamed
  • Fixed an issue where the sitemap plugin and sitemap.xml was displayed and exported incorrectly
  • Fixed an issue with adding edited photos from the resources browser
  • Fixed an issue with resources not getting exported when previewing
  • Fixed an issue where RapidWeaver would appear to deadlock while opening projects
  • Fixed an issue where RapidWeaver would re-publish all files on every publish
  • Fixed an issue where RapidWeaver would get stuck looping between pages
  • Fixed an issue where the incorrect path would be used for social tags in the page header
  • Fixed an issue with multiple buy buttons showing
  • Removed the javascript that was removing line breaks from the Offroad theme
  • Fixed an issue where banner images wouldn’t show due to an issue with CSS consolidation
  • Fixed a naming issue with FontAwesome
  • Show Properties button in Blog now works correctly
  • Fixed various podcasting and channel issues within the Blog page
  • Fixed an issue with page styles being incorrectly applied to Master Styles
  • Fixed up an issue with the Addons Installer
  • Fixed up various crashes in the Photo Album Plugin
  • Fixed a crash when using “Reveal in Finder” and the resource cannot be found
  • Fixed up crash when using the link panel
  • Fixed a crash that would sometimes occur in the Snippets Window
  • Numerous other fixes and enhancements!

I understand that this is a non-final version and will probably contain bugs, but I would still like to download RapidWeaver 8.1 Final Candidate 3 (Build ** 20508b** )


(Mathew Mitchell) #2

I tried the new beta this morning but I’m getting an ongoing set of crash messages. It means I can’t work. If I get rid of one message, another pops up right away. The message was for Stacks and I sent to @isaiah. But now I need to go backwards as I simply can’t work with constant pop ups. (BTW my website was working just fine with previous beta. I’m sure there are some potential problems but now need to get back to real work.)


(Joe Workman) #3

This happened to me as well… I had to force quit RW. When I opened RW again, this did not happen again (so far) on the same project.


(Isaiah Carew) #4

This seems like another one of those things where a developer private beta or a heads up email might have been a good thing.


(Dan) #5

@Isaiah so sorry about that, didn’t think it’d be an issue - email us directly if we can do anything to help.

@ everyone else…
Please remember this is a beta and as such is not the final product. Keep the feedback coming it’s all really good and helps us shape the final product.

Expect another build later this week.

Thanks
Dan


(Dave Farrants) #6

Same here - multiple crashes across multiple projects. Installed latest Beta, restarted Mac, projects open fine but as soon as a Stack is clicked on to edit a ‘Crash’ window appears on a loop - dismiss and it comes back, have to close RW with Alt/Apple/Esc.

Edit.
Reverted back to RapidWeaver8-20479b - all back to normal.


(Dan) #7

Do make sure you send the Crash reports to us/Isaiah, will be good to get these fixed up!

Cheers
Dan


(Dave Farrants) #8

@dan Difficult! - I have 12 client websites, the crash happened on 3 that I tried after that I had to revert back to an earlier Beta to be able to continue working.


(Pete Schuder) #9

I know there is a place to find previous versions of RW8, but I am on limited wifi and would appreciate a link. This latest version keeps crashing and then gets into a loop when I try to close down. Can’t get out with regular shutdown, had to use cmdQ. Should have waited longer…


(Pete Schuder) #10

Dan:
How did you revert back to RW8-20479b? Sorry for my ignorance.


(Isaiah Carew) #11

Wow. Not sure how to respond to this twist of events. I did not see this coming.

@ Everyone Else
Well, folks, sorry about this state of affairs. This situation was new to me this morning. I’ll do my best to get a beta release out by the end of the day that’s a tad more usable. Until then I’d recommend moving back to the previous RW beta version or to the release version.

Isaiah


(Dave Farrants) #12

I used this one - RapidWeaver 8.1 Final Candidate!


(Dan) #13

So sorry, in my testing this build was good enough to use on my own projects. Seems it’s causing users more issues than we anticipated :frowning:

In the meantime, I’ll pull this build from the auto-updater and get a new build out later this week.

Always ping me if you need help or have issues with anything, you know I’m alway here to help and just want to make RapidWeaver the best it can be!

Cheers
Dan


(Dan) #14

Latest build has been removed, please use RapidWeaver 8.1 Final Candidate 2 for now!


(Jörgen Isaksson) #15

Hi there! I’m on Version 8.1 (20502b) and I always get this dialog when opening the project

. As soon as I select the home folder everything is fine. But when I save and open the project again I get the same question.

You should really save those security scoped bookmarks in the project file (bundle) and resolve them each time the project file is opened. This way the user doesn’t have to “allow” that folder every time. I have done this for years in my own apps for the Mac App Store and it works well. The only thing to consider is if the security scoped bookmark is “stale” and then you have to ask the user for permissions again.

Best regards / Jörgen


(Tom Bradley) #16

@jogga Hey!

That’s exactly what RW is doing, storing security scoped bookmarks. This alert may pop up if you have any unresolvable bookmarks in an attempt to repair them. Please check to see if you have any resources with question marks and either delete or re-link them.

If it still appears, could you send the project to support@realmacsoftware.com so we can take a look?

Cheers


(Martin Waring) #17

I’ve just recently found that with RW8, if I don’t complete the Web Icons section (below General) for a project - I get a couple of ‘404 resources not found’ error codes generated which aint good for SEO. Previously I had been using the realfavicongenerator for all my web icons so am I now forced into using this Rapidweaver 8 alternative whether I like it or not? Or is there a way to turn this off? I’m not finding it if there is.


(Martin Waring) #18

Is there any reason why when working on a project the middle pane will suddenly change so that it then has to be scrolled left and right in order to see all of it? Even with both left and right panes closed I still have to left and right scroll the main centre pane. I am working on 15inch MBP on what could be quite a complex layout.


(Jan Fuellemann) #19

I am curious as well. As RW does not support all Favicons out of the box, I would like to rely on the generator as well. @dan Any insights on this? Could you check if this is always the case? Or better - support the additional Favicons?


(Jörgen Isaksson) #20

Hi Tom… that was fast! As soon as I have “allowed” access to the home folder I don’t see any quesion marks in the resources window, and everything works as expected. Hmmmm… OK. I’m sending my project file to support. Notice that I have the project file and resources stored on my iCloud volume since I need to get hold of it from many other Macs. Good luck!
Best regards / Jörgen