RapidWeaver 8.1 Public Beta 8 (Build 20385b)


(Dan) #1

Hey Weavers,

Here’s the latest beta of RapidWeaver 8.1 - Please keep the feedback coming, it’s really helpful.

Make sure you back up any mission-critical projects before using them with this version, and yes, you can run this alongside other versions of RapidWeaver should you wish.

If you find any issues please report them here in this thread.

What’s New in 8.1 Beta 8 (Build 20385b)?

  • Started work on adding Touch Bar support!
  • Added support for resizing the preview in the main window
  • Various other minor fixes

What’s New in 8.1?

  • Dark Mode for Mojave now supported
  • Added Amazon S3 as a Publishing Destination
  • Touch Bar support added
  • Added support for resizing the preview in the main window
  • Added support back in for copying a resources URL
  • Added a new drop down menu to the Simulator toolbar button
  • Added iPhone XS Max to the simulator window
  • Add a new preference to disable UI sounds
  • Multiple selection is now supported in the Resources Browser
  • Resources can now be dragged from a child folder to the root resources folder
  • Source list layout is now restored between opens
  • Files in the Resources Browser can now be renamed
  • Fixed an issue where the sitemap plugin and sitemap.xml was displayed and exported incorrectly
  • Fixed an issue with adding edited photos from the resources browser
  • Fixed an issue with resources not getting exported when previewing
  • Fixed an issue where RapidWeaver would appear to deadlock while opening projects
  • Fixed an issue where RapidWeaver would re-publish all files on every publish
  • Fixed an issue where RapidWeaver would get stuck looping between pages
  • Fixed an issue where the incorrect path would be used for social tags in the page header
  • Fixed an issue with multiple buy buttons showing
  • Removed the javascript that was removing line breaks from the Offroad theme
  • Fixed an issue where banner images wouldn’t show due to an issue with CSS consolidation
  • Fixed a naming issue with FontAwesome
  • Show Properties button in Blog now works correctly
  • Fixed an issue with page styles being incorrectly applied to Master Styles
  • Fixed up an issue with the Addons Installer
  • Fixed up various crashes in the Photo Album Plugin
  • Fixed a crash when using “Reveal in Finder” and the resource cannot be found
  • Fixed up crash when using the link panel
  • Fixed a crash that would sometimes occur in the Snippets Window
  • Numerous other fixes and enhancements to boring (or too secret to mention yet)
  • [DEV] Added a method to plugins to mark a page as changed without reloading the preview #2781

I understand that this is a beta and will probably contain bugs, but I would still like to download RapidWeaver 8.1 beta 8 (Build 20385b)

If you do find an issue please report it here on this thread.

Happy Weaving!


Resources link to source
(Dan) #2

(Paul Russam) #3

Not only have you reintroduced preview width adjustment youve make it better than it was before!
Thank you


(Greg Schneck) #4

@Dan @Aaron
This beta release still does not fix this bug introduced in beta 5 and 6. Can you please, please, fix?

Refer to this post please


(Mathew Mitchell) #5

The beta has a serious flaw. I’ve tested on 2 different computers. I can republish all with no problem. But if I try to publish pages that have been changed (1, 2 or more) then the app crashes.


(Aaron Marquez) #6

Just confirming, would that be if you right-click and select “publish page/changes” for those selected pages?


(jol yates) #7

Bug (disappearing sidebar images) here:

Jol


(Mathew Mitchell) #8

@Aaron It happens either of 2 ways:

  1. I right click and select publish changes
  2. I actually make changes to 1 or more page and then select to publish

This is a very reliable bug: it happens every time I try. I’m now safely back in the arms of 8.0.3.

I’m using Mojave with MacBook Pro (Dec 2016) and iMac 27 (Aug 2017)

I’ve also tried restarting the computer. Still persists. No problems on 8.0.3, nor on the immediately previous beta version.


(James Bond) #9

Thank you.


(Wondrous) #10

Where the autocompletion code in the field of the CSS? In this version of its at all not will?


#11

I run a MacBook 2017, a MacBook Air 2012 and a MacMini 2013, all now on MacOS 10.14 Mojave, with the first two on SetApp copies a of RW 8.0.3 and the others on Realmac licensed copies. My experience of RW 8.0.3 was the same on all three, a series of increasing crashes when trying to close a file, having successfully uploaded. sometimes it worked, sometimes it didn’t. I found that the only foolproof way was to close RW8 completely and when I next ran it, the file was in a closed state. Recently, it got worse and I couldn’t even do that. Once open, there was no way to close the file at all.

I have been following the various Beta threads and in desperation eventually jumped in and tried Beta 8 on one of the laptops. Guess what? All my file saving issues have disappeared! It works exactly as it should do. Which is not the experience of at least one other user on here. So I guess it shows that software is really complicated and other programs you run may interact in an unexpected way. Personally, I just feel that Mojave itself feels slightly flaky and will be happier when Apple issue a bug fix update.

So, while I await the full release of RW 8.1, so my SetApp versions updates as well, I will happily run the Beta versions, even though there may still be a few things to iron out.


(SF) #12

Am I the only one who’s missing the replace page option from RW7?


(Menno) #13

Glad to see it is back. Thanks :+1:


(Judson) #14

Cache busting links enabled crash my project. Unchecking publishes fine.


(Simon Maddox) #15

Thanks for reporting this, @JudsonDigital! We’ll take a look.
Just in case, could you email a project to support@realmacsoftware.com with a link to this thread please? Tell them I sent you, and they will get your project over to me to look at :+1:


(Simon Maddox) #16

Hi @JudsonDigital. Thanks for sending your project in! Unfortunately I’ve been unable to reproduce the issue here :frowning:

When RapidWeaver crashes, does it show a Crash Reporter window? Have you submitted that? If so, can you message me privately to tell me the email address you used? I’ll be able to find your crash report and hopefully fix it that way instead :slight_smile: