RapidWeaver 8.1 Public Beta 5 (Build 20330b)


(Dan) #1

Hello Weavers,

This is the fifth public beta for RapidWeaver 8.1, there’s lots of nice fixes and enhancements in this build (especially in the Resources Browser, we now support multiple selection and more!), but please remember this is a beta and as such is still in development.

What’s New in 8.1?

  • Dark Mode for Mojave now supported
  • Added Amazon S3 as a Publishing Destination
  • Added support back in for copying a resources URL
  • Multiple selection is now supported in the Resources Browser
  • Resources can now be dragged from a child folder to the root resources folder
  • Source list layout is now restored between opens
  • Files in the Resources Browser can now be renamed
  • Fixed an issue where the sitemap plugin and sitemap.xml was displayed and exported incorrectly
  • Fixed an issue with adding edited photos from the resources browser
  • Fixed an issue with resources not getting exported when previewing
  • Fixed an issue where RapidWeaver would appear to deadlock while opening projects
  • Fixed an issue where RapidWeaver would re-publish all files on every publish
  • Fixed an issue where RapidWeaver would get stuck looping between pages
  • Fixed an issue where the incorrect path would be used for social tags in the page header
  • Fixed an issue with multiple buy buttons showing
  • Removed the javascript that was removing line breaks from the Offroad theme
  • Fixed an issue where banner images wouldn’t show due to an issue with CSS consolidation
  • Fixed a naming issue with FontAwesome
  • Show Properties button in Blog now works correctly
  • Fixed an issue with page styles being incorrectly applied to Master Styles
  • Fixed up an issue with the Addons Installer
  • Fixed up various crashes in the Photo Album Plugin
  • Fixed a crash when using “Reveal in Finder” and the resource cannot be found
  • Fixed up crash when using the link panel
  • Fixed a crash that would sometimes occur in the Snippets Window
  • Numerous other fixes and enhancements to boring (or too secret to mention yet)
  • [DEV] Added a method to plugins to mark a page as changed without reloading the preview #2781

Make sure you back up any mission-critical projects before using them with this version, and yes, you can run this alongside other versions of RapidWeaver should you wish.

What’s new in 8.1 beta 5?

  • More work on the Resource Browser, lots of nice enhancements!
  • Colour pickers now have have their borders back
  • Fixed a bug in the Site Settings Interface
  • Theme Thumbnails now show in 10.11 and 10.12
  • “Preview In…” sheet tweaked to work with Dark Mode
  • Fixed an issue with the Sidebar in Dark Mode
  • Fixed a crash when restoring saved documents
  • Fixed a bunch of theme style issues
  • Fixed a font issue with the Offroad theme
  • Fixed an issue where links to resources in preview mode were incorrect

I understand that this is a beta and will probably contain bugs, but I would still like to download RapidWeaver 8.1 beta 5 (Build 20330b)

If you do find an issue please report it here on this thread.

Happy Weaving!

Thanks

Dan


(Wondrous) #2

Dan, thank you, the thumbnails become visible. But why in the sidebar CSS can’t substitute the expressions/code? You start typing and nothing is offered, in previous versions (RW 7) it was. Or does it depend on the Stacks plugin?


(Gary White) #3

In Dark Mode, there are a couple of tweaks I noticed that are still required:

The privacy message has black text on a dark background:
RW8_1b5-PrivacyMessage-DarkMode

Other Tags on the Inspector/Meta Tags doesn’t show the +/- on the buttons:
RW8_1b5-OtherTags-DarkMode

One other question - I noticed that when I let RW generate the social tags that the URL for images gets an extra slash before the resource folder. Seems wrong to me, but is there a reason for this? RW doesn’t add the extra slash before the resource folder in the URLs for the Web Icons:
RW8_1b5-social-tags


(Alix) #4

RW7 and RW8

When I try and upgrade a RW 7 doc and open it in RW8, RW 8 has stopped opening a RW7 doc and gives me the Crash Reporter. (Version 8.1 (20330b))

And when I now open a doc in RW 7 it works fine, until I try and save it. (Even if I havent made any changes) the act of asking the app to save a doc hangs RW7. (Version 7.5.6 (18820))

So affectively I can neither upgrade my RW 7 docs or use them in RW 7 anymore.

I’m very fed up. I have an email newsletter that was made in RW7 and needs to go out asap

I have tried (not sure this would or would not make any difference, but thought it was worth a try) repairing my iMac disk permissions, but all of the above is still happening.

Does anyone have any ideas please?


(Dan) #5

Quick reply as I’m out and about right now, but try downgrading back to 8.0.3 for now. Does that help?

Could you also send the troublesome document to dan@realmacsoftware.com (with a link to this thread) so we can look into this further for you.

Many Thanks
Dan


(Alix) #6

Reverting to 8.03 has worked and both RW7 and 8 now work as expected.

It wasn’t just one file, it was all RW7 files not opening in RW8. A developer had also sent me a template (RW7)and that wouldn’t open either. So of course I then tried to us RW7 to update my RW7 sites and this didn’t work either as any site I opened as soon as I saved it RW7 crashed. So there is nothing to send you. Unless there is some log thing that I could send you detailing this.

I did send all the crash reports

A:)


(Dan) #7

@alixnotes We’ve looked into this and have fixed up the issue, all should be working well in the next beta that’s due out later this week.

Cheers!


(Alix) #8

well all is still not well.

RW 8.03 worked fine yesterday. Now it is falling over. I have 4 tabs open all on edit and everything I try to shut one of them RW falls over. I have filled in the Crash reports every time. I have tried closing different tabs but it doesn’t make any difference. I am SO fed up of this. Frankly I wish I had never updated to 8 at all and just kept on with 7. Problem is now tho I have new stacks installed in 8 and as I use RW on a daily basis a large amount of work in RW 8. Help please!


(Dan) #9

Hi Alix,

For the time being I’d suggest not using tabs if you’re seeing issues. We’ll look into it and will hopefully get it fixed in the next update.

btw. You can run RW7 side-by-side with RW8, just point the add-ons location to the same custom location.

Cheers
Dan


(Alix) #10

Thanks for the reply, Dan. I do realise that I can run them side by side, but Ive been using RW8 for several weeks now and I assume that the docs are not backwards compatible. However, maybe I can I copy and paste the changes I have made in RW8 into RW 7? Is that possible?

As far as the tabs are concerned, I can’t just use one tab because I cant get the tabs to close. When I close any of them RW 8 falls over so when I reopen it it still has all the tabs opening up. Is there a keyboard combination to get RW to open up without opening any docs?


(Doug Bennett) #11

I don’t remember all the options available at startup(not at Mac), but try starting while holding the opt key. A menu opens with several startup options.


#12

I find the only way out of this behaviour (which I am suffering from as well) is to not even attempt to close individual tabs, but just close RW8.03 completely. The next time you restart RW8.03 the projects are in a closed state and you can carry on working.


(Alix) #13

Thanks Doug. I tried that but it doesn’t give me the option to not open the windows. Lots of other options but not that.


(SF) #14

@dan I’m noticing issues with OG tags and third party stacks/cms systems in RW8.

We need the ability to turn off the social media tags on stack pages that generate other pages, otherwise the OG meta data gets created twice, and only the first one, (RW8’s introduced data), gets scanned by things like FaceBook.

Total CMS is an example of where I’m running into that issue.

Any plans to be able to toggle that off?


(Dan) #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.