RapidWeaver 8.1 Public Beta 1


(Dan) #1

Hello Weavers,

This is the first public beta for RapidWeaver 8.1 — in this version we’re focusing on stability, improving export/preview speeds, and making sure we’re compatible with Mojave when it launches (expect to see dark mode support in a future beta).

So with that out of the way, here’s a list of what’s new:

  • Fixed an issue where RapidWeaver would re-publish all files on every publish
  • Fixed an issue where RapidWeaver would get stuck looping between pages
  • Fixed an issue where the incorrect path would be used for social tags in the page header
  • Fixed an issue with multiple buy buttons showing
  • Removed the javascript that was removing line breaks from the Offroad theme
  • Fixed an issue where banner images wouldn’t show due to an issue with CSS consolidation
  • Fixed a naming issue with FontAwesome
  • Show Properties button in Blog now works correctly
  • Fixed an issue with page styles being incorrectly applied to Master Styles
  • Fixed up an issue with the Addons Installer
  • Fixed up various crashes in the Photo Album Plugin
  • Fixed a crash when using “Reveal in Finder” and the resource cannot be found
  • Fixed up crash when using the link panel
  • Fixed a crash that would sometimes occur in the Snippets Window
  • Numerous other fixes and enhancements to boring (or too secret to mention yet)
  • [DEV] Added a method to plugins to mark a page as changed without reloading the preview #2781

While we feel this build is stable enough to use on a daily basis, please be aware it is beta and is not final. Make sure you back up any mission-critical projects before using them with this version, and yes, you can run this alongside other versions of RapidWeaver should you wish.

I understand that this is a beta and will probably contain bugs, but I would still like to download RapidWeaver 8.1

If you do find an issue please report it here on this thread or email dan@realmacsoftware.com

You can expect another beta later this week, or early next.

Happy Weaving

Thanks
Dan


RW8.1 "Unable to load CMS preview libraries" in Preview
(Keith Flanagan ) #2

Hi Dan,

Any chance of added touchbar support for those of us with a newer MBP?


(Greg Schneck) #3

@dan
As info… 8.1 beta will not open a project that has opened fine in every version of RW8 so far…
Upon the “open” of my project I get the spinning beach ball and I have to force quit.

Going back to any previous version, project opens fine.


(Dave Farrants) #4

@dan Same here.


(Tom Bradley) #5

@1611mac @DaveFox

Hey guys, would you be able to send your project files to dan@realmacsoftware.com so I can dig into this.

Cheers


(Dave Farrants) #6

@tpbradley Done.


(Greg Schneck) #7

@tpbradley - Done - sent @Dan a Dropbox link to my project.

Tom… I’ll be working on this today myself. My project file is one of many that makeup a 1600 page site. This particular project is very small and I’ll “work it” today by removing one item at a time until I can get it to open in the beta. I’ll post here and also email Dan if I find anything.


(Tom Bradley) #8

Thanks guys, I’ve located the problem. It’s to do with auto starting the web server when the document loads. I’ll get that fixed for the next release :smiley:


(Greg Schneck) #9

Thanks… I was just going to post that I trimmed my project down to ONE blank home Stacks3 page and it still wouldn’t open. Glad you found the problem.

I can confirm that when I open the project in 3.0.3 and set auto start OFF then you are correct, the project opens fine in the 3.1 beta 1.

Thanks!


RW 8 Bug? - upon open, automatically updates date of addons folder AND RW files
(Tappy) #10

Issue with PowerGrid CSV Stack posted here: RW8.1 "Unable to load CMS preview libraries" in Preview


(Wondrous) #11

Dan, tell please, how to select and delete multiple files in Resources?


(Dan) #12

You have to delete them one by one at the moment, but it’s on our to do list for RW 8.1!


(Wondrous) #13

Okay, thank you!

Noticed in the new version of the RW8 that it sometimes opens the project immediately with a Preview and open sidebar with stacks. In RW 6 and 7 this was not.


(Doug Bennett) #14

That’s a new feature. It’s supposed to open to the same state it was closed in.


(Wondrous) #15

Hmm, nothing like that. Before closing the program, I saved the project on the editor’s page, not Preview, and the sidebar with the stacks was closed.
It is not clear why this is done.


(Rob D) #16

In my case, projects sometimes open with saved state and sometimes they don’t. Most notably, the Library side-panel should always open, but it doesn’t always happen. That is true for both new projects and those that were converted from RW7.


(Wondrous) #17

It is not clear, of course, why do so. Opened a project, opened and closed the sidebar on the left or right, the project didn’t do anything, but when closing the program asks about saving the project. What for?!

And the question of automatic saving of the project while exporting remains very incomprehensible.


(Eugenio) #18

I hope it works, since version 8 does not work, the 7 is even better


(Dominique Renard) #19

When I click on “install and relaunch”, Rapidweaver closes and nothing else happens. If I reopen, the proposal for updating to 8,1 appears once again…


(Robert Ziebol 🖖🏼) #20

Go get the Beta 4 version maybe??
https://forums.realmacsoftware.com/t/rapidweaver-8-1-public-beta-4/22403/9