RapidWeaver 8.2 is now Available (UPDATED)


(George Peacock) #21

I accepted my system’s recommendation to upgrade to 8.2 this morning. I was able to preview just not able to publish. Came up with a Stacks error for Lockdown on a key project I have - I will look to downgrade back to 8.03 if I can - as that version consistently works.

Sorry to say this, but it’s getting very scary upgrading RW these days (I have been looking at the Forum re messages around versions as they come out). Any advice on what is the latest “fairly stable” version?


(chuck berhain) #22

My thoughts too, not confidence inspiring.
I ultimately use the direct download just for additional peace of mind.
8.2 is thankfully working without obvious problems at least.


(Phil) #23

9 months since version 8 launch!


(Dave Vaughn) #24

Since the last Rapidweaver update Version 8.2 (20740), I can not publish changes to Rapid Cart (v4.15.0 (3120)) - CRASHES INSTANTLY

I have been using for months without issue until this latest updates - Please advise - must make RapidCart changes for clients - Thank you!


(Neil) #25

If you’re having issues, you can go back to the previous version (8.1.7) for now. https://www.realmacsoftware.com/rapidweaver/releasenotes/


Unable to Export with RW 8.2
(Dan) #26

I don’t think this is RapidWeaver related. You should contact the guys at Rapid Cart Pro as it may be an issue they need to fix.

Thanks
Dan


(Tom Bradley) #27

Hey guys,

Thanks for reporting these problems. As Dan said we think some of these could be plugin related. However, if you could send me your project file along with instructions to reproduce the problem, I’ll see what I can find. Email it to me at support@realmacsoftware.com with a subject of “FAO: Tom #3079”.

Project files can be quite large so using DropBox or WeTransfer might be necessary.

Cheers
Tom


RapidWeaver 8.3 Public Beta 1 (Build 20772b)
(Dave Vaughn) #28

Ok, I reverted back to RW 8.1.7 and all working again, thanks


(Dave Vaughn) #29

Hi Dan, thank you for the quick response. As per an email from “NeilUK”, I reverted back to RapidWeaver 8.1.7 and all is working well again.

I will hold at 8.1.7 and watch for new version details.

Best,

Dave


(Doug Bennett) #30

You didn’t say the error. There was an error reported with the Lockdown plugin on the YourHead slack channel May 18th with the beta version of RapidWeaver. @isaiah was looking into it
Don’t know if this is the same problem, but it didn’t sound like it was an issue with RapidWeaver itself but with the Lockdown plugin similar to the changes done to Pluskit and sitemap plus.


(George Peacock) #31

Doug. Thanks for note. I looked on the Yourhead site for latest version etc but missed the note you mention. However I sent a screenshot of the log to Yourhead. I have since downgraded to 8.17 (seems others have had fairly good exp with this one) and giving that version a go. I was previously on 8.03 which worked really well, however it was pre the big change on Resources. I am a UIKIT fan and their new version 3 requires a more recent version of RW, so hence a deep breath and trying out 8.17.


Style text plugin missing
(Doug Bennett) #32

The note I mentioned was on the YourHead slack channel:
https://yourhead.slack.com/
It’s kind of an advanced forum for YourHead products used a lot by developers of stacks. I checked and haven’t heard mention of a fix (new release beta) yet from @isaiah.


(Ronnie West) #33

Is it safe to update to latest version now?
Also is this a free update or a paid version upgrade?
Cheers!
Ron.


(Doug Bennett) #34

That depends on what you’re upgrading from. If you have the latest main version 8.x the incremental upgrade are free. If you’re running any earlier versions like 7.x or 6.x than it’s a onetime paid upgrade to get to the latest 8.x version.

Seems most folks aren’t having issues with 8.2. The folks that are drop back to 8.1.7. The issues from above, seem to be with certain plugins.
The two mentioned above “Rapidcart Pro” and “Lockdown”.

As always it’s best practice to have a good backup strategy in place.


(Doug) #35

Still getting a new web inspector open behind RW every time i preview.
This only happens if i have safari open, If safari is shut down nothing appears.
Also tried with firefox and chrome, the inspector does not appears with them.

Cheers
Doug


(Eric Vaughn) #38

Thank you @dan, the RW Team and all the Stack Developers for continuing to make this the best web development software anywhere. I truly appreciate the hard work you guys do!!!


(Markus Frieauff ) #39

Same here!


#40

RapidWeaver 8.3 (20766b) seems to have been released into beta today, without any sort of fanfare. Maybe this is to address the problems mentioned?


(SF) #41

So RapidCart is working ok on 8,1,7? What was the error you were having with 8.2? I’m terrified of trying to make a change now to RapidCart Pro to discover it’s been busted.


(Markus Frieauff ) #42

Is there any news on the annoying bug that opens a web inspector window behind RW everytime we preview? Sometimes when I am done editing and want to check the page in Safari I need to close 15-20 of those windows…