🚀 RapidWeaver 8.3 is now Available!


(Dan) #1

Hello Weavers,

I’m pleased to announce that RapidWeaver 8.3 is now available directly, and via Setapp. The App Store version should be available in the next few days once Apple have approved it.

This is an excellent release and a recommended update for all users. If you’re still using RapidWeaver 5, 6, or 7, you can upgrade for a discounted price here.

What’s New in 8.3?

  • Ongoing work to improve Amazon S3 Publishing
  • Added support for Emporter
  • Added new update engine due to DevMate going away
  • Added support for detecting and managing duplicate images
  • Fixed an issue when copying the url of a resource
  • Fixed an issues with sub folders being incorrectly named when opening and old project
  • Fixed an issue where an ‘Untitled Folder’ directory could be seen in resources
  • Fixed a crash when adding new resources if existing resources are unresolved
  • Fixed a crash in the link panel
  • Fixed a crash when dragging a resource into site settings
  • Fixed an issue where the blog social images would not be saved
  • Updated Multi Lander Theme
  • Various other under the hood tweaks and fixes.

Download RapidWeaver 8.3 here

Have a good weekend and Happy Weaving!

Cheers
Dan & Team


(Dan) #2

(Ai Konn) #3

Hello Dan,

thank you for providing 8.3!

I just tried it, but for me there are still two bugs left:

  1. When you publish to 1&1 (German server) Rapidweaver still needs about 60 - 90 seconds to connect. This bug exists since version 8.2

  2. I’m using the stack ‘switcher’. If you are in Edit Mode everything is alright. But if you go to ‘Preview’ the stck disappears. There is nothing to see in Preview from Switcher.

So the last version that really is OK for me ist still 8.1.7


(Rosalind Share) #4

Hi Dan, thank you for the update!

I have downloaded 8.3, but it has installed itself in the Applications folder as RapidWeaver 8.2 ie it didn’t overwrite Rapidweaver.

Am I supposed to delete the old RW & rename RW 8.2?

Many thanks,

Ros


(Menno) #5

@dan
Just to inform you: The link to Rapidweaver 8.3 on the Rapidweaver Release Notes page downloads v 8.2.1 (20758).

The link you provided in this post is OK of course.

Cheers,
Menno.


(Dan) #6

Thanks, this has now been fixed!

In other news, the App Store version of RapidWeaver 8.3 is now available!


(Uikitter ) #7

RW itself is saying 8.2.1 is the latest, when you run update checker.


(John R. Hughes) #8

When checking for an update in the app, it says RapidWeaver 8.2.1 is currently the newest version available.


(allen) #9

Awesome work!!!

would you pls tell me where to “log”/“file”/“inform you of” bugs that I find? I definitely want to help you bug test


(Tom Bradley) #10

@UiKitter @1Macman Thanks, I’ve just fixed this so please give it another try.

@aragorn7773 Great thanks, you can report bugs here on the forum or via email to support@realmacsoftware.com, cheers!


(John R. Hughes) #11

Works now, thanks for fixing it.


(Rosalind Share) #12

RW 8.3 installs in the Applications folder as RapidWeaver 8.2 ie it does NOT update RW in Applications.

I have posted to Dan but no reply.


(Trond Grøntoft) #13

That didn’t happen here. The new version installed itself as RapidWeaver 8.app replacing the old one with the same name.


(Rosalind Share) #15

Strange as this is usually thhe case. Deleted both & reinstalled!


(Axel) #16

I just updated from 8.2.1 to 8.3 and in the main window RW now complains that I have no stacks installed, even though they appear as installed in RW / Prefs. Reinstalling the stacks has no effect - I get the expected “already installed” warning and clicking “Continue installing” doesn’t make the stack functional. I deleted RW (both just the app and again with everything AppCleaner finds) and downloaded 8.3 and reinstalled with no change - still no stacks.

Prefs / Addons / Stacks / Reveal in Finder shows the correct folder with all of my stacks.

Is there an official way to completely uninstall? What else can I try?


(Jan Fuellemann) #17

Does the message tell you that the plug-in Stacks (capital S) is not installed or the stacks themselves? I would first reinstall Stacks (the plugin) from Yourhead software athttp://yourhead.com/stacks/


(Axel) #18

Stacks itself appears to be installed and working. The individual sub-stacks are allegedly not installed… but reinstalling Stacks appears to have fixed it! Thanks for the suggestion Jan!


(allen) #19

Thank you
Thank you
Thank you :smile:


(Stephen Jeffrey Andrew Dalton) #20

Hi there I updated to 8.3 but noticed most of my stacks and other parts would not work did I do something wrong or do we have to get new add-ones??


(MRO) #21

Hi Stephen,
Maybe you have to update your Stacks?

Go to Library and then Updates

See picture: