RapidWeaver 8.2 is now Available (UPDATED)


(Dan) #1

Hello Weavers,

As you may know, we’ve been working hard on 8.2 for many months, and I’m pleased to say it’s now available :partying_face: Thanks to everyone who helped with the beta, it really does makes a difference!

So, on to the good stuff, here’s a list of what’s new:

What’s New in RapidWeaver 8.2

  • Lists in styled text areas should now behave a little better
  • Improved the speed of export when publishing to a RAM disk
  • RapidWeaver is now Notarized via Apple
  • Further work on improving the way missing resources are searched for (and hopefully found).
  • Fixed an issue where users were unable to “Copy Support Logs”
  • Removed the SFTP public key field from publishing settings (as it’s not required)
  • Fixed the preview issue where RapidWeaver wouldn’t update the preview correctly
  • Fixed a bug where RapidWeaver would appear to hang during publishing (possibly caused by OpenSSL and certificate/server issues)
  • Fixed up a tonne of issues with the Photo Album page type
  • Contact form now updates correctly when changing page properties
  • Control + Left Click a resource in the resource browser now works correctly
  • Improved performance when accessing files, especially from remote drives
  • Fixed a crash in the crash reporter, and it does make you wonder if perhaps we need a crash reporter for the crash reporter.
  • Fixed an issue where preview would get stuck in an endless loop (or dare I say infinite loop).
  • Fixed an issue when saving with an image attachment in styled text areas would deadlock the app

If you’re still using an older version of RapidWeaver, we’d urge you to upgrade now. This is honestly the best version of RapidWeaver we’ve ever shipped.

Edit: Some users have reported developer identity errors when launching RapidWeaver. A new build is now available that rectifies this problem.

Download the direct version of RapidWeaver 8.2.

Happy Weaving!


(Dan) #2

(Chris Handley) #3

“RapidWeaver 8” can’t be opened because the identity of the developer cannot be confirmed.


(Brian LaPan) #4

That’s a standard non-MAS security warning. Just go to your System Prefs/Security/General and just ok the app there. Or wait for the MAS version to pop up - I imagine it will be soon.


(Neal Tobochnik) #5

The info page says that you need Mac Os 10.12 for this update. But it seems to run fine in Mac OS 10.11.6. What is the answer?

Is something going to break?


(Markus Frieauff ) #6

I installed the update and now with every preview and publish I get the console window of Safari to pop up. See screenshot.


(Paul Russam) #7

Between 11 and 12 Apple introduced some massive changes to MacOS, by stating 12 RM are ensuring compatibility.
It WILL work in 12 and MAY work in 11, if you experience problems then it’s on you.
For example, a lot of stacks are now requiring php version 7 or greater, 10.11 has php5


(Dan) #8

You shouldn’t be seeing that error as RapidWeaver is code signed. Can you try re-downloading RapidWeaver 8.2

Has anyone else see that issue with RW?


(Stuart Marshall) #9

Yes - I got that too when installing this version.


(Doug) #10

Installed new version and also get a new console window with every preview and a new console window when returning to editor, so 2 new consoles every time I preview.


RapidWeaver 8.3 Public Beta 1 (Build 20772b)
(Neil) #11

8.2 just crashes for me. Every time I try to set up publishing or publish with SFTP.

I’ve gone back to the previous version.


(Tom Bradley) #12

Hey guys, thanks for reporting the problems!

We’ve temporarily removed v8.2 while we investigate. Please revert to 8.1.7 for now, you can grab it here

https://dl.devmate.com/com.realmacsoftware.rapidweaver8/20674/1553595093/RapidWeaver8-20674.zip

Cheers


(Dave Farrants) #13

8.2 installed with no problems and publishing OK here (down’d 8.1.7 just in case :wink:)


(Tom Bradley) #14

Alrighty, I’ve just pushed out a new build that should fix the developer identity problems!

@therealmf @DougUK @NeilUK This build may well fix your problems too, could you give it a try?

Happy Weaving!


(Doug) #15

Just installed again, I don’t get a new console window when hitting preview now, but i do get new console window when returning to editor from the preview. so now i’m just getting one new console window when i preview :slight_smile:

btw the new console window appears behind so you don’t see them till you minimise RW.


(Tom Bradley) #16

I think this could be a hang over from running the last build. Could you try closing all windows that RapidWeaver has open, then restarting the app?


(Doug) #17

Just re-booted, started RW then hit preview and no console window appeared, then went back to RW editor and no console window appeared.

However when i started safari…
The console windows appeared twice again on RW preview, so I then closed safari, tried again and the console windows did not show.

So they only seem to appear when safari is open :slight_smile:

Also just tried with Chrome open and it doesn’t seem to be affected, so it’s related to Safari :slight_smile:


(Markus Frieauff ) #18

Here’s my finding: I installed the update and was able to work without console windows showing up for the last 15 min or so. In that time I previously checked the page I was working on in Safari (cmd-p). Now, after some time of no issues, the console popped up again. It has a header line of “Web information - iMac - RapidWeaver - JSContext” and the window is empty.


(Kurt Trucksess) #19

I just downloaded 8.2. I keep getting the error “Unable to Export” when I go to publish my web site. Any suggestions on how to resolve this issue?


(Dave) #20

Preview is not working for me, Dan. I will revert back as well. Thanks!