RapidWeaver 8.2 Public Beta 3 (20703b)


(Dan) #1

Hello Weavers,

Just in-time for the weekend (again) we have a brand-new build of everyone’s favourite website builder. As usual, all the details are below.

Please remember this is BETA software and as such may contain bugs! If you rely on RapidWeaver for mission-critical work do not use the beta builds, stick to the official releases .

What’s New in RapidWeaver 8.2 Public Beta 3 (20703b)?

  • [NEW] Further work on improving the way missing resources are searched for (and hopefully found).
  • [NEW] Fixed an issue where users were unable to “Copy Support Logs”
  • [NEW] Removed the SFTP public key field from publishing settings (as it’s not required)
  • Fixed the preview issue where RapidWeaver wouldn’t update the preview correctly
  • Fixed a bug where RapidWeaver would appear to hang during publishing (possibly caused by OpenSSL and certificate/server issues)
  • Fixed up a tonne of issues with the Photo Album page type
  • Contact form now updates correctly when changing page properties
  • Control + Left Click a resource in the resource browser now works correctly
  • Improved performance when accessing files, especially from remote drives
  • Fixed a crash in the crash reporter, and it does make you wonder if perhaps we need a crash reporter for the crash reporter.
  • Fixed an issue where preview would get stuck in an endless loop (or dare I say infinite loop).
  • Fixed an issue when saving with an image attachment in styled text areas would deadlock the app

I’m happy with the risks of using beta software and would like to Download RapidWeaver 8.2 Public Beta 3 (Build 20703b).

If you find any issues please report back on this thread with details on how to re-create the bug and we’ll get it fixed for the next beta.

Have a great weekend!

Cheers
Dan


(Isaiah Carew) #2

@dan @tpbradley

Anything change recently involving debugging options? Did you change the notarization or anything like that?

This build is working as expected when I run it normally, but for some reason Xcode refuses to launch this version within the debugger. Xcode provides most terse and useless message I’ve ever seen:

image

I tried automatic update to retrieve the build and also direct download from the link above. Both result in the same error. I’ve also quit, rebooted, and deleted derived data. I’ve launched the app successfully stand-alone to ensure that the quarantine bit is set, so i don’t think it’s gatekeeper blocking things.

Simply pointing the same build-debug-scheme at the 8.1.7 works fine – pointing it at the 8.2 beta 3 build (20703b)

This is Mojave 10.14.4 and Xcode 10.2.1 – which I think is all the latest non-beta releases of os and tools.

That’s it. The console log messages for Xcode are about a thousand lines, nothing that looks particularly useful or educational. There are a few lines that are about the debug server – nothing that jumps out at me and says much interesting – but perhaps there’s something in there that looks similar to a setting you’ve changed recently.

|debug|03:50:25.015477 -0500|Xcode|found no value for key IDEDebuggerSuppressTargetActivationForTest in CFPrefsSearchListSource<0x7fb5e708ce90> (Domain: com.apple.dt.Xcode, Container: (null))|
|---|---|---|---|
|default|03:50:25.023732 -0500|debugserver|2 +0.012573 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|default|03:50:25.035670 -0500|debugserver|3 +0.011940 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|debug|03:50:25.043418 -0500|Xcode|sending={command=210, info={LSFrontReservationExists=true, }, }|
|debug|03:50:25.043742 -0500|Xcode| reply={success=true, }|
|debug|03:50:25.044379 -0500|Xcode|Bundle: <private>, key: Pause program execution, value: , table: Localizable, localizationName: (null), result: Pause program execution|
|debug|03:50:25.044426 -0500|Xcode|Bundle: <private>, key: pause, value: , table: Localizable, localizationName: (null), result: pause|
|debug|03:50:25.046049 -0500|Xcode|Bundle: <private>, key: No debug session available., value: , table: Localizable, localizationName: (null), result: No debug session available.|
|debug|03:50:25.046392 -0500|Xcode|Bundle: <private>, key: No debug session available., value: , table: Localizable, localizationName: (null), result: No debug session available.|
|debug|03:50:25.046538 -0500|Xcode|looked up value <private> for key IDELocationSimulationUsePopover in CFPrefsSource<0x7fb5df53d8c0> (Domain: Volatile, User: , ByHost: No, Container: , Contents Need Refresh: No) via CFPrefsSearchListSource<0x7fb5e708ce90> (Domain: com.apple.dt.Xcode, Container: (null))|
|default|03:50:25.047258 -0500|debugserver|4 +0.011565 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|debug|03:50:25.048510 -0500|Xcode|Bundle: <private>, key: Breakpoint, value: , table: Localizable, localizationName: (null), result: Breakpoint|
|debug|03:50:25.049175 -0500|Xcode|found no value for key XRMemoryGraphAutomaticCapture in CFPrefsSearchListSource<0x7fb5e708ce90> (Domain: com.apple.dt.Xcode, Container: (null))|
|debug|03:50:25.049326 -0500|Xcode|found no value for key DBGUseDebugHierarchyInfrastructureIfSupported in CFPrefsSearchListSource<0x7fb5e708ce90> (Domain: com.apple.dt.Xcode, Container: (null))|
|debug|03:50:25.055823 -0500|Xcode|found no value for key bristol in CFPrefsSearchListSource<0x7fb5df61cc50> (Domain: com.apple.universalaccess, Container: (null))|
|default|03:50:25.058795 -0500|debugserver|5 +0.011559 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|default|03:50:25.070408 -0500|debugserver|6 +0.011613 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|default|03:50:25.082087 -0500|debugserver|7 +0.011674 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|default|03:50:25.088907 -0500|Xcode|Making presenter 0E879B57-B9DB-4802-9BEA-7BB904FE72F0 observe change|
|default|03:50:25.089045 -0500|Xcode|Making presenter 0E879B57-B9DB-4802-9BEA-7BB904FE72F0 observe change|
|default|03:50:25.093686 -0500|debugserver|8 +0.011585 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|default|03:50:25.105284 -0500|debugserver|9 +0.011610 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x00000005|
|default|03:50:25.116935 -0500|debugserver|10 +0.011655 sec [8119/0307]: error: ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) err = ::task_for_pid ( target_tport = 0x0103, pid = 33048, &task ) => err = 0x00000005 ((os/kern) failure) (0x0000000|
|debug|03:50:25.119121 -0500|Xcode|Bundle: <private>, key: line %i, value: , table: Localizable, localizationName: (null), result: line %i|
|error|03:50:25.128467 -0500|debugserver|error: MachTask::StartExceptionThread (): task invalid, exception thread start failed.|
|error|03:50:25.128632 -0500|debugserver|error: Attach failed: "unable to start the exception thread".|

RapidWeaver 8.2 Public Beta 1 (20697b) — UPDATED BUILD
(Tom Bradley) #3

Hey @isaiah,

RW isn’t notarized but we are attempting to. This must be originating from one of the build settings I’ve altered. Leave it with me :wink:


(Isaiah Carew) #4

thanks @tpbradley,

if you need any more info from me – or need me to test a build, just say the word


(Dan) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.