RapidWeaver 8.3 Public Beta 1 (Build 20772b)


(Dan) #1

Hey guys,

Here’s an early build of RapidWeaver 8.

Please remember this is BETA software and as such may contain bugs! If you rely on RapidWeaver for mission-critical work do not use the beta builds, stick to the official releases .

What New in 8.3?

  • Added new update engine
  • Added support for Emporter
  • Various other under the hood tweaks and fixes.

I’m happy with the risks of using beta software and would like to Download RapidWeaver 8.3 Public Beta 1 (Build 20772b).

If you find any issues please report back on this thread with details on how to re-create the bug and we’ll get it fixed for the next beta.

Happy Weaving :slight_smile:

Cheers


(Markus Frieauff ) #2

Did you manage to fix the “preview opens new console window in Safari” error?


(Doug Bennett) #3

I’ve been using the 8.3 beta versions for a while and have not seen this happening. But I don’t remember this happening before so not sure what triggers that behavior.

I use web inspectors all the time usually with simulator or preview in browsers but sometimes in preview and haven’t noticed any unusual things happening.

If you could maybe give a bit more details on what’s happening and what triggers the behavior I’d be happy to test it out later today.


(Dan) #4

Can you remind me of the exact issue, perhaps post a video of the bug in action?

Many Thanks
Dan


(Markus Frieauff ) #5

Sure. When I enable Developer Tools in Safari and then in RW switch from edit to preview, Safari opens up a new console window (which is empty). The window has a browser window title of “Webinformationen - iMac --RapidWeaver – JSContext”.
When I disable Developer Tools, the console doesn’t open up. Which makes sense.
The problem with this bug is that when I switch frequently (and I do during development) the console windows stack on top of each other, and when I switch over to Safari I have to hit ctrl-w a dozen times or so to get rid of these windows.

Video here: https://www.dropbox.com/s/d1n4tww8mvpfuv0/RW%20console%20bug.mov?dl=0


(Doug Bennett) #6

I took a look at the video and I don’t see that happening with the beta. I honestly don’t remember that happing before.


(Markus Frieauff ) #7

It’s there since 8.2, see this thread here with a few more experiences like mine:


(Doug Bennett) #8

Are you using any of the old LogHound plugins now YourHead like SiteMap+, Lockdown or PlusKit?

Seems like from that thread that may have been the issue?

I never had the issue with 8.2.x but I don’t use those plugins. @isaiah has stated on the YourHead Slack channel that there is a bug in the old LogHound stuff running past RW8.1x and he will fix later.

If that isn’t the issue (you’re not running any of those plugins) then have you sent in a link to a project file to support as @tpbradley requested?


(Markus Frieauff ) #9

No loghound plugins in the projects I am working on currently. I did send the project file to @tpbradley but never heard back.


(Markus Frieauff ) #10

Things are getting worse. Now I don’t even have to switch to preview. Just ticking a box in the meta section suffices to create a new empty console window. Have a look:
https://www.dropbox.com/s/0kcxhjyn72oq7a3/gettingworse.mov?dl=0


(Doug Bennett) #11

The video above doesn’t work.

@dan or @tpbradley will need to have a look at the project file.


(Markus Frieauff ) #12

thanks. I don’t know why it did the first time. The link is almost the same. Anyhow, copying it in a new window should work.


(Tom Bradley) #13

Ok, I think I know what the issue is. In Safari do you have the “Automatically Show Web Inspector for JSContexts” under Develop -> [machine name] checked? Does it help if you uncheck it?


(Markus Frieauff ) #14

Yeeeees!!! That solved it! Thanks so much, Tom @tpbradley! I had never even noticed the “machine name” section…might be worth noting that for other non-geeks like me…Thanks again!


(Tom Bradley) #15

No worries @therealmf, glad I could help! :smiley:


(Doug) #16

Yes solved it for me too, Iv’e ben developing for donkey’s years and never noticed the machine name section lol

Thanks @tpbradley :slight_smile:


(Dan) #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.