RapidWeaver Multi Lingual (RWML) Extra-Content wird nicht übersetzt


(Jan Andree) #1

Ich habe ein Problem mit RapidWeaver Multi Lingual (RWML) von toosj media. Mein contant wird richtig übersetzt und dargestellt aber die Extra-Contant Bereiche werden nicht übersetzt oder doppelt dargestellt. Muss man dort noch mal extra was einstellen?
Auf meiner Seite stelle ich oben das stack RWML Enclosure DE. Danach RWML Content DE in diesem Teil die komplette Seite mit alles stacks auf deutsch. Danach RWML Content EN in diesem Teil alle die komplette Seite mit allen stacks auf english. Bis auf die Bausteine in den ExtraContent funktioniert auch alles.


(Michael M.) #2

Es kann Konflikte mit anderen Stacks geben, habe ich bei RWML schon gehabt.

Mach mal in deinem Projekt eine Testseite, in der du nur Sprachinhalte zusammen mit RWML anlegst. Damit überprüfst du, ob deine Konfiguration überhaupt stimmt. Wenn es funktioniert, geh zurück in die nicht funktionierende Seite und suche den Stack, der nicht mit RWML zusammenarbeitet.


(Jan Andree) #3

Bei mir werden alle ExtraContent Bereiche 1-4 nicht übersetzt die sich auf der Seite im RWML stack befinden… alles andere wird übersetzt. Ich habe eine Antwort bekommen vom support bekommen… Könnte mir die einer Übersetzen/Erklären?

Hi Jan,

This is expected behaviour based on the usage of the stacks since EC stacks are moved to a different location on the page at “runtime”: http://support.tsooj.net/customer/en/portal/articles/434377-can-i-use-rwml-content-inside-extra-content-area-s-

_Hope this helps. _
_Best regards, _
Joost

Supportseite:

Can I use RWML content inside Extra Content Area’s?

The RWML system is compatible with the Extra Content system, note
that you should place for example (a) RWML Content (stack) inside an
Extra Content stack and not the other way around.

Why can’t I place the Extra Content stack inside an RWML Content stack?
The Extra Content stack’s content is removed at page load and so no
longer contained inside the RWML Content stack. Besides that it is best
to use a single Extra Content stack for each Extra Content Area that you
would like to use.

Im download war eine rwml enclosure stack datei…


(Michael M.) #4

Zusammengefasst: Du musst im ExtraContent-Bereich einen RWML Content Stack platzieren und nicht umgekehrt.

Den Download-Link nimm bitte mal aus deinem Post heraus - ich kann mir nicht vorstellen, dass Joost den hier sehen will.


(Jan Andree) #5

Vielen Dank!!! Ich werde berichten.


(Jan Andree) #6

Funktioniert leider immer noch nicht. Die EC-Bereiche werden übersetzt aber tauchen auf der übersetzten Seite zweimal auf. Einmal im content (übersetzt) und dann noch mal im EC aber dort nicht übersetzt.


(Jan Andree) #7

Irgendwas stimmt auch nicht. Selbst wenn ich alle Übersetzungen Englisch raus nehme aus der Seite und die Seite im Menü übersetzen lasse kommt ein stack mit Bild und Text. Habe die Seite mal Joost geschickt.


(Jan Andree) #8

Man kann wohl ExtraContent Bereiche übersetzen lassen. Diese dürfen aber nur einmal auf einer Seite vorkommen sonst stören sich diese. Das verstehe ich nicht nur zum Teil. Ich habe einen ExtraContent 1 in Deutsch. Jetzt will ich diesen in Englisch. Dann muss man doch zwei ExtraContent Stacks mit Bereich 1 markieren und diese jeweils in RWML DE und RWML EN einbauen. Dann hat man doch schon zwei ExtraContent Bereiche mit dem gleichen Wert 1!?


(Michael M.) #9

Der ExtraContent ist nur der Container für den Inhalt. Und je nach Seitenaufruf wird einmal der eine oder der andere Inhalt angezeigt. Das läuft aber nicht über unterschiedliche Container, sondern über Skripte


(Jan Andree) #10

Es funktioniert! Puh… Danke für die Tipps!

also man baut eine Seite so auf:
RWML Enclosure oben - extracontent1 stack in diesen steckt man den rwml content de UND den rwml content en - danach gehts normal weiter mit rwml content de… rwml content en und so weiter.

also in die extracontent bereiche kommen beide sprachen rein so das man die bereiche nicht doppelt vergiebt.


(Michael M.) #11

Genauso würde ich das machen


(Jan Andree) #12

hat einer noch einen Tipp wie ich statt EN DE in die Navigation eine kleine Flagge bekomme?
Ich habe es mit einem link als Seitenname auf das Flaggenbild probiert:
<img src="http://www.linkzumbild.de/bilder/flag_de.png" alt="deutsch“>
die Flagge ist dann in der Navigation, aber wenn man drauf geht übersetzt er das englische nicht mehr ins deutsche…


(Michael M.) #13

Soweit ich mich erinnere, ist unter den Demos von Tsooj eine Beispielsdatei dabei.

Ansonsten geh vor wie bei den Texten: Zwei RWML-Content-Stacks, einer DE, der andere EN und dort jeweils einen Image-Stack mit einer Flagge einsetzen


(Jan Andree) #14

Im Video auch nur mit DE EN in der Navigation. Im Content-Bereich geht das gut mit den Flaggen, wie du es beschrieben hast. Aber würde die Flaggen gerne in der Navi haben.


(Michael M.) #15

Du kannst das nach dem gleichen Muster machen, wie Tsooj das in seiner Demo gemacht hat. Er hat dort Textlinks (EN / NL) in die Navigation gesetzt - die müsstest du themeabhängig durch Bildlinks ersetzen


(Jan Andree) #16

ok das habe ich auch… nun hoffe ich die letzte Frage:
Habe die Page Namen mit <span lang=DE>Seitenname</span><span lang=EN>page</span> beschieben. So steht es auch bei Tsooj. Läuft auch in der Desktop Ansicht sehr gut aber in der Mobil und Pad Ansicht stehen dann beide Sprachen in der Navigation. Liegt dann wohl am Theme… Eine Idee wie ich das weg bekomme?