RWML - Short Text - Problem with German and Italian letters

If You have a look at the page in German or Italian, all the issues of ü, ä, é, à, ß and so on present in ‘RWML short text’ are substituted by strange characters.

further down, the RWML Wrapper stack performs its duty correctly.

Am I doing something wrong or is there a chance of incompatibility between the theme and the stack? (same problem with Firefox, Safari or whatever; all pages are unicode and the problem is still present even if I change to western)
Can You suggest a work around that does not mean change all “short text” to “wrappers”?

Thank You

First off, the font you use must include all the characters that you need. That said, I don’t see the issue you are talking about (Safari).

Hello Andrea,

I see the issues on your otherwise beautiful site. First block has problems with German Umlauts etc. I use RWML a lot but never came across this problem. This said, I do Dutch-French-English sites, where I use typos as ü, ï, … as well. Normally you set a RWML Base and RWML Wrapper. Are you sure the german Text stack is in the RWML Wrapper. Multi language sites can get complicated on screen sometimes, it can happen a certain Text ‘falls’ out of the Wrapper.

If not, maybe this is a question for @willwood since he took over RWML Stack.

Good luck,


Correction: RWML is Will Woodgate’s stack (taken over from Tsooj Media).

EDIT: Please, disregard this post, since the wrong reference (Joe Workman) has been now corrected.

1 Like

@Rovertek Sorry, you’re right. I bought it from Tsjool and forgot it was taken over by Will Woodgate.

I corrected that since some people might search for the same issue

1 Like

@sandokandrea – You should use UTF-8 encoding (not Western).

How do you type/place the umlauts in your text?

Thank You @Rovertek , I’m glad that somebody does not have the problem. That simplifies the issue or shift it somewhere else.
The font does have the complete character set. Thank You for the hint.

I think… I remember that I had to change some browser settings… I have to fetch back the memory.

Well… I actually noticed as well. The part of the site in the Wrapper does not have any problem. The part of the site in the simple text does.
No, I’m working with RWML Since 1.0 or 1.1 release and I’m pretty sure that the text is in the right container, but thank You for the hint. And thank You for the compliment!!

I tried several ways.
First thing: it does not affect the text in the wrapper but just the text in the ‘short text’ stack.

I tried as “ü”, I tried as “&#_252;” and as “&u_uml;” (without the underscore) as well. No success.
In the menus it works without problems. Just in the ‘short text’ stack.

I’ve just made a test. If I setup safari as standard code ‘Unicode (UTF-8)’ the problem is solved.
(the whole site is UTF-8 coded, but switching it to Western latin does not solve the problem)

But this is not the solution: I should tell the customers to change the standard code for their browser to Unicode. This is not acceptable.

I’ll check later on other sites I’ve made, maybe it is a theme related issue, not just RWML. I’m using Reservation from Brandon Lee on this site

Hi Andrea,
which version of RWML are you using? The current version is 2.3 (see screenshot). Since Will Woodgate took over the stack from Tsooj he did a lot of good stuff to it. Maybe the error would be gone if you’d use the latest version of RWML?
Another thing to consider: you are using a very old theme which is not supported anymore for several years now (BLT has been quiet for years as far as I remember). Maybe this could also be the reason for some thing not working as they should…

1 Like

Hi @sandokandrea ,

Recent versions of RWML do not change character encoding. I’ve not seen anything in legacy versions of the RWML stack to suggest that these changed character encoding either. So I’m not sure that’s the problem here.

Most of the time, you never need to change the encoding of your website away from UTF-8. It’s one of those settings you should not meddle with unless you are absolutely certain you know what you are doing! Only if you were putting together a very specialist website, would you consider carefully changing encoding away from UTF-8, to something else.

Most tutorials that teach you how to hand-code websites always say to use UTF-8. That seems to be the predominant character encoding used for most websites.

I would suggest that you go back to your RapidWeaver site settings and change the page encoding back to UTF-8. Republish the website, clear your cache, and see if things look any better. When you look at the page source code, you will be able to see the character encoding declaration set at the top, in the head section.

Instead of saying this:

<meta charset="ISO-8859-1" />

It should say:

<meta charset="UTF-8" />

I fail to understand the comment about asking website users to change the encoding in their web browsers. The fault appears to be with the website, not the web browser a person is using!

Please don’t traumatise your website users into trying to change complicated settings that are of no relevance to them or bombard them with technical jargon. People hate it, and nine times out of ten, they’ll just click away to another website…

To my knowledge, themes do not set character encoding. This is not something I do in any of my own RapidWeaver themes. It’s RapidWeaver that does this, based on what you’ve configured the character encoding as in your site settings.

I don’t have RapidWeaver in front of me currently, but it is in General Settings or the first tab of the Page Inspector? Someone else on here might be able to confirm where you can put your website back to UTF-8.

RWML v1 is no longer actively developed or supported. In the fullness of time, you may wish to consider upgrading to RWML v2, which has been available for a couple of years.


Hello @RapidBase , I’m using Version 2.3.0 of RWML and I think it is gorgeous working.
I was thinking (and fearing) as well that the problem is rather in the Theme than in the rest of the components. I have to dig into that.

1 Like

Hello @willwood, thank You for Your long answer.

I was using RWML since version 1.1. Now I’m at 2.3 and happy of the improvements.
I corrected that change in the charset back to “UTF-8” but this did not solve the problem.
I’d never ask the user to change the encoding, no way to do that, they would switch away from my site

This gave me the hint to check some inside the coding of the web page.

  • any text in the RWML-wrapper changes the “ü” into “&u_uml;” (without underscore)
  • any text in the RWML-short text stays as “ü”, is not changed into “&u_uml;” (without underscore)

During rendering on the web page the “ü” is changed to ü and the “&u_uml;” (without underscore) into “ü”

Wait my next post: problem solved

Problem solved.

Thanks to @willwood hint, I started playing around with the only issue I had of the charset in the web pages.
It was in the head, on line 16. I moved it to line 1 and then the web page was OK.

I do not have any clue why, but it is solved. That’s the important point.

Thanks to all of You for the gorgeous support and the very good suggestions!!

(luckily I still do not need to rebuild the web page on a new theme, that is a great relief)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.