Realmac Blog RSS Feed Reposting Continuously

I’m subscribed to the Realmac official blog RSS feed, and over the past few days, it’s been going bezerk republishing the same most recent articles over and over again.

Not really a support thing, but something for Team RM to be aware of, though I secretly hope it has something awesome to do with RW9 and the built in blog plugin.

1 Like

The blog does not use the built in blog plugin 🤷

Tagging @dan

Odd, I’m using Alloy from @Elixir at the moment, we have been updating our website a lot recently, but I’m not sure why it keeps refreshing the RSS feed.

We did enable “pretty URL’s” recently so perhaps that triggered it :thinking:

Any ideas @Elixir ?

I’ll take a look when I’m back in the office Monday. :+1:

@Elixir Thanks man, I’m still wondering if it was just the change we made (switching on Pretty URL’s). I’ll keep an eye on it myself.

Hmm, adding it to my own RSS reader, there does seem to be an issue (see screen recording). Although the XML looks correct at first glance.

1 Like

Like I mentioned, I’ll take a look at this tomorrow when I’m back in the office and see where problem might be. :+1:

1 Like

@dan Can you let me know what specific version of Alloy you’re currently using live on your site for the blog?

It’s Alloy 3.1.0 :+1:

@dan Thanks. I published a test here in v3.1.0 using a setup like you described you’re using, but have not gotten the same results as I’m seeing on your blog’s RSS feed. That said, I’ve made some adjustments nonetheless to improve the lastBuildDate for the feed, which might help your situation. I’m going to look at it a bit more tomorrow too before I send you a beta to test. Any chance you could email me your project file so I can look it over? If you can, send me a copy of your posts folder from your server too. It’ll give me something to test against to make sure I’m matching your setup.

@dan Just checking in to see if I can get a copy of that project file and the posts folder so I can run a few tests.

Wasn’t around today as it’s a Bank Holiday here in the UK. Will sort it out tomorrow and send it over.

Awesome. Sounds good. Just wanted to follow up. :+1:

Thanks man, just sent you an email with the project, files, and links attached :+1:

Got it in the inbox. Thanks. Will have a look and see what I see.