Blog display bug - related to upload issue with feed.xml

blog

(Neil Beaver) #1

Hello. I’m having a very strange issue with my blog page. One of the links in my menu has a submenu which drops down when you hover over it. When my blog page loads, it displays this submenu and there is no way to make it disappear, not even reloading the page or restarting the browser.

This seems to be related to a problem that occurs when I publish my site. If I have updated the blog page, the publishing tends to get stuck on the file feed.xml. This started to happen recently, at exactly the time this weird display bug started.

I’ve tried deleting feed.xml and re-publishing. When I first had this issue, that seemed to solve it. But now the problem has returned and it doesn’t matter what I do I can’t get this issue to go away.

I don’t really know how to begin troubleshooting it, so any help would be much appreciated.

I’m using the MarketIt Theme from Realmac Software. No other plugins or stacks or anything else that I’m aware of.


(Greg Schneck) #2

Do you have a url so we can see your issue? Are you using the built-in RW blog? Do you really want the “feed.xml” (rss xml file)


(Neil Beaver) #3

Thanks for your reply. Yes, it’s the built in RW blog.

The URL is: http://www.robosoul.co.uk/blog/page0.php

I’ve been assuming that I want the feed.xml file, but I don’t know whether or not anyone’s actually following it. Is there a way to check?


(Greg Schneck) #4

If you use Google tracking or other tracking you could setup tracking for clicks on the url.

You can test if the xml file is related to upload problem by turning of the RSS feed and trying your upload. You say “publishing gets stuck on the xml” file. Do you get an error? If so what it is.


(Greg Schneck) #5

It appears your xml file is not being uploaded. When I click your RSS link I get a 404 Page Not Found error. Export your site locally and see if you get your xml file. Here’s the RSS link as it is on your site so look in your “blog” > “files” folder when exported.

http://www.robosoul.co.uk/blog/files/feed.xml


(Neil Beaver) #6

Thanks again. That would be because I deleted the feed.xml file from the server. The first time I had this problem, it was copying multiple feed.xml files to the server and I had to delete them all to resolve the problem. Now it doesn’t seem to make any difference if I delete it. The publish still gets stuck on that file and doesn’t complete.

I’ve now turned off the RSS feed. Publishing gets stuck on a different file, one of my blog posts (nothing unusual about it as far as I can tell, nothing has changed in it recently).

The publishing error I’m getting at the moment is this:
Couldn’t upload to your FTP server

Clicking on the info button reveals this:
Timeout was reached. URL: ftp://ftp.robosoul.co.uk

When I go to the publishing settings and perform a test I get this:
Connection test successful


(Neil Beaver) #7

I should add: it seems that my blog page is not completing its loading process. In Safari, the stop button never changes to a reload button. In Chrome, the spinny thing keeps on spinning. In Firefox, the bouncy ball thing keeps on bouncing.


(Greg Schneck) #8

Try exporting your entire site to a local folder and see if that completes.


(Neil Beaver) #9

Yes, it completes and the site runs locally. Except for the blog page, which displays as HTML. It appears to be complete, in the sense that there is an tag at the end of the document.


(Greg Schneck) #10

To get your site fully working for now export to local folder and use ftp to upload to your server.

This is sounding like an issue with RW publishing. Have you tried different publishing settings? Turn Backup off (if on) and try different “Connection” and “Mode” settings in your Publish setup.


(system) #11

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.