RESOLVED Can't save my project files anymore


(Franz Rathmair) #1

Hello fellow weavers,

since I upgraded from El Capitan to Sierra I have massive problems with my projects: They crash when seeking to upload as soon as I change anything in the title of a page, or change the footer from 2016 to 2017, or add another page. Now I saw that I can’t save the project … brrrr !

Any ideas where to get a handle on this?

I have tried several of the former versions, from 7.1.3 to the newest one, 7.2.2. No difference.

Franz


(Doug Bennett) #2

I don’t know what you might have going on. You said it crashes? Did it produce a report to send to RM?
Have you tried with another project? Since you said, you cannot save did you try “save as” and give a new name?

My guess would be that your project file might have gotten corrupted.


(Franz Rathmair) #3

Hi Doug,

thanks for commenting.

I have tried almost all my projects. A small test project ist the only one that functions at it should.

The others have a fatal problem as soon as I make changes to the page name, to a footer etc. As soon as I see all the pages on the lieft side get the blue dot - saving does not work anymore, nor exporting. Either it gets stuck eternally and I have to force quit it, or it crashes on export.

My strategy for the future as soon as I have enough time: I will start a new project with the same theme and then copy over from one of these dysfunct projects one page after another, always saving and publishing until it crashes. Then the last page must be the culprit.

It is frustrating and time consuming to fix this thing again. I had too many troubles with RW in the last year.

Thanks for your interest and help.

Franz

‌„Von allen Seiten umgibst du mich und hältst deine schützende Hand über mir.“‌ Psalm 139,5
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Jason Bostick) #4

Do you have Pluskit on those sites by any chance? That seems to have caused problems for some (and Yourhead is working on a fix/update that is in beta right now). May be completely unrelated in your case but just a shot in the dark.


(Franz Rathmair) #5

Hi Jason,

yes, I do have Pluskit in all my projects. But I have it also installed in the one test project that is functioning. I have to check how I use it there, maybe it is not used at all. But in the projects that are crashing I use it heavily.

Well, it would be great if the overhaul of PlusKit would come soon!

Franz

‌„Wir vertrauen fest auf Gottes Liebe. Gott ist Liebe und wer in dieser Liebe bleibt, der bleibt in Gott und Gott in ihm.“‌ 1.Johannes 4,16
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Doug Bennett) #6

might want to check this post out:


(Jason Bostick) #7

Yeah, if you are comfortable/interested in trying out the beta, Isaiah is hot and heavy on a new version and it might fix your problems. You may want to connect with @isaiah or Yourhead’s support email directly for more specifics.


(Isaiah Carew) #8

Updating to PlusKit 4 is probably a good idea for any RapidWeaver 7.1+ user.

But assuming a crash is something specific without any evidence is probably a tad premature.

I’d recommend starting with the crash report. When RapidWeaver crashes it generates some information and presents a little window. Clicking the “i” button will bring up reports that can be helpful to support folks in identifying the problem.

In most cases a systemic crash like this will have to be checked out by a support person. Sending them the crash reports, the rapid weaver file (the smallest one that shows the problem) and all the addons required to open the file is a good next step.

Also: focus on one problem and report the specific details of that. Saving, exporting, hanging and crashing may be related they may be unrelated too. Focus on one of those and give us all the details:

  • does it hang or crash?
  • what was the last button/menu/key you clicked?
  • what did RapidWeaver do right before the crash?
  • were there any error messages or crash reports?

Isaiah


(Franz Rathmair) #9

Hi Isaiah,

thanks so much for your reply.

I downloaded and installed PlusKit Beta - and the tests with two of my projects that used to halt when saving or crash when exporting are working again!!! Wonderful! I’ll check the others tomorrow…

I’m so grateful that you are working on PlusKit and for your help by jumping into the conversation!

Shalom greetings from Austria,
Franz

‌„Deine Güte und Liebe werden mich mein Leben lang begleiten, in deinem Haus darf ich für immer bleiben.“‌ Psalm 23,6
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Franz Rathmair) #10

Thanks, Doug, for the tip re PlusKit. I donwloaded the Beta and two of the projects I tested are working again!!!

Peace,
Franz

‌„Deine Güte und Liebe werden mich mein Leben lang begleiten, in deinem Haus darf ich für immer bleiben.“‌ Psalm 23,6
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Franz Rathmair) #11

Hi Isaiah,

yesterday (Friday) night I wrote back to you with excitement that two projects were working again with the Bete version of PlusKit that was available.

Well, tonight (Saturday) I am not so positive.

When I opened RW 7.2.2 today I saw that PlusKit had another new version, so I installed it. (Can’t find out the version number)

I worked on one project quite a bit and everything seemed to be ok. Then I closed the project. When I tried to open it the next time, it would open a blank page and then the ball started spinning. I checked with the other projects who had been functioning last night - the same.

As soon as I click on a page name in the left side the ball begins to spin. The content remains blank. With one project it works somewhat better (ending with „privat“), the problem was occurring once or twice, right now I can open it.

I have saved the protocols of the Activity Monitor from five different projects and will attach them for you.

Thanks for your help.

Shalom,
Franz

‌„Deine Güte und Liebe werden mich mein Leben lang begleiten, in deinem Haus darf ich für immer bleiben.“‌ Psalm 23,6
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Franz Rathmair) #12

Update:

Hi Isaiah,

after I had sent you my last email with the five attached analysis reports, I tried a former version of RW, 7.1.7. With that I can save and export again, which makes me happy because otherwise I couldn’t make changes.

I am encountering another problem with a slideshow from Henk Vrieselaar in the Home page of one of my projects. Since he can’t check it out until he has the new version of PlusKit (I will send him the download link for the Beta version) I will have to find a workaround or simple solution until that time.

Anyway, thank you very much for taking on the PlusKit upgrade. I use it in all of my projects and I wouldn’t know how to do if PlusKit were not available anymore or failed to function correctly.

Have a good week!

Franz

‌„Wir vertrauen fest auf Gottes Liebe. Gott ist Liebe und wer in dieser Liebe bleibt, der bleibt in Gott und Gott in ihm.“‌ 1.Johannes 4,16
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Isaiah Carew) #13

I think there is a reasonable chance that your projects might contain infinite @import loops.

Changes to the RapidWeaver API (lazy loading) prevents us from detecting and breaking these sorts of loops in PlusKit. This means that older versions will work OK, but with new RW and new PlusKit these infinite loops cause these sorts of problems.

Did you send the activity monitor reports to our support channel? Or somewhere else?


(Franz Rathmair) #14

Hi,

thank you for your response.

I have sent the activity monitor files to RW support now.

If it is an infinite loop of PlusKit - how can I find that out and correct it? For what exactly do I need to check the project?

Thanks.

Franz

‌„Deine Güte und Liebe werden mich mein Leben lang begleiten, in deinem Haus darf ich für immer bleiben.“‌ Psalm 23,6
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Isaiah Carew) #15

If it’s a PlusKit thing then you should send the files to http://yourhead.com/support (YourHead Software took over PlusKit from Loghound last year)

I’m afraid there’s no automatic way to tell when a loop is created (if there was, then I’d use it to fix the issue) – unfortunately with RW7.1 they simply cannot be detected anymore until it’s too late.

PlusKit is still in beta and this is something we’re still actively looking for a solution for – so don’t give up hope. However I can’t make promises as so far the new features of RW 7.1 have made all obvious mechanisms for doing this infeasible.

Since you know it’s PlusKit I’d recommend an audit of how you’re using it. Which pages import which other pages. If there is a loop, it’s probably pretty obvious. If it’s not obvious – or you’re using PlusKit import so much that it’s too confusing to work out – then I’d recommend working on simplifying it. Each use of import has some impact on the performance of RW stability – keep it simple and you’ll be a happy weaver. :slight_smile:

Isaiah


(Franz Rathmair) #16

It seems I am getting more and more into a mess here.

A few days ago Henk Vrieselaar had suggested I delete the PlusKit Beta version and return to the 3.x version, which I tried. But that didn’t help. So I again installed the Beta version (which was once at least updated by you). The problem is now that PlusKit is not working anymore at all.

With the b7 version that came in today:

a) on a simple test version with just two pages the imported page is seen in preview, but when exported all I see is the @import((page)) text.
b) on my extended project it shows the @import… text already in preview.

I have another issue with RSS stacks not being loaded, but I am not sure whether that has to do with PlusKit or not.

Can it be that I am also causing problems by switching between different versions of RW? Like 7.2.2 and then 7.1.7?

Regards,
Franz


(Franz Rathmair) #17

Dear Isaiah,

I am really at the end of my wits… I have spent so many hours to solve the issues, to no avail.

The most simple project with PlusKit beta 7 is not working when exported to the server. It works in preview - when visiting the site it only shows the @import((…)).

I am attaching the project file.

Thanks for your help.

Regards.
Franz

‌„Ich komme zum Gericht“, spricht Jahwe, der allmächtige Gott, „und ich werde … gegen alle vorgehen, die … Ausländer verdrängen.“‌ Maleachi 3,5
Franz Rathmair | Mobil: +43 650 53 46 175 | Web: rathmair.eu http://www.rathmair.eu/‌‌


(Gabrielle Vickery) #18

Hi Franz, your problem sounds awful, has it now been resolved successfully?


(Franz Rathmair) #19

Hi Gabrielle,

thank you for asking. I am glad to be able to tell you that the issue has been resolved. Isaiah was tremendously helpful in fixing PlusKit and also in finding out which other plugin was messing up my project(s). Right now things are working…

Franz