Round of crashes exporting or publishing on 7.1.x (Solved 7.1.3)


(German Yague) #1

Doesn’t matter if I only use Rapidweaver Plugins, doesn’t matter how many plugins I use, no matter what version or what project, RW crashes RANDOMLY at export or publish. Isn’t anyone else seeing this? PLEASE PLEASE. I cannot work. I cannot export. Since 7.0.3 Rapidweaver is a nightmare.


(German Yague) #2

Attached an example project that crashes randomly exporting it (7.1.2), using only built-in RW addons, no external plugins. The more pages you add, the more likely the project is to crash.

http://www.germanyague.com/rw7crash.zip


(Isaiah Carew) #3

I can duplicate your results. Publishes fine the first time, but if I duplicate a few pages, then the next publish fails often.

Seems like a real bug. I can duplicate this in both 7.1.1 and 7.1.2.

I’ve sent crash reports to the devs @dan @simon


(Dan) #4

We’re aware of the issue and are working on it. It’s proving rather pesky to nail down, but we’ll get it!

Should be fixed in 7.1.3 due next week. Sorry for the disruption!


(Paul Giglia) #5

I just downloaded the new update 7.1.2, and when I try to preview my site I get this: Exception while exporting site. -[__NSCFString characterAtIndex:]: Range or index out of bounds
I’m not exporting site. No changes made from last time I opened RW and previewed. Anyone know what this is? Thanks.


(German Yague) #6

Thanks Dan, another thing in this 7.1.x update, I cannot save my (large) projects. Whenever I try to save an upgraded file (from 7) the waiting ball of macOS appears and the entire program freezes. Do I send you a copy of the project?


(Marian Wosnitza) #7

Same here. Since 7.1 and above I cannot publish our company’s website anymore.
This is dead serious. Our business is affected.
Plus, the “Save as” dialogue sucks.
It takes minutes until a window opens, you can edit the file name and save it.
Current version of RW is not usable.
PLEASE URGENTLY FIX THESE ERRORS.


(Marian Wosnitza) #8

Thanks Dan, for taking immediate action.
We are completely stuck since we cannot publish our website anymore.
Also, the “save as” dialogue does not work properly. It takes minutes until a window opens, more minutes until you can change a filename, and yet more minutes until you can save your new file. Can’t work with RW 7.1.2.
Hoping on a quick cure of the problems.


(Mathew Mitchell) #9

I don’t think you are completely stuck. Go back to RW 7.1.0:


(Jan Lagerwall) #10

Glad to hear that I’m not the only one who experiences this. It seems RW publishes fine if there are just a few pages to update, but any change that causes many updates (e.g. inserting a new page at root level or rearranging the order of pages) will definitely crash RW. I’ve tried reinstalling RW fresh as well as all plug-ins and stacks, but it improved nothing. Thanks to Mathew for suggesting going back to 7.1.0. I’ll try this, hoping that I can get working again, because it is very frustrating not to be able to update my website for several days.


(Marian Wosnitza) #11

Hi Mathew,

RW 7.1.0 produces the same crash when trying to publish.
No cure!

Best Regards,
Marian


(Marian Wosnitza) #12

Hi Mathew,

Solved the “save as” issue. This was home made - apologies!
What remains, is the PUBLISH issue: Neither 7.1.0 nor above can publish - all versions crashes right after begin of export.

Thanks for helping.
Best Regards
Marian


(Jan Lagerwall) #13

Yup, I can second that. No improvement with 7.1.0.


(C Pony Vigil) #14

Looks like many are feeling the pain or schedules…
May the force be strong in this one…
oh well waking a break and check back…
$:-(

:grinning:


(C Pony Vigil) #15

Listening to Desert Dwellers time to listen and be cool I think:ear::v::eye::massage::space_invader:


(Giorgio Zamariola) #16

Hello everybody, I posted some tests and a temporary trick here:

I hope it will help, while waiting for RW 7.1.3 coming soon.

Giorgio


(Bengt a.d.F. Moll) #17

Since upgrading to 7.1.2 RapidCart Pro Shop is exporting and exporting and exporting … in preview mode. Publishing the site crashes Rw.


(Patrick Mooney) #18

Yes I have had this same issue as have others. The only way so far, until Relamac fix it is to publish the pages by selecting one (or just a few, by holding the ‘shift key’ as you select) and ‘ctrl’ click the page for the menu to appear at the side of the selected page with ‘Publish Page’ and do this for each page (or a small number of pages at a time).

Also you can do ‘sub pages’ if it asks, depending on the number of sub pages and what on them.

Hope that’s of help.


(Dan) #19

We should RapidWeaver 7.1.3 out in the next few hours that will fix this issue, sorry for the delay!


(C Pony Vigil) #20

May the force be with you Dream big and Weave us a happy day )’(