RM8.7 wont open project file

I am running v8.7 on my Mac, all of a sudden the prog wont open any existing project files or let me start a new project.
I have tried uninstalling and reinstalling the prog but it hasn’t solved the problem.
Any advice please.

1 Like

Most of us are using RW8.7 and have been for awhile.

What happens when you try and open a project?

What happens when you try and create a new project?

What version of macOS are you using?

1 Like

I am using 8.7, sorry, missed out the full version number in my post
Everything worked fine until today, now when I try to open an existing project either by clicking on the project file in RW or by trying open it directly from finder nothing happens.
I can’t create a new project either.
I am using the latest version of Big Sur

1 Like

What happens? Does it crash, close or what?

Did you upgrade macOS since the last time? When you say the latest version what version is that?

1 Like

Nothing happens at all when trying to open a project or start a new one. I click and/or double click with no response whatsoever
I am using Big Sur 11,2,2 and I have worked with RW since updating the OS.
Incidentally I still have RW 7.5 on the Mac and that is working ok

I’m not sure what might be happening.
If you right-click on the project and select the “open with…” option does RapidWeaver 8 show up as the default option? If not does RapidWeaver 8 show up at all? If it’s there as an option will it open if you select it? And one other check is RapidWeaver 8 running from your applications folder?

Other than that my suggestion would be to contact RealMac support.

I’m not running Big Slur, but there’s a lot of folks who are without this kind of problem.

I have checked everything you suggested and still no joy. Guess I will have to try support. Thanks for your advice @nyway

Try this:

Hold down the Option key when you start RapidWeaver. A little window will pop up and give you some options for enabling 3rd party plugins, 3rd party themes, and resetting the project window location location.

Using that window disable 3rd party plugins and themes and reset the project window.

This is the fail-safe mode. If this still doesn’t work, it’s time to talk with Realmac Software support. But if it does work, it means that one of those plugins or themes is causing some trouble – and 9 times out of 10 it’s a plugin, probably something that needs to be updated.

If that seems to be the case, then you should open your RW Addons folder (Cmd-7) and remove all of the plugins in the folder. Add them back one at a time, and launch RW after each addition – but only add the ones that you’re really using right now. It’s best to leave plugins uninstalled unless you need them.

When you find the culprit, just go grab a new version from the developer. All the YourHead plugins are at: http://yourhead.com/

Just download a new version and drag it into your RW Addons folder. If you have all the latest versions and you still have a crash on launch – then:

  1. Let us know which plug-in is causing the issue
  2. Post the first page or two of the crash report here if you can
  3. Contact the developer of the plug-in for support
1 Like

I am having the same issue. My system says it wants to update stacks to 4.2.2 and then locks up. I am using MAC Big Sur with M1, but it was working this week. I am not sure if there any updates that were installed that I don’t know about.

@davisg13 - can you try just downloading the latest version from here: https://yourhead.com/stacks/download

I have the same problem. since I reboot my Mac, I cannot ope a project and I cannot make a new projectfile. I have an Macbook pro with Intel chipset. the newest Version of Mac OS X the newest rapid weaver and since yesterday the newest stack version.
Help me urgently because now I cannot work on my project earning money with this software!!!

This stacks version did not help

Hi Linda,

I posted very detailed step-by-step instructions on what to try to get past a “nothing works” situation above. Here’s a link to the steps: RM8.7 wont open project file

It would be helpful if you could say what happens when you tried it. The more details you can provide about what’s happening, the more I’ll be able to help.


I am running Big Sur version 11.3 [20E5186d] as a Beta tester for Apple alongside RapidWeaver 8.7 with freshly installed Stacks.
The only issue I found is trying to use the simulate feature during updating web sites, is the simulate option shows a blank screen unless the site is examined firstly using the view option. It is then fine.
I am not sure what is causing this but with a workaround easily accessible, it doesn’t worry me.
Could be a memory issue in my Mac or an Apple issue … who knows.
Everything else, features, stack etc are fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.