Rapidweaver 7 Won't Open


(Traci L. SLatton) #1

Hello,

Rapidweaver 7 won’t open to me. When I try to start the app, the program doesn’t load a new project. Instead, it goes to a finder window. See screenshot.

Then I have to force quit RW7 as “quit” doesn’t work.

What’s going on?

Thanks,
Traci

PS I have RW8 but find it’s not terribly stable.


(Doug Bennett) #2

That’s a file open window (running RW7) If you select a file rapidWeaver 7 project file it should open fine.

Check your preferences by
Selecting the RapidWeaver Menu item:
2018-11-07_11-05-29

2018-11-07_11-08-15

Make sure the on Launch option is checked:


(Greg) #3

This is an issue I often had with RW7 after a reboot. It was looking for a file (not a project) but no indication as to what. I found that logging out and logging in again resolved the issue.

I note that has also occurred in RW8 except it does specify the file it was looking for. It also occurred after a reboot. Cannot remember now what that was unfortunately. Next time…


(Rob D) #4

Besides what’s been said already, have you tried to drag RW7 project on the RW7’s icon in Finder or in the Dock?


(Traci L. SLatton) #5

So apparently this is a Known Issue. Guru Aaron from Realmac got back to me.

Here’s the page referencing the fix:

I will say that it hasn’t been completely easy to fix, but I seem to have done so. Fingers crossed.

Many thanks!

Traci


(LJ) #6

Lots of issues can be caused by Clean My Mac. Put it in the trash where it belongs.


(Greg) #7

Just a side note. I do not have any of those utilities installed or anything like them yet it was a consistent issue after a reboot. I suspect it has something to do with how MacOS handles preference files these days.


(Traci L. SLatton) #8

It’s mystifying. I don’t use nor own Clean My Mac, and as far as I know, the only thing that happened was a reboot.


(Isaiah Carew) #9

This can happen when

  1. The app is installed somewhere it shouldn’t be.
    Just make sure you install RapidWeaver in your Applications folder of the hard drive you use to boot the machine. If you only have one hard drive, then it should be in the main Applications folder. Some people leave it in their Downloads folder – but newer versions of MacOS really don’t like that very much.

  2. The app has damaged on your hard drive.
    If you’ve recently recovered from a backup or moved your files to a new computer, then it looks like not all went well. It might be worth double checking other files. If RapidWeaver is the only app that’s having this sort of difficulty then that’s an easy fix. Just go to the main Realmac Software website, download a fresh copy, and replace the one that’s on your hard drive.

  3. Your operating system or hard drive is damaged
    If you discover that there are other things wrong on your hard drive, then the first thing to do is try to make a backup. If it fails, then at least try copying your critical data: pictures, important documents, email, etc.
    Once you have a good backup then you should go about fixing the machine – whatever that requires. Usually a complete reformat, OS reinstall, and recover data from the backup. If that all sounds too daunting, then take your machine to an apple store (make an appointment first) and have them help you do the recovery.


(Greg) #10

Unfortunately (or probably fortunately) none of these apply in my case. When I get a chance I’ll test it on the macbook. As mentioned it only happens after a reboot. Otherwise it chugs along nicely!


(Isaiah Carew) #11

Well, I’d say re-download the app anyway. I mean, why not? That takes like 30 seconds and eliminates that possibility.

But if that doesn’t fix it then I’d say #3 is probably most likely. This really shouldn’t be happening. If it is, it’s an indication that something is pretty wrong with the operating system at a pretty fundamental level.

If my mac was doing this (and yes, it has done similar things) I’d double check my backups are up-to-date and working well, then format the drive. I wouldn’t even wait a minute.

If that’s too daunting, I’d really consider having a professional look at it. But, yeah, re-download the app first thing.


(Greg) #12

I’ll have a play the next time I need to reboot the machine. Since there is no indication of issues in the console log or disk first aid I’ll leave a system rebuild to another day.

I did test it on my macbook but it worked fine after a reboot.

Maybe my imac is worried about it’s upcoming 10th birthday…:grinning: